Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.57/7: Рейтинг темы: голосов - 7, средняя оценка - 4.57
Niyazka
0 / 0 / 0
Регистрация: 05.02.2013
Сообщений: 7
1

Права доступа!

05.02.2013, 20:02. Просмотров 1295. Ответов 11
Метки нет (Все метки)

Как пользователям запретить изменять, перемещать, помечать на удаление элемент справочника "Номенклатура" с видом "Услуга", если дата последнего изменения элемента меньше текущей даты.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
05.02.2013, 20:02
Ответы с готовыми решениями:

Права доступа в 1С 8.2
Подскадите, пожалуйста, как можно ограничить права доступа на справочник "Сотрудники", чтобы из...

Права доступа в 1С УТ
Добрый день! 1С УТ 10.3, Существует ли возможность закрыть возможность редактирования каких-то...

Права доступа
Можно ли запретить пользователю изменять документы, созданные другим пользователем? и в документе...

Права доступа к 1С
Доброго вечера уважаемые форумчане. Имеем 2003 сервер терминала, юзеры подключаются по удалённому...

Права доступа к документам
Хм, нужно такую штуку написать, типа справочника прав, где прописуеться пользователь - он же...

11
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
05.02.2013, 20:25 2
Цитата Сообщение от Niyazka Посмотреть сообщение
Как пользователям запретить изменять, перемещать, помечать на удаление элемент справочника "Номенклатура" с видом "Услуга"
Необходимо использовать RLS.

Цитата Сообщение от Niyazka Посмотреть сообщение
если дата последнего изменения элемента меньше текущей даты
Такую информацию по умолчанию 1С не хранит, так что придется еще и доработать сам справочник.
1
Niyazka
0 / 0 / 0
Регистрация: 05.02.2013
Сообщений: 7
05.02.2013, 21:09  [ТС] 3
Хм, хотелось бы без переработки самого справочника. Может есть какой то механизм?
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
05.02.2013, 22:31 4
Цитата Сообщение от Niyazka Посмотреть сообщение
Хм, хотелось бы без переработки самого справочника.
Не получится.

Цитата Сообщение от Niyazka Посмотреть сообщение
Может есть какой то механизм?
Нет.

А зачем вообще такие сложности?
0
Niyazka
0 / 0 / 0
Регистрация: 05.02.2013
Сообщений: 7
06.02.2013, 09:02  [ТС] 5
Да не мне эти сложности нужны, а методистам.А конфу изменять не хочется и так много доработок в ней, потом обновлять одни мучения.
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
06.02.2013, 20:06 6
Подпиской на событие.
1
SoloWay
25 / 25 / 6
Регистрация: 26.09.2010
Сообщений: 291
08.02.2013, 14:43 7
Побалутйесь с ролями в конфигураторе
0
duk337
08.02.2013, 20:09
  #8

Не по теме:

Цитата Сообщение от SoloWay Посмотреть сообщение
Побалутйесь с ролями в конфигураторе
... и вешайтесь при обновлении

0
SoloWay
25 / 25 / 6
Регистрация: 26.09.2010
Сообщений: 291
10.02.2013, 16:30 9
Цитата Сообщение от duk337 Посмотреть сообщение
... и вешайтесь при обновлении
Если сделать грамотно то все будет в порядке
0
Niyazka
0 / 0 / 0
Регистрация: 05.02.2013
Сообщений: 7
10.02.2013, 21:28  [ТС] 10
Может через главную обработку событий попробовать!?
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
10.02.2013, 21:51 11
Цитата Сообщение от Niyazka Посмотреть сообщение
Может через главную обработку событий попробовать!?
Простите что вмешиваюсь в тему, но позвольте узнать? Что такое главная обработка событий ?

Добавлено через 20 минут
Цитата Сообщение от duk337 Посмотреть сообщение
Подпиской на событие.
Попробую расписать что хотел сказать вам duk337

1. Создаем новую РОЛЬ (например: запретить_что_то_делать_с_моей_номенклатурой) не даем ей прав ни на какой объект метаданных
2. Создаем общий модуль (например: МойОбщийМодуль) описываем в нем процедуру
1C
1
2
3
4
5
6
7
8
Процедура МояПроверкаНаДоступностьЗаписиНоменклатуры(Объект, Отказ) Экспорт
   Если РольДоступна("ПолныеПрава") Тогда //Админ, уходим из процедуры
      Возврат;
   КонецЕсли;
   Если РольДоступна("запретить_что_то_делать_с_моей_номенклатурой") Тогда //А тут пришел наш пользователь, отказ в записи
      Отказ = Истина;
   КонецЕсли;
КонецПроцедуры
3. Создаем подписку на событие. В Источник указываем наш справочник НОМЕНКЛАТУРА. Событие - ПередЗаписью, Метод - Наша только что описанная процедура!

Готово! Теперь если юзеру установить нашу добавленную роль, он ничего не сможет сделать с номенклатурой! (Не распространяется на ПолныеПрава)
Я думаю duk337 хотел подчеркнуть что такая реализация ни как не повлияет на обновления! В отличии если править типовые роли - которые будут слетать чуть ли не при каждом обновлении!

P.S. А вот условие на дату изменения и на то что это услуга попробуйте придумать сами!
1
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
11.02.2013, 19:25 12
Цитата Сообщение от duk337 Посмотреть сообщение
Подпиской на событие.
Цитата Сообщение от Niyazka Посмотреть сообщение
Может через главную обработку событий попробовать!?
Вид сбоку, что ли?

Добавлено через 1 минуту
Цитата Сообщение от Dethmontt Посмотреть сообщение
Попробую расписать что хотел сказать вам duk337
Спа-си-бо!
0
11.02.2013, 19:25
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
11.02.2013, 19:25

1с - права доступа суперпользователя
Здравствуйте читающие! Появилась необходимость выполнения кода и запроса от имени пользователя,...

Права доступа пользователям
Есть один документ - рис. Возможно ли в этом документе сделать так, чтобы одна группа...

Права доступа в ТиС9.2 1с7.7
В базе реально используется 6 документов Права доступа на них абсолютно одинаковые, но на документ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru