Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.58/12: Рейтинг темы: голосов - 12, средняя оценка - 4.58
Augusto
70 / 70 / 1
Регистрация: 18.12.2012
Сообщений: 390
1

Не выводится область в печатной форме

02.03.2013, 13:28. Просмотров 2375. Ответов 5
Метки нет (Все метки)

Сделал внешнюю печатную форму АктОбОказанииУслуг (переделал с типовой). Добавил туда область "Доверенность".
Заполняю, вывожу. Выводится все, кроме добавленной области. Где косяк подскажите, плиз.
Код внесенных изменений:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
//Заполнение доверенности---------------------------------------------------------------------------
 
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   ЗначенияСвойствОбъектов.Объект,
        |   ЗначенияСвойствОбъектов.Свойство,
        |   ЗначенияСвойствОбъектов.Значение
        |ИЗ
        |   РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
        |ГДЕ
        |   ЗначенияСвойствОбъектов.Объект.Ссылка = &ТекущийДокумент";
 
    Результат = Запрос.Выполнить();
 
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    
    ОбластьМакета = Макет.ПолучитьОбласть("Доверенность");
     
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Если ВыборкаДетальныеЗаписи.Свойство.Наименование = "ДоверенностьНомер" Тогда 
         ОбластьМакета.Параметры.ДоверенностьНомер = ВыборкаДетальныеЗаписи.Значение;
        ИначеЕсли ВыборкаДетальныеЗаписи.Свойство.Наименование = "ДоверенностьДата" Тогда
         ОбластьМакета.Параметры.ДоверенностьДата = ВыборкаДетальныеЗаписи.Значение;
        ИначеЕсли ВыборкаДетальныеЗаписи.Свойство.Наименование = "ДоверенностьВыдана" Тогда
         ОбластьМакета.Параметры.ДоверенностьВыдана = ВыборкаДетальныеЗаписи.Значение;
        ИначеЕсли ВыборкаДетальныеЗаписи.Свойство.Наименование = "ДоверенностьЧерезКого" Тогда
         ОбластьМакета.Параметры.ДоверенностьЧерезКого = ВыборкаДетальныеЗаписи.Значение;
        КонецЕсли;
    КонецЦикла;
    ТабДокумент.Вывести(ОбластьМакета);
 
//--------------------------------------------------------------------------------------------------
0
Миниатюры
Не выводится область в печатной форме  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
02.03.2013, 13:28
Ответы с готовыми решениями:

По печатной форме
Добрый день! Есть вот такой код: ЗапросПоТоварам1 = Новый Запрос();...

Ошибка в печатной форме счета
Сделал ВПФ счет на оплату. Выскакивает ошибка:...

Вывод заголовка в печатной форме
Привет, товарищи! Делал внешнюю печатную форму к документу "Зарплата к выплате". Там всё простенько...

1с 8.2: Разбивает Строки В Печатной Форме Накладной
Добрый день! Нужна помощь профессионалов по такому вопросу: Платформа 1С:Предприятие 8.2...

Дополнительные реквизиты документа в печатной форме 8.2 УТ 11
К документу ЗаказПоставщику сделана внешняя печатная форма. В документе имеется дополнительный...

5
Xomych
828 / 632 / 105
Регистрация: 01.11.2012
Сообщений: 2,318
02.03.2013, 13:35 2
ТабДокумент, где определяется, код можно?
0
sonatto
02.03.2013, 13:59
  #3

Не по теме:

Цитата Сообщение от Augusto Посмотреть сообщение
ТабДокумент.Вывести(ОбластьМакета)
а поговорить? а поцеловать? а показать?

0
Augusto
70 / 70 / 1
Регистрация: 18.12.2012
Сообщений: 390
02.03.2013, 19:24  [ТС] 4
1C
1
2
3
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_Акт";
    Макет       = ПолучитьМакет("Акт");
Добавлено через 44 секунды
Цитата Сообщение от sonatto Посмотреть сообщение
а поговорить? а поцеловать? а показать?
ржу не могу...Петросян отдыхает

Добавлено через 2 часа 39 минут
Вот вся обработка
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
  Перем мВалютаРегламентированногоУчета Экспорт;
 
 
 
 
Функция Печать() Экспорт
    
    ДопКолонка = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
    Если ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
        ВыводитьКоды    = Истина;
        Колонка         = "Артикул";
        ТекстКодАртикул = "Артикул";
    ИначеЕсли ДопКолонка = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Код Тогда
        ВыводитьКоды    = Истина;
        Колонка         = "Код";
        ТекстКодАртикул = "Код";
    Иначе
        ВыводитьКоды    = Ложь;
        Колонка         = "";
        ТекстКодАртикул = "Код";
    КонецЕсли;
 
    Если ВыводитьКоды Тогда
        ОбластьШапки  = "ШапкаСКодом";
        ОбластьСтроки = "СтрокаСКодом";
    Иначе
        ОбластьШапки  = "ШапкаТаблицы";
        ОбластьСтроки = "Строка";
    КонецЕсли;
 
    ЗапросШапка = Новый Запрос;
    ЗапросШапка.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);
    ЗапросШапка.Текст =
    "ВЫБРАТЬ
    |   Номер,
    |   Дата,
    |   ДоговорКонтрагента,
    |   ДоговорКонтрагента.РасчетыВУсловныхЕдиницах КАК РасчетыВУсловныхЕдиницах,
    |   Контрагент КАК Получатель,
    |   Организация КАК Поставщик,
    |   Организация,
    |   СуммаДокумента,
    |   ВалютаДокумента,
    |   УчитыватьНДС,
    |   СуммаВключаетНДС
    |ИЗ
    |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";
    Шапка = ЗапросШапка.Выполнить().Выбрать();
    Шапка.Следующий();
 
    ЗапросУслуги = Новый Запрос;
    ЗапросУслуги.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);
    ЗапросУслуги.УстановитьПараметр("Курс",            ЗаполнениеДокументов.КурсДокумента(ЭтотОбъект,      мВалютаРегламентированногоУчета));
    ЗапросУслуги.УстановитьПараметр("Кратность",       ЗаполнениеДокументов.КратностьДокумента(ЭтотОбъект, мВалютаРегламентированногоУчета));
    
    ЧастьЗапросаДляВыбораСодержанияУслуг = ФормированиеПечатныхФорм.ПолучитьЧастьЗапросаДляВыбораСодержанияУслуг("РеализацияТоваровУслуг");
    
    ЗапросУслуги.Текст =
    "ВЫБРАТЬ
    |   Номенклатура КАК Номенклатура,
    |   ВЫРАЗИТЬ(Номенклатура.НаименованиеПолное КАК Строка(1000)) КАК Товар,
    |   Номенклатура." + ТекстКодАртикул + " КАК КодАртикул,
    |   Количество,
    |   ЕдиницаИзмерения  КАК ЕдиницаИзмерения,
    |   Цена * &Курс / &Кратность КАК Цена,
    |   Сумма * &Курс / &Кратность КАК Сумма,
    |   СтавкаНДС,
    |   СуммаНДС * &Курс / &Кратность КАК СуммаНДС
    |ИЗ
    |   Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |   И
    |   РеализацияТоваровУслуг.Номенклатура.Услуга = Истина
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |   " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
    |   " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
    |   Номенклатура." + ТекстКодАртикул + " КАК КодАртикул,
    |   Количество,
    |   Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |   Цена * &Курс / &Кратность КАК Цена,
    |   Сумма * &Курс / &Кратность КАК Сумма,
    |   СтавкаНДС,
    |   СуммаНДС * &Курс / &Кратность КАК СуммаНДС
    |ИЗ
    |   Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |   " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
    |   " + ЧастьЗапросаДляВыбораСодержанияУслуг + ",
    |   Номенклатура." + ТекстКодАртикул + " КАК КодАртикул,
    |   Количество,   
    |   Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |   Цена * &Курс / &Кратность КАК Цена,
    |   Сумма * &Курс / &Кратность КАК Сумма,
    |   СтавкаНДС,
    |   СуммаНДС * &Курс / &Кратность КАК СуммаНДС
    |ИЗ
    |   Документ.РеализацияТоваровУслуг.АгентскиеУслуги КАК РеализацияТоваровУслуг
    |
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";
    ТаблицаУслуги = ЗапросУслуги.Выполнить().Выгрузить();
    
    // Переменные
    Проведен = СсылкаНаОбъект.Проведен;
    Дата = СсылкаНаОбъект.Дата;
    Ссылка = СсылкаНаОбъект;
    СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
    //
    Если Проведен И (Шапка.РасчетыВУсловныхЕдиницах
        ИЛИ (Шапка.ВалютаДокумента <> мВалютаРегламентированногоУчета И Дата >= '20090101000000')) Тогда
        
        Запрос = Новый Запрос;
        Запрос.УстановитьПараметр("Ссылка", Ссылка);
        Запрос.УстановитьПараметр("СчетУчетаРасчетовСКонтрагентом", СчетУчетаРасчетовСКонтрагентом);
        Текст = 
        "ВЫБРАТЬ
        |   СУММА(Хозрасчетный.Сумма) КАК Сумма
        |ИЗ
        |   РегистрБухгалтерии.Хозрасчетный КАК Хозрасчетный
        |ГДЕ
        |   Хозрасчетный.Регистратор = &Ссылка
        |   И Хозрасчетный.СчетДт = &СчетУчетаРасчетовСКонтрагентом
        |   И Хозрасчетный.СчетКт В
        |           (ВЫБРАТЬ РАЗЛИЧНЫЕ
        |               РеализацияТоваровУслугТовары.СчетДоходов
        |           ИЗ
        |               Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
        |           ГДЕ
        |               РеализацияТоваровУслугТовары.Ссылка = &Ссылка
        |
        |           ОБЪЕДИНИТЬ
        |
        |           ВЫБРАТЬ РАЗЛИЧНЫЕ
        |               РеализацияТоваровУслугУслуги.СчетДоходов
        |           ИЗ
        |               Документ.РеализацияТоваровУслуг.Услуги КАК РеализацияТоваровУслугУслуги
        |           ГДЕ
        |               РеализацияТоваровУслугУслуги.Ссылка = &Ссылка)
        |";
        Запрос.Текст = Текст;
        СуммаВзаиморасчетов = Запрос.Выполнить().Выгрузить()[0].Сумма;
        
        РасчетСуммыНДСПоСтавке =  УчетНДС.РасчетНДСвРубляхПоСтавкеДокумента(Шапка.Дата);
        
        Если НЕ СуммаВзаиморасчетов = NULL Тогда
            
            ТаблицаУслуги.Колонки.Добавить("СуммаБезНДС");
            
            МассивРаспределения = Новый Массив;
            
            Для Каждого СтрокаТовар Из ТаблицаУслуги Цикл
                
                СуммаСНДС = СтрокаТовар.Сумма + ?(Шапка.СуммаВключаетНДС, 0, СтрокаТовар.СуммаНДС);
                СуммаБезНДС = СуммаСНДС - СтрокаТовар.СуммаНДС;
 
                МассивРаспределения.Добавить(СуммаСНДС);
                СтрокаТовар.СуммаБезНДС = СуммаБезНДС;
                                
            КонецЦикла;
            
            ТаблицаУслуги.Колонки.Добавить("СуммаРублевая");
            УчетНДС.РаспределитьСуммуПоСтолбцу(МассивРаспределения, СуммаВзаиморасчетов, ТаблицаУслуги, "СуммаРублевая");
            
            Для Каждого СтрокаТовар Из ТаблицаУслуги Цикл
                
                Если РасчетСуммыНДСПоСтавке Тогда
                    //Выделение суммы НДС, Расчет суммы без НДС
                    ЗначениеСтавкиНДС = УчетНДС.ПолучитьСтавкуНДС(СтрокаТовар.СтавкаНДС);
                    
                    СтрокаТовар.СуммаНДС = ?(ЗначениеСтавкиНДС = 0, 0, Окр(СтрокаТовар.СуммаРублевая * ЗначениеСтавкиНДС/(100+ЗначениеСтавкиНДС),2));
                    СтрокаТовар.Сумма = СтрокаТовар.СуммаРублевая - СтрокаТовар.СуммаНДС;
                    
                Иначе
                    МассивРаспределения.Очистить();
                    МассивРаспределения.Добавить(СтрокаТовар.СуммаБезНДС);
                    МассивРаспределения.Добавить(СтрокаТовар.СуммаНДС);
                    МассивРаспределенныхСумм = ОбщегоНазначения.РаспределитьПропорционально(СтрокаТовар.СуммаРублевая, МассивРаспределения);
                    Если МассивРаспределенныхСумм <> Неопределено Тогда
                        СтрокаТовар.Сумма = МассивРаспределенныхСумм[0];
                        СтрокаТовар.СуммаНДС = МассивРаспределенныхСумм[1];
                    КонецЕсли;
                КонецЕсли;
                
                Если Шапка.СуммаВключаетНДС Тогда
                    СтрокаТовар.Сумма = СтрокаТовар.Сумма+СтрокаТовар.СуммаНДС;
                КонецЕсли;
                
            КонецЦикла;
            
        КонецЕсли;
        
    КонецЕсли; 
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_Акт";
    Макет       = ПолучитьМакет("Акт");
 
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначения.СформироватьЗаголовокДокумента(Шапка, "Акт");
    ТабДокумент.Вывести(ОбластьМакета);
 
    ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
    СведенияОбОрганизации    = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
    ПредставлениеПоставщика = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации, "НаименованиеДляПечатныхФорм,");
    ОбластьМакета.Параметры.ПредставлениеПоставщика = ПредставлениеПоставщика;
    ОбластьМакета.Параметры.Поставщик                = Шапка.Поставщик;
    ТабДокумент.Вывести(ОбластьМакета);
 
    ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
    СведенияОКонтрагенте     = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата);
    ПредставлениеПолучателя = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОКонтрагенте, "НаименованиеДляПечатныхФорм,");
    ОбластьМакета.Параметры.ПредставлениеПолучателя = ПредставлениеПолучателя;
    ОбластьМакета.Параметры.Получатель = Шапка.Получатель;
    ТабДокумент.Вывести(ОбластьМакета);
 
        
    
//Заполнение доверенности---------------------------------------------------------------------------
 
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.СсылкаНаОбъект);
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   ЗначенияСвойствОбъектов.Объект,
        |   ЗначенияСвойствОбъектов.Свойство,
        |   ЗначенияСвойствОбъектов.Значение
        |ИЗ
        |   РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
        |ГДЕ
        |   ЗначенияСвойствОбъектов.Объект.Ссылка = &ТекущийДокумент";
 
    Результат = Запрос.Выполнить();
 
    ВыборкаДетальныеЗаписи = Результат.Выбрать();
    
    ОбластьМакета = Макет.ПолучитьОбласть("Доверенность");
     
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Если ВыборкаДетальныеЗаписи.Свойство.Наименование = "ДоверенностьНомер" Тогда 
         ОбластьМакета.Параметры.ДоверенностьНомер = ВыборкаДетальныеЗаписи.Значение;
        ИначеЕсли ВыборкаДетальныеЗаписи.Свойство.Наименование = "ДоверенностьДата" Тогда
         ОбластьМакета.Параметры.ДоверенностьДата = ВыборкаДетальныеЗаписи.Значение;
        ИначеЕсли ВыборкаДетальныеЗаписи.Свойство.Наименование = "ДоверенностьВыдана" Тогда
         ОбластьМакета.Параметры.ДоверенностьВыдана = ВыборкаДетальныеЗаписи.Значение;
        ИначеЕсли ВыборкаДетальныеЗаписи.Свойство.Наименование = "ДоверенностьЧерезКого" Тогда
         ОбластьМакета.Параметры.ДоверенностьЧерезКого = ВыборкаДетальныеЗаписи.Значение;
        КонецЕсли;
    КонецЦикла;
    ТабДокумент.Вывести(ОбластьМакета);
 
//--------------------------------------------------------------------------------------------------   
    
    
 
    ЕстьСкидки = Ложь;
 
 
    // Вывести табличную часть
    ОбластьМакета = Макет.ПолучитьОбласть(ОбластьШапки);
    Если ВыводитьКоды Тогда
        ОбластьМакета.Параметры.ИмяКодАртикул = ТекстКодАртикул;
    КонецЕсли;
    ТабДокумент.Вывести(ОбластьМакета);
    
    ОбластьМакета = Макет.ПолучитьОбласть(ОбластьСтроки);
 
    НомерСтроки = 0;
 
    Для Каждого СтрокаТабличнойЧасти Из ТаблицаУслуги Цикл
 
        НомерСтроки = НомерСтроки + 1;
        
        ОбластьМакета.Параметры.Заполнить(СтрокаТабличнойЧасти);
        ОбластьМакета.Параметры.НомерСтроки = НомерСтроки;
        ОбластьМакета.Параметры.Товар = СокрЛП(СтрокаТабличнойЧасти.Товар);
        
        Если Шапка.ВалютаДокумента <> мВалютаРегламентированногоУчета Тогда
            ОбластьМакета.Параметры.Цена  = СтрокаТабличнойЧасти.Сумма / ?(СтрокаТабличнойЧасти.Количество = 0, 1, СтрокаТабличнойЧасти.Количество);
        КонецЕсли;
        
        ТабДокумент.Вывести(ОбластьМакета);
 
    КонецЦикла;
 
    Если ТаблицаУслуги <> Неопределено Тогда
 
        Сумма    = ТаблицаУслуги.Итог("Сумма");
        СуммаНДС = ТаблицаУслуги.Итог("СуммаНДС");
 
    Иначе
 
        Сумма    = 0;
        СуммаНДС = 0;
 
    КонецЕсли;
 
    ОбластьМакета = Макет.ПолучитьОбласть("Итого");
    ОбластьМакета.Параметры.Всего = ОбщегоНазначения.ФорматСумм(Сумма);
    ТабДокумент.Вывести(ОбластьМакета);
 
    Если Шапка.УчитыватьНДС Тогда
 
        ОбластьМакета = Макет.ПолучитьОбласть("ИтогоНДС");
        
        Если СуммаНДС <> 0 Тогда
            ОбластьМакета.Параметры.ВсегоНДС = ОбщегоНазначения.ФорматСумм(СуммаНДС);
            ОбластьМакета.Параметры.НДС      = ?(Шапка.СуммаВключаетНДС, "В том числе НДС", " Сумма НДС");
        Иначе
            ОбластьМакета.Параметры.ВсегоНДС = "-";
            ОбластьМакета.Параметры.НДС      = "Без налога (НДС)";
        КонецЕсли;
        
        ТабДокумент.Вывести(ОбластьМакета);
 
    КонецЕсли;
 
    СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
    ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
    ОбластьМакета.Параметры.ИтоговаяСтрока ="Всего оказано услуг " + НомерСтроки
                                           + ", на сумму " + ОбщегоНазначения.ФорматСумм(СуммаКПрописи, мВалютаРегламентированногоУчета);
    ОбластьМакета.Параметры.СуммаПрописью  = ОбщегоНазначения.СформироватьСуммуПрописью(СуммаКПрописи, мВалютаРегламентированногоУчета);
    ТабДокумент.Вывести(ОбластьМакета);
 
    ОбластьМакета = Макет.ПолучитьОбласть("Подписи");
    ТабДокумент.Вывести(ОбластьМакета);
    
    
 
    Возврат ТабДокумент;
 
КонецФункции // ПечатьАктаОбОказанииУслуг()
0
sonatto
62 / 60 / 0
Регистрация: 02.10.2012
Сообщений: 448
02.03.2013, 20:17 5

Не по теме:

Цитата Сообщение от Augusto Посмотреть сообщение
ржу не могу...Петросян отдыхает
у петросяна денег куры не клюют, а комуто ржачка -наверно на пиво хватает7
тута бывали - забывали ТабДокумент.показать(ОбластьМакета);


здесь нужен грамотный поступок:оставить текст мудоля только от любимой секции и добиться ее вывода а после к ней все остальное приделать: разделяй и властвуй!
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
02.03.2013, 20:23 6
Там шаблон, похоже, должен быть
типа <Доверенность от [ДоверенностьДата], выдана [ДоверенностьВыдана]>

Добавлено через 4 минуты
Совет:
1C
1
2
3
4
5
Структ=Новый Структура;
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Структ.Добавить(""+ВыборкаДетальныеЗаписи.Свойство,ВыборкаДетальныеЗаписи.Значение);
КонецЦикла;
ОбластьМакета.Параметры.Заполнить(Структ);
1
02.03.2013, 20:23
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.03.2013, 20:23

Как Вывести Заголовок В Печатной Форме
Привет, товарищи! Делал внешнюю печатную форму к документу &quot;Зарплата к выплате&quot;. Там всё простенько...

Как упорядочить строки в печатной форме
Здравствуйте, подскажите как сделать печатную форму накладной. Строки в печатной форме по выбору...

Время на печатной форме документа в ТиС 7.7
Доброго всем дня! Помогите пожалуйста вывести время проведения документа (Чек ККМ) на печатную...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.