Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
Jackshi
59 / 59 / 6
Регистрация: 16.01.2013
Сообщений: 155
1

Вн обработка, Таблица значений

28.03.2013, 16:33. Просмотров 776. Ответов 5
Метки нет (Все метки)

Доброго времени суток форумчане!

У меня такой вопрос:

При нажатии кнопки Заполнить открывается форма
1C
1
2
3
4
5
Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт
        
Форма = ПолучитьФорму("Форма");
Форма.ОткрытьМодально();
КонецПроцедуры
при нажатии кнопки на форме, Таблица значений формы заполняется Табличной частью выбранного документа
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
Процедура ВыгрузитьНажатие(Элемент)
Таб = ЭтаФорма.Товары;
Если Не ЗначениеЗаполнено(Докум) Тогда
Предупреждение("Выберите документ!",5);
Возврат;
Иначе
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ РАЗЛИЧНЫЕ
|   ЦеныАТТСрезПоследних.Цена
|ИЗ
|   РегистрСведений.ЦеныАТТ.СрезПоследних(, ХарактеристикаНоменклатуры = &ХарактеристикаНоменклатуры) КАК ЦеныАТТСрезПоследних";
        
Для Каждого Стр Из Докум.Товары Цикл
ТД = Таб.Добавить();
ТД.Номер = Стр.НомерСтроки;
ТД.Серия = Стр.ХарактеристикаНоменклатуры;
ТД.Номенклатура = Стр.ХарактеристикаНоменклатуры.Владелец;
Запрос.УстановитьПараметр("ХарактеристикаНоменклатуры", Стр.ХарактеристикаНоменклатуры);
Выборка = Запрос.Выполнить().Выбрать();
Выборка.Следующий();            
ТД.РозничнаяЦена = Выборка.Цена;
КонецЦикла;         
КонецЕсли;
КонецПроцедуры
Мне нужно при нажатии другой кнопки, все данные из таблицы значений перенеслись в документ? Помогите с решением.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.03.2013, 16:33
Ответы с готовыми решениями:

Таблица Умножения (Внешняя Обработка)
Здравствуйте, помогите пожалуйста разобраться с заданием. Требуется создать таблицу умножения...

Таблица Значений
У меня есть таблица значений которая выводит оценки студента в три колонки но первую строчку в...

Таблица Значений
Не могли бы вы мне помочь, мне нужно в отчете создать Таблица Значений которая будет считывать...

Таблица значений
Такая ситуация: Есть док Отчет кассира (фондовый). В него напихали изменений (менял не я). Теперь...

Таблица значений
Недавно начал изучать 1С, до этого учил C++ builder, если там двумерный массив так по сути...

5
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
28.03.2013, 16:49 2
оповестить и обработкаоповещения
0
Jackshi
59 / 59 / 6
Регистрация: 16.01.2013
Сообщений: 155
28.03.2013, 17:27  [ТС] 3
Если можно код пожалуйста. А то я не соображу, искал в инете и в СП. И у меня 8.1
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
28.03.2013, 22:01 4
я сейчас вдали от 1с. Давайте попросим Деда Мороза форумчан помочь. А так посмотрите в синт.поме - оно и прояснится

Добавлено через 44 секунды
Цитата Сообщение от Jackshi Посмотреть сообщение
меня 8.1
Главное - конфигурация
1
Dethmontt
Модератор
Эксперт 1С
2685 / 2465 / 428
Регистрация: 10.03.2011
Сообщений: 8,846
Записей в блоге: 1
Завершенные тесты: 1
29.03.2013, 01:18 5
НУ как вариант, создаем на форме реквизит с типом произвольный - например "ДопПараметрыформы"

Далее:
1C
1
2
3
4
5
6
7
8
Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт
   
   Структура = Новый Структура("ДокументОбъект,ИмяТЧ,ТП",Объект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта);     
   Форма = ПолучитьФорму("Форма");
   Форма.ДопПараметрыформы = Структура;
   Форма.ОткрытьМодально();
 
КонецПроцедуры
Теперь в модуле формы можно обратиться к Объекту Документ через реквизит ДопПараметрыформы
Например:
1C
1
2
3
Процедура ВыгрузитьНажатие(Элемент)
ДопПараметрыФормы.ДокументОбъект.Дата = Дата(1,1,1);
ОткрытьЗначение(ДопПараметрыФормы.ДокументОбъект);
Это в теории... (сам не пробовал) возможно наткнешься на ошибку "Ошибка передачи мутабельного значения"
Пробуй короче...
1
Jackshi
59 / 59 / 6
Регистрация: 16.01.2013
Сообщений: 155
29.03.2013, 10:31  [ТС] 6
Цитата Сообщение от duk337 Посмотреть сообщение
Давайте попросим Деда Мороза
Есть на свете Дед Мороз)

Таблэтка от Dethmontt'а работает.

Всем спасибо!
0
29.03.2013, 10:31
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.03.2013, 10:31

Таблица значений
Здравствуйте. Подскажите пожалуйста метод, который открывает таблицу значений после нажатия на...

таблица значений 7--> 8
хэлпаните. Как перенести таблицу значений (все колонки там строковые) из 7 в 8. ? Ну неполучается...

Таблица значений
Всем доброго времени суток. Как сделать чтобы таблица значений была видна в нескольких процедурах?


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru