Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/4: Рейтинг темы: голосов - 4, средняя оценка - 4.50
Keitlin16
1 / 1 / 0
Регистрация: 12.01.2013
Сообщений: 83
1

Таблица Значений

16.04.2013, 11:48. Просмотров 721. Ответов 5
Метки нет (Все метки)

У меня есть таблица значений которая выводит оценки студента в три колонки но первую строчку в Дисциплина2, УчебноеВремя и НО она пропускает не подскажете почему ?)

ОценкиДиплома = Новый ТаблицаЗначений;
ОценкиДиплома.Колонки.Добавить("Дисциплина1");
ОценкиДиплома.Колонки.Добавить("УчебноеВремя1");
ОценкиДиплома.Колонки.Добавить("Оценка1");

ОценкиДиплома.Колонки.Добавить("Дисциплина2");
ОценкиДиплома.Колонки.Добавить("УчебноеВремя2");
ОценкиДиплома.Колонки.Добавить("Оценка2");

ОценкиДиплома.Колонки.Добавить("Дисциплина3");
ОценкиДиплома.Колонки.Добавить("УчебноеВремя3");
ОценкиДиплома.Колонки.Добавить("Оценка3");

Выборка = Справочники.ВкладышДляДиплома.Выбрать();
Сч = 0; КолСтрок = 0;
Пока Выборка.Следующий() Цикл

Если Выборка.ФИО = ФИОСтудента.ФИО Тогда

Для каждого Строка Из Выборка.Дисциплины Цикл
Сч = Сч +1; КолСтрок = КолСтрок +1;
Если КолСтрок > 16 И КолСтрок < 32 Тогда
СтрТабл = ОценкиДиплома.Получить(КолСтрок - 16);
СтрТабл.Дисциплина2 = Строка.Дисциплина;
СтрТабл.УчебноеВремя2 = Строка.УчебноеВремя;
СтрТабл.Оценка2 = Строка.НО;
ИначеЕсли КолСтрок >= 32 Тогда

СтрТабл = ОценкиДиплома.Получить(КолСтрок - 32);
СтрТабл.Дисциплина3 = Строка.Дисциплина;
СтрТабл.УчебноеВремя3 = Строка.УчебноеВремя;
СтрТабл.Оценка3 = Строка.НО;
Иначе
СтрТабл = ОценкиДиплома.Добавить();
СтрТабл.Дисциплина1 = Строка.Дисциплина;
СтрТабл.УчебноеВремя1 = Строка.УчебноеВремя;
СтрТабл.Оценка1 = Строка.НО;
Сообщить(Строка.Дисциплина);
КонецЕсли;

КонецЦикла;
Прервать;

КонецЕсли;

КонецЦикла;
ОценкиДиплома.ВыбратьСтроку();
0
Миниатюры
Таблица Значений  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.04.2013, 11:48
Ответы с готовыми решениями:

Таблица значений
Всем доброго времени суток. Как сделать чтобы таблица значений была видна в нескольких процедурах?

таблица значений 7--> 8
хэлпаните. Как перенести таблицу значений (все колонки там строковые) из 7 в 8. ? Ну неполучается...

Таблица значений
Недавно начал изучать 1С, до этого учил C++ builder, если там двумерный массив так по сути...

Таблица Значений
Не могли бы вы мне помочь, мне нужно в отчете создать Таблица Значений которая будет считывать...

Таблица значений
Здравствуйте. Подскажите пожалуйста метод, который открывает таблицу значений после нажатия на...

5
E_x
63 / 63 / 0
Регистрация: 07.10.2012
Сообщений: 165
16.04.2013, 12:23 2
Быть может вопрос глупый,но все же. В отладчике смотрели? Какие данные передаются в этом месте?

Вы заполняете вот в этом месте:
1C
1
2
СтрТабл.Дисциплина2 = Строка.Дисциплина;
СтрТабл.УчебноеВремя2 = Строка.УчебноеВремя;
Логично предположить, что Строка.Дисциплина и Строка.УчебноеВремя содержат пустые значения.
0
Dethmontt
Модератор
Эксперт 1С
2684 / 2464 / 428
Регистрация: 10.03.2011
Сообщений: 8,846
Записей в блоге: 1
Завершенные тесты: 1
16.04.2013, 12:31 3
Или это условие никогда не выполняется
1C
1
Если КолСтрок > 16 И КолСтрок < 32 Тогда
0
Keitlin16
1 / 1 / 0
Регистрация: 12.01.2013
Сообщений: 83
16.04.2013, 12:32  [ТС] 4
почему не выполняется ?
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
16.04.2013, 12:36 5
Цитата Сообщение от Keitlin16 Посмотреть сообщение
СтрТабл = ОценкиДиплома.Получить(КолСтрок - 16);
Эта строчка отрабатывает на 17 итерации, а получение по индексу начинается с 0.
Вот Вы и устанавливаете значение не в 0 строке, а в 1-ой.
1
Keitlin16
1 / 1 / 0
Регистрация: 12.01.2013
Сообщений: 83
16.04.2013, 12:47  [ТС] 6
Спасибо большое )))
0
16.04.2013, 12:47
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.04.2013, 12:47

Таблица значений
Такая ситуация: Есть док Отчет кассира (фондовый). В него напихали изменений (менял не я). Теперь...

Таблица значений (в реализация 7.7)
Здравствуйте. Возник такой вопрос: есть два справочника С1 и С2, где С2 подчинен справочнику С1....

Вн обработка, Таблица значений
Доброго времени суток форумчане! У меня такой вопрос: При нажатии кнопки Заполнить...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru