Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
Augusto
70 / 70 / 1
Регистрация: 18.12.2012
Сообщений: 390
1

Печатная форма

04.06.2013, 15:08. Просмотров 1101. Ответов 5
Метки нет (Все метки)

Уже не знаю что делать. Вроде детская проблемка, устраняющаяся на раз - два, а никак не могу понять в чем подвох.
Делаю печатную форму для дока Расходный кассовый ордер в БГУшке. Надо добавить параметр ДатаДокумента.
Добавил в макет параметр (на скрине), пытаюсь присвоить ему значение, а мне выдает
{ВнешняяОбработка.Справка.МодульОбъекта(357)}: Поле объекта не обнаружено (пДатаДокумента)
ОбластьПодвал.Параметры.пДатаДокумента = пДатаДокумента;
Любой другой параметр беру - все норм. С этим какой-то бред. Что только не пробовал - всегда такая ошибка.
Если что, вот код (параметр внизу кода)
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
Функция Печать() Экспорт
    
    МетаданныеДокумента = СсылкаНаОбъект.Метаданные();
    
    Если НЕ МетаданныеДокумента.Движения.Содержит(Метаданные.РегистрыБухгалтерии.ЕПСБУ) Тогда
        Возврат Неопределено;
    КонецЕсли;  
    
    СтруктураРеквизитовШапки = Новый Структура;
    СтруктураРеквизитовШапки.Вставить("пНомер", "Номер");
    СтруктураРеквизитовШапки.Вставить("пДата", "Дата");
    СтруктураРеквизитовШапки.Вставить("пНаименованиеОрганизации", "Учреждение.НаименованиеПолное");
    СтруктураРеквизитовШапки.Вставить("пКодОКПО", "Учреждение.КодОКПО");
    СтруктураРеквизитовШапки.Вставить("Учреждение", "Учреждение");
    
    ВидПервичногоДокумента   = "";
    НомерПервичногоДокумента = "";
    ДатаПервичногоДокумента  = "";
    ОснованиеТекст           = "";
    БалансВШапке             = Ложь;
    
    Если ОбщегоНазначения.ЕстьРеквизитДокумента("ВидПервичногоДокумента", МетаданныеДокумента) Тогда
        СтруктураРеквизитовШапки.Вставить("ВидПервичногоДокумента", "ВидПервичногоДокумента");
    КонецЕсли;
    Если ОбщегоНазначения.ЕстьРеквизитДокумента("НомерПервичногоДокумента", МетаданныеДокумента) Тогда
        СтруктураРеквизитовШапки.Вставить("НомерПервичногоДокумента", "НомерПервичногоДокумента");
    КонецЕсли;
    Если ОбщегоНазначения.ЕстьРеквизитДокумента("ДатаПервичногоДокумента", МетаданныеДокумента) Тогда
        СтруктураРеквизитовШапки.Вставить("ДатаПервичногоДокумента", "ДатаПервичногоДокумента");
    КонецЕсли;
    Если ОбщегоНазначения.ЕстьРеквизитДокумента("Баланс", МетаданныеДокумента) Тогда
        СтруктураРеквизитовШапки.Вставить("пБаланс", "Баланс.Представление");
        БалансВШапке = Истина;
    КонецЕсли;
    Если ОбщегоНазначения.ЕстьРеквизитДокумента("ДатаПроведения", МетаданныеДокумента) Тогда
        СтруктураРеквизитовШапки.Вставить("пДатаПроведения", "ДатаПроведения");
    КонецЕсли;
    Если ОбщегоНазначения.ЕстьРеквизитДокумента("ВидОперации", МетаданныеДокумента) Тогда
        СтруктураРеквизитовШапки.Вставить("ОснованиеТекст", "ВидОперации.Представление");
    ИначеЕсли ОбщегоНазначения.ЕстьРеквизитДокумента("Содержание", МетаданныеДокумента) Тогда
        СтруктураРеквизитовШапки.Вставить("ОснованиеТекст", "Содержание");
    ИначеЕсли ОбщегоНазначения.ЕстьРеквизитДокумента("Основание", МетаданныеДокумента) Тогда
        СтруктураРеквизитовШапки.Вставить("ОснованиеТекст", "Основание");
    КонецЕсли;
    
    
    СтруктураШапки = ОбщегоНазначения.СформироватьСтруктуруШапкиДокументаПоСсылке(СсылкаНаОбъект, СтруктураРеквизитовШапки, МетаданныеДокумента);
    СтруктураШапки.Свойство("ВидПервичногоДокумента", ВидПервичногоДокумента);
    СтруктураШапки.Свойство("НомерПервичногоДокумента", НомерПервичногоДокумента);
    СтруктураШапки.Свойство("ДатаПервичногоДокумента", ДатаПервичногоДокумента);
    СтруктураШапки.Свойство("ОснованиеТекст", ОснованиеТекст);
    //номер выводим "как есть", без преобразований
    //СтруктураШапки.Вставить("пНомер", ОбщегоНазначения.ПолучитьНомерНаПечать(Новый Структура("Номер, Учреждение", СтруктураШапки.пНомер, СтруктураШапки.Учреждение)));
    
    пБухгалтерФИО = "";
    ТекУчреждение = Неопределено;
    Если СтруктураШапки.Свойство("Учреждение", ТекУчреждение) Тогда
        СтруктураПараметров = Новый Структура("ОтветственныеЛица");
        ПолучениеНСИ.ПолучитьДанные(ТекУчреждение, СтруктураШапки.пДата, СтруктураПараметров);
        пБухгалтерФИО = БухгалтерскийУчет.ФИО(СтруктураПараметров.ГлавныйБухгалтер, Истина);
    КонецЕсли;  
    
    пИсполнитель             = "";
    //пДолжностьИсполнителя    = "";
    пТелефонИсполнителя      = "";
    Если ОбщегоНазначения.ЕстьРеквизитДокумента("Исполнитель", МетаданныеДокумента) Тогда
        пИсполнитель = СсылкаНаОбъект.Исполнитель;
    ИначеЕсли Найти("НД_ПКО,НД_РКО,ДД_ПКО,ДД_РКО",МетаданныеДокумента.Имя) <> 0 тогда
        пИсполнитель = глЗначениеПеременной("глТекущийПользователь").ФизЛицо;
    КонецЕсли;
    
    Если ЗначениеЗаполнено(пИсполнитель) тогда
        Если ТипЗнч(пИсполнитель) = Тип("СправочникСсылка.Сотрудники") Тогда
            ДанныеСотрудника = Новый Структура("ДанныеСотрудника", Новый Структура("Должность"));
            //Если ПолучениеНСИ.ПолучитьДанные(пИсполнитель, СтруктураШапки.пДата, ДанныеСотрудника) Тогда
            //  пДолжностьИсполнителя = ДанныеСотрудника.Должность;
            //КонецЕсли;
            КИСотрудника = Новый Структура("КИСотрудника");
            Если ПолучениеНСИ.ПолучитьДанные(пИсполнитель, СтруктураШапки.пДата, КИСотрудника) Тогда
                пТелефонИсполнителя = КИСотрудника.ТелефонСлужебный;
            КонецЕсли;
            пИсполнитель = БухгалтерскийУчет.ФИО(пИсполнитель,Истина);
        Иначе
            пИсполнитель = БухгалтерскийУчет.ФИО(пИсполнитель.Наименование,Истина);
        КонецЕсли;
    КонецЕсли;  
    
    
    ДатаЗаголовка = Неопределено;
    Если НЕ СтруктураШапки.Свойство("пДатаПроведения", ДатаЗаголовка) Тогда
        ДатаЗаголовка = СтруктураШапки.пДата;
    КонецЕсли;
    СтруктураШапки.Вставить("пДатаЗаголовка", Формат(ДатаЗаголовка, "ДЛФ=ДД"));
    СтруктураШапки.Вставить("пДатаЗаголовкаЦифрами", Формат(ДатаЗаголовка, "ДЛФ=Д"));
    СтруктураШапки.Вставить("пДата", Формат(СтруктураШапки.пДата, "ДЛФ=Д"));
    СтруктураШапки.Вставить("пНазваниеДокумента", МетаданныеДокумента.Синоним);
    
    ПолнаяДатаДокумента = Формат(СтруктураШапки, "ДФ=""дд ММММ гггг """"года""""""");
    
    Если ЗначениеЗаполнено (ВидПервичногоДокумента) Тогда
        ВидПервичногоДокумента = СтруктураШапки.ВидПервичногоДокумента;
    Иначе
        ВидПервичногоДокумента = МетаданныеДокумента.Синоним;
    КонецЕсли;
    Если ЗначениеЗаполнено(НомерПервичногоДокумента) Тогда
        НомерПервичногоДокумента = СтруктураШапки.НомерПервичногоДокумента;
    Иначе   
        НомерПервичногоДокумента = СтруктураШапки.пНомер;
    КонецЕсли;
    Если ЗначениеЗаполнено(ДатаПервичногоДокумента) Тогда
        ДатаПервичногоДокумента = СтруктураШапки.ДатаПервичногоДокумента;
    Иначе
        ДатаПервичногоДокумента = СтруктураШапки.пДата;
    КонецЕсли;
    Если НЕ ЗначениеЗаполнено(ОснованиеТекст) Тогда
        ОснованиеТекст = "";
    Иначе
        Если МетаданныеДокумента.Имя <> "Сторно" Тогда
            ОснованиеТекст = ", " + ОснованиеТекст;
        Иначе
            ОснованиеТекст = СокрП(ОснованиеТекст)+", ";
        КонецЕсли;
    КонецЕсли;
    
    Если МетаданныеДокумента.Имя = "Сторно" Тогда
        СтруктураШапки.Вставить("пОснование",ОснованиеТекст +"Сторно документа "+СсылкаНаОбъект.СторнируемыйДокумент);
    Иначе
        СтруктураШапки.Вставить("пОснование", ВидПервичногоДокумента + " № " + НомерПервичногоДокумента + " от " + Формат(ДатаПервичногоДокумента, "ДЛФ=Д") + ОснованиеТекст);
    КонецЕсли;
    
    ТабличныйДок = Новый ТабличныйДокумент;
    ТабличныйДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    ТабличныйДок.ПолеСлева = 5;
    ТабличныйДок.ПолеСправа = 0;
    ТабличныйДок.ЧерноБелаяПечать = Истина;
    ТабличныйДок.КлючПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Справка0504833_Справка0504833";
        
    МакетСправки     = ПолучитьОбщийМакет("Справка0504833");
    ОбластьЗаголовок = МакетСправки.ПолучитьОбласть("Заголовок");
    ОбластьШапка     = МакетСправки.ПолучитьОбласть("Шапка");
    ОбластьСтрока    = МакетСправки.ПолучитьОбласть("Строка");
    ОбластьСтр_1     = ОбластьСтрока.ПолучитьОбласть("Стр_1");
    ОбластьСтр_2     = ОбластьСтрока.ПолучитьОбласть("Стр_2");
    ОбластьСтр_3     = ОбластьСтрока.ПолучитьОбласть("Стр_3");
    ОбластьИтого     = МакетСправки.ПолучитьОбласть("ИтогоПоДокументу");
    ОбластьПодвал    = МакетСправки.ПолучитьОбласть("Подвал");
    ОбластьКонцевик  = МакетСправки.ПолучитьОбласть("Концевик");
    
    ОбластьЗаголовок.Параметры.Заполнить(СтруктураШапки);
    
    ТабличныйДок.Вывести(ОбластьЗаголовок);
    ТабличныйДок.Вывести(ОбластьШапка);
    
    УчетныйРегистрОпераций = Новый ТаблицаЗначений;
    УчетныйРегистрОпераций.Колонки.Добавить("НомерЖурнала");
    
    ТаблицаДвижений = ОбщегоНазначения.СформироватьТаблицуДвиженийДокумента(СсылкаНаОбъект);
    
    Для Каждого СтрокаТаблицы Из ТаблицаДвижений Цикл
        МассивСекций = Новый Массив;
        МассивСекций.Добавить(ОбластьСтр_1);
        МассивСекций.Добавить(ОбластьСтр_2);
        Если ((НЕ СтрокаТаблицы.СчетДт.Пустая()) И СтрокаТаблицы.ЗабалансовыйДт) ИЛИ ((НЕ СтрокаТаблицы.СчетКт.Пустая()) И СтрокаТаблицы.ЗабалансовыйКт) Тогда
            МассивСекций.Добавить(ОбластьСтр_3);
        КонецЕсли;  
        Если НЕ ТабличныйДок.ПроверитьВывод(МассивСекций) Тогда
            ТабличныйДок.Вывести(ОбластьКонцевик);
            ТабличныйДок.ВывестиГоризонтальныйРазделительСтраниц();
            ТабличныйДок.Вывести(ОбластьШапка);
        КонецЕсли;  
        
        // Выводим строку содержания проводки
        пСодержаниеПроводки = СтрокаТаблицы.Содержание;
        Если НЕ БалансВШапке  Тогда
            ТекИФО = СтрокаТаблицы.Баланс;
            Если ЗначениеЗаполнено(ТекИФО) Тогда
                пСодержаниеПроводки  =  пСодержаниеПроводки + " по ИФО: """ + СОКРП(ТекИФО) + """";
            КонецЕсли;
        КонецЕсли;
        ОбластьСтр_1.Параметры.пСодержаниеПроводки = пСодержаниеПроводки;
        ОбластьСтр_1.Параметры.пСумма              = СтрокаТаблицы.Сумма + СтрокаТаблицы.СуммаЗабалансовая;
        ТабличныйДок.Вывести(ОбластьСтр_1);
        
        ТекКВД = СтрокаТаблицы.КВД;
        // Выводим строку проводки
        // Общая часть проводки
        ОбластьСтр_2.Параметры.пНомерСтроки  = СтрокаТаблицы.НомерСтроки;
        ОбластьСтр_2.Параметры.пНомерЖурнала = СтрокаТаблицы.НомерЖурнала;
        
        // Заполним параметры дебета
        ОбластьСтр_2.Параметры.пКБКДт       = "";
        ОбластьСтр_2.Параметры.пСчетДт      = "";
        ОбластьСтр_2.Параметры.пКОСГУДт     = "";
        ОбластьСтр_2.Параметры.пСубконтоДт1 = "";
        ОбластьСтр_2.Параметры.пСубконтоДт2 = "";
        ОбластьСтр_2.Параметры.пСубконтоДт3 = "";
        ОбластьСтр_2.Параметры.пКоличествоДт    = "";
        ОбластьСтр_2.Параметры.пВалютаДт        = "";
        ОбластьСтр_2.Параметры.пСуммаВалютнаяДт = "";
        ТекСчетДт = СтрокаТаблицы.СчетДт;
        Если НЕ ТекСчетДт.Пустая() Тогда
            ОбластьСтр_2.Параметры.пКБКДт = СтрокаТаблицы.КБКДт;
            
            Если СтрокаТаблицы.НетУчетаПоКВДДт Тогда
                ОбластьСтр_2.Параметры.пСчетДт = "" + ТекСчетДт;
            Иначе   
                ОбластьСтр_2.Параметры.пСчетДт = "" + ТекКВД + "." + ТекСчетДт;
            КонецЕсли;  
            
            Если СтрокаТаблицы.ЗабалансовыйДт Тогда
                ОбластьСтр_2.Параметры.пКОСГУДт = "";
                ОбластьСтр_2.Параметры.пСубконтоДт1 = СтрокаТаблицы.СубконтоДт1;
                ОбластьСтр_2.Параметры.пСубконтоДт2 = СтрокаТаблицы.СубконтоДт2;
                ОбластьСтр_2.Параметры.пСубконтоДт3 = СтрокаТаблицы.СубконтоДт3;
            Иначе
                ОбластьСтр_2.Параметры.пКОСГУДт = СтрокаТаблицы.СубконтоДт1;
                ОбластьСтр_2.Параметры.пСубконтоДт1 = СтрокаТаблицы.СубконтоДт2;
                ОбластьСтр_2.Параметры.пСубконтоДт2 = СтрокаТаблицы.СубконтоДт3;
                ОбластьСтр_2.Параметры.пСубконтоДт3 = СтрокаТаблицы.СубконтоДт4;
            КонецЕсли;  
            ОбластьСтр_2.Параметры.пКоличествоДт    = СтрокаТаблицы.КоличествоДт;
            ОбластьСтр_2.Параметры.пВалютаДт        = СтрокаТаблицы.ВалютаДт;
            ОбластьСтр_2.Параметры.пСуммаВалютнаяДт = СтрокаТаблицы.ВалютнаяСуммаДт;
        КонецЕсли;  
        
        // Заполним параметры кредита
        ОбластьСтр_2.Параметры.пКБККт       = "";
        ОбластьСтр_2.Параметры.пСчетКт      = "";
        ОбластьСтр_2.Параметры.пКОСГУКт     = "";
        ОбластьСтр_2.Параметры.пСубконтоКт1 = "";
        ОбластьСтр_2.Параметры.пСубконтоКт2 = "";
        ОбластьСтр_2.Параметры.пСубконтоКт3 = "";
        ОбластьСтр_2.Параметры.пКоличествоКт    = "";
        ОбластьСтр_2.Параметры.пВалютаКт        = "";
        ОбластьСтр_2.Параметры.пСуммаВалютнаяКт = "";
        ТекСчетКт = СтрокаТаблицы.СчетКт;
        Если НЕ ТекСчетКт.Пустая() Тогда
            ОбластьСтр_2.Параметры.пКБККт = СтрокаТаблицы.КБККт;
            
            Если СтрокаТаблицы.НетУчетаПоКВДКт Тогда
                ОбластьСтр_2.Параметры.пСчетКт = "" + ТекСчетКт;
            Иначе   
                ОбластьСтр_2.Параметры.пСчетКт = "" + ТекКВД + "." + ТекСчетКт;
            КонецЕсли;  
            
            Если СтрокаТаблицы.ЗабалансовыйКт Тогда
                ОбластьСтр_2.Параметры.пКОСГУКт = "";
                ОбластьСтр_2.Параметры.пСубконтоКт1 = СтрокаТаблицы.СубконтоКт1;
                ОбластьСтр_2.Параметры.пСубконтоКт2 = СтрокаТаблицы.СубконтоКт2;
                ОбластьСтр_2.Параметры.пСубконтоКт3 = СтрокаТаблицы.СубконтоКт3;
            Иначе
                ОбластьСтр_2.Параметры.пКОСГУКт = СтрокаТаблицы.СубконтоКт1;
                ОбластьСтр_2.Параметры.пСубконтоКт1 = СтрокаТаблицы.СубконтоКт2;
                ОбластьСтр_2.Параметры.пСубконтоКт2 = СтрокаТаблицы.СубконтоКт3;
                ОбластьСтр_2.Параметры.пСубконтоКт3 = СтрокаТаблицы.СубконтоКт4;
            КонецЕсли;  
            ОбластьСтр_2.Параметры.пКоличествоКт    = СтрокаТаблицы.КоличествоКт;
            ОбластьСтр_2.Параметры.пВалютаКт        = СтрокаТаблицы.ВалютаКт;
            ОбластьСтр_2.Параметры.пСуммаВалютнаяКт = СтрокаТаблицы.ВалютнаяСуммаКт;
        КонецЕсли;  
        
        ТабличныйДок.Вывести(ОбластьСтр_2);
        
        ВыводитьСубконто4 = Ложь;
        Если НЕ ТекСчетДт.Пустая() Тогда
            Если СтрокаТаблицы.ЗабалансовыйДт Тогда
                ОбластьСтр_3.Параметры.пСубконтоДт4 = СтрокаТаблицы.СубконтоДт4;
                ВыводитьСубконто4 = Истина;
            КонецЕсли;  
        КонецЕсли;  
        Если НЕ ТекСчетКт.Пустая() Тогда
            Если СтрокаТаблицы.ЗабалансовыйКт Тогда
                ОбластьСтр_3.Параметры.пСубконтоКт4 = СтрокаТаблицы.СубконтоКт4;
                ВыводитьСубконто4 = Истина;
            КонецЕсли;  
        КонецЕсли;  
        Если ВыводитьСубконто4 Тогда
            ТабличныйДок.Вывести(ОбластьСтр_3);
        КонецЕсли;  
        
        УчетныйРегистрОпераций.Добавить().НомерЖурнала = СокрЛП(СтрокаТаблицы.НомерЖурнала);
    КонецЦикла; 
    
    Если глЗначениеПеременной("глНеВыводитьИтоговуюСуммуБухгалтерскойСправки") Тогда
        
        ТабличныйДок.Вывести(ОбластьКонцевик);
        
    Иначе
        
        ОбластьИтого.Параметры.пСуммаИтого   = ТаблицаДвижений.Итог("Сумма"); // сумма по балансовым счетам
 
        Если глЗначениеПеременной("глВыводитьОбщийИтогБухгалтерскойСправки") Тогда
            ОбластьИтого.Параметры.пСуммаИтого   = ОбластьИтого.Параметры.пСуммаИтого + ТаблицаДвижений.Итог("СуммаЗабалансовая");  
        КонецЕсли;  
        ТабличныйДок.Вывести(ОбластьИтого);
        
        Если глЗначениеПеременной("глВыводитьРаздельноИтогиПоБалансовымИЗабалансовымСчетам") Тогда
            ОбластьИтого.Параметры.пСуммаИтого   = ТаблицаДвижений.Итог("СуммаЗабалансовая");
            ОбластьИтого.Области.ЗаголовокИтоговойСтроки.Текст = ОбластьИтого.Области.ЗаголовокИтоговойСтроки.Текст + " (по забалансовым счетам)";
            ТабличныйДок.Вывести(ОбластьИтого);
        КонецЕсли;  
        
    КонецЕсли;  
        
    МассивСекций = Новый Массив;
    МассивСекций.Добавить(ОбластьПодвал);
    Если НЕ ТабличныйДок.ПроверитьВывод(МассивСекций) Тогда
        ТабличныйДок.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;  
    
    Исполнитель = СсылкаНаОбъект.Кассир;
    пДолжностьИсполнителя = "Кассир";
 //   Ссылка = СсылкаНаОбъект;
 //   
 //   Запрос = Новый Запрос;
 //   Запрос.Текст = 
 //     "ВЫБРАТЬ
 //     |   НД_РКО.Ссылка,
 //     |   НД_РКО.Дата
 //     |ИЗ
 //     |   Документ.НД_РКО КАК НД_РКО
 //     |ГДЕ
 //     |   НД_РКО.Ссылка = &Ссылка";
 
 //   Запрос.УстановитьПараметр("Ссылка", Ссылка);
 //
 //   Выборка = Запрос.Выполнить().Выбрать();
 //     Пока Выборка.Следующий() Цикл
 //         ДатаЧисло = Выборка.Дата;
 //         //ДатаМесяц = Формат(Выборка.Дата, "ДФ=ММММ");
 //         //ДатаГод = Формат(Выборка.Дата, "ДФ=гггг");
 
 //     КонецЦикла;
        
 
    //ДлинаСтроки         = СтрДлина(ПолнаяДатаДокумента);
    //ПервыйРазделитель   = Найти(ПолнаяДатаДокумента," ");
    //ВторойРазделитель   = Найти(Прав(ПолнаяДатаДокумента,ДлинаСтроки - ПервыйРазделитель), " ") + ПервыйРазделитель;
    
    //ОбластьПодвал.Параметры.ДатаЧисло  = """" + Лев(ПолнаяДатаДокумента, ПервыйРазделитель - 1) + """";
    //ОбластьПодвал.Параметры.ДатаМесяц = Сред(ПолнаяДатаДокумента, ПервыйРазделитель + 1, ВторойРазделитель - ПервыйРазделитель - 1);
    //ОбластьПодвал.Параметры.ДатаГод   = Прав(ПолнаяДатаДокумента, ДлинаСтроки - ВторойРазделитель);
     //Струк = Новый Структура;
     //Струк.Вставить("пДатаЗаголовка", Формат(ДатаЗаголовка, "ДЛФ=ДД"));
     пДатаДокумента = "12"; 
      
 
    ОбластьПодвал.Параметры.пБухгалтерФИО            = пБухгалтерФИО;
    ОбластьПодвал.Параметры.пДолжностьИсполнителя    = пДолжностьИсполнителя;
    ОбластьПодвал.Параметры.пИсполнитель             = Исполнитель;
    ОбластьПодвал.Параметры.пТелефонИсполнителя      = пТелефонИсполнителя;
    ОбластьПодвал.Параметры.пДатаДокумента = пДатаДокумента;
 
    УчетныйРегистрОпераций.Свернуть("НомерЖурнала");
    УчетныйРегистрОпераций.Сортировать("НомерЖурнала");
    СтрокаУчетныйРегистрОпераций = СтроковыеФункцииКлиентСервер.ПолучитьСтрокуИзМассиваПодстрок(УчетныйРегистрОпераций.ВыгрузитьКолонку("НомерЖурнала"));
    ОбластьПодвал.Параметры.УчетныйРегистрОпераций = ?(СтрокаУчетныйРегистрОпераций = "", "", "ж/о " + СтрокаУчетныйРегистрОпераций + " за " + Формат(ДатаЗаголовка, "ДФ = 'ММММ гггг'"));
    ТабличныйДок.Вывести(ОбластьПодвал);
    
    Возврат ТабличныйДок;
    
КонецФункции
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.06.2013, 15:08
Ответы с готовыми решениями:

Печатная форма
Добрый день Уважаемые! У меня такая проблема нигде в сети не могу найти печатную форму...

Печатная форма 8.2
1.Добрый день не подскажите можно в одной ячейке написать разными шрифтами? к примеру:...

Печатная форма М-15
Помогите. В 1С-упрощенке есть таблица М-15 Мне нужно чтоб эта форма была в 1с ТиС 7.7 и...

Печатная Форма 1с 8.2
Здравствуйте,помогите новичку Вот печатная форма

Печатная форма
Помогите пожалуйста. Есть такая процедура: //{{_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ(Печать) // Данный...

5
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
04.06.2013, 15:12 2
Цитата Сообщение от Augusto Посмотреть сообщение
на скрине
А скрин то где?
0
Augusto
70 / 70 / 1
Регистрация: 18.12.2012
Сообщений: 390
04.06.2013, 15:14  [ТС] 3
извиняюсь, забыл прицепить
0
Миниатюры
Печатная форма  
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
04.06.2013, 15:29 4
Проверить, что в ячейке таб. поля указано что это параметр, а не шаблон.
Скопировать название параметра из ячейки и подставить в код. Возможно закралась где то латинская буква.
1
Augusto
70 / 70 / 1
Регистрация: 18.12.2012
Сообщений: 390
04.06.2013, 15:49  [ТС] 5
Нашел косяк. Все оказалось гораздо проще. Дурацкий склероз виноват. Забыл сменить
МакетСправки = ПолучитьОбщийМакет("Справка0504833"); на
МакетСправки = ПолучитьйМакет("Справка0504833");

Добавлено через 29 секунд
Нет мне прощения
0
Dethmontt
04.06.2013, 16:41     1C 8.x Печатная форма
  #6

Не по теме:

Руки оторвать и по щекам надавать! :D

0
04.06.2013, 16:41
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.06.2013, 16:41
Привет! Вот еще темы с ответами:

Печатная Форма
Подскажи пожалуйста Процедура Печать(ТабДок, Ссылка) Экспорт //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)...

Печатная форма
Такая проблема: есть печатная форма, допустим, счет-фактуры. Там много строк и 1-2 строки не...

Печатная Форма Документа
:lamer: Всем привет! Начал изучать 1с 7.7(почему именно 7.7? - потому что так хочу.)возникла...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru