Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/17: Рейтинг темы: голосов - 17, средняя оценка - 4.71
nikita1981
2 / 2 / 1
Регистрация: 21.12.2012
Сообщений: 53
1

Удаление движений при установке отметки удаления

02.07.2013, 11:05. Просмотров 3118. Ответов 2
Метки нет (Все метки)

Я пока не профи по 1С..... Есть у меня такая задача - создать так, чтобы при установке отметки удаления документа, не удалялись движения по этому док-ту. Можно, конечно, в свойствах документа поставить "Не удалять автоматически", а потом написать код процесса установки пометки. Но вся суть в том, чтобы отметка удаления служила просто показателем, что надо удалить. Я попробовал для журнала документов создать процедуру (СостояниеДок - созданный реквизит документа).
Код служит для того, чтобы: 1. Установить пометку удаления для проведенного дока, 2. При снятии отметки документ возвращается в исходное состояние.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Процедура ЖурналДокументовСписокПередУстановкойПометкиУдаления(Элемент, Отказ)
    // Вставить содержимое обработчика.
    Отказ = ложь;
    Док = ЭлементыФормы.ЖурналДокументовСписок.ТекущиеДанные.Ссылка.ПолучитьОбъект();
 
    Если Док.Проведен = истина Тогда
         Док.СостояниеДок = "Проведен";
    Иначе
        Если Док.ПометкаУдаления = истина И Док.СостояниеДок = "Проведен"  
        Тогда
        Док.ПометкаУдаления = ложь;
        Отказ = истина;        
        Док.Записать(РежимЗаписиДокумента.Проведение);
        Док.СостояниеДок = "";
        КонецЕсли;
    КонецЕсли;
    
КонецПроцедуры
Здесь есть один недостаток - при отмене проведения движения удаляются и в связанном регистре после снятия отметки данные по этому док-ту удаляются. Может кто сталкивался с такой проблемой и есть какой код?
Еще заметил такую странность - не все документы "хотят возвращаться" к проведенности..
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
02.07.2013, 11:05
Ответы с готовыми решениями:

Задание условий для движений документа по регистрам
Друзья, помогите плиз! Имеется документ с двумя реквизитами, пусть будет...

Нет движений в РегистреБухгалтерии.Хозрасчетный в подписке на событие
В Очередной раз прошу помощи. Сделала подписку на событие. Но в НЗ после...

Ошибки при записи движений документа в регистр накопления
Здравствуйте. Есть собственная конфигурация 1С 8.3 по планированию и учету...

Формирование движений
Всем добрый день, помогите разобраться, в программировании 1С я новичек,...

Нет движений по расходной накладной по РБ
Не могу понять, почему расходная накладная не делает движения по РБ...

2
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
02.07.2013, 11:12 2
имхо, хватит просто флажка "Пометка на пометку на удаление", а "Пометка на удаление" - сама по себе. В журнале вывести две пометки.
0
nikita1981
2 / 2 / 1
Регистрация: 21.12.2012
Сообщений: 53
18.10.2013, 10:37  [ТС] 3
но это не все, придется для этого создавать свою командную панель на форме документа. Т.е. отключать стандартные команды. Писать коды для команд типа Провести, Удалить и т.п. В журнале создавать процедуры для пометки и непосредственно удаления... Отключать автоматику удаления движений регистров, связанных с документом... Но, в принципе, если 1Сники хотят помечать на удаление по принципу который уже есть, то это не страшно.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.10.2013, 10:37

Выбор значения в зависимости от типа движений
Всем привет! Пытаюсь собрать свою конфигурацию. 1С 8.3 В управляемом...

Формирование движений без перепроведения документов
Добрый день! Конфигурация Управление торговлей, редакция 11.1.6.17. Создал...

Запрет удаления содержимого нескольких ячеек в строке при установке значения в ячейке
Добрый день К сожалению не смог решить сам свою задачу, прошу помощи Есть...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru