Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
Yulunga
372 / 266 / 69
Регистрация: 22.04.2013
Сообщений: 1,701
Записей в блоге: 1
Завершенные тесты: 1
1

1c БП 2.0 имитировать ентер?

15.07.2013, 15:47. Просмотров 500. Ответов 5
Метки нет (Все метки)

День добрый всем.

переделываю требование-накладную
чтоб на второй закладке(счета затрат) по умолчанию писались номер счёта, субконто1 и субконто2.
но у субконт нет видимости - они появляются только если выбрать счёт.
написал
СчетЗатрат = ПланыСчетов.Хозрасчетный.НайтиПоКоду("20.01");
он вставляется. но субконты не открываются (
надо как-то имитировать, что я ентер нажал? или как сделать ?
и как заполнить субконты уж заодно, не подскажете, пожалуйста?
не работает ничего из :
1C
1
2
3
Субконто1 = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.НоменклатурныеГруппы.Наименование("000000004");
    Субконто2 = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.НоменклатурныеГруппы.Код("000000003");
    //Субконто2 = "Материальные расходы";
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.07.2013, 15:47
Ответы с готовыми решениями:

Ентер в текстбоксе
Я пишу ирк-клиент, чат такой, в текстбоксе ввожу сообщения, по нажатию Enter сообщения...

написано ф2 то ентер
всем привет. ноут включается но там такая фигня.. ноут то горит, то нет.. и внизу написано f2 то...

Отправить ентер окну
Суть проблемы: в чужом окне есть RichEdit в котором при нажатии клавиши Enter отсылается текст. ...

ИСРП глючит ентер
Происходит какой то бред: жму в окне кода ентер, курсор перемещается вниз а новой строки не...

считать с файла через ентер
Здравствуйте! Если считывать с файла вот так: freopen("input.txt", "r", stdin); ...

5
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
15.07.2013, 16:46 2
вставил счёт - инициируй событие СчетПриИзменении()

Добавлено через 29 секунд
ну или скопируй оттуда текст туда, где вставляешь
0
Yulunga
372 / 266 / 69
Регистрация: 22.04.2013
Сообщений: 1,701
Записей в блоге: 1
Завершенные тесты: 1
18.07.2013, 08:43  [ТС] 3
вот последнее так и не расшифровал )
а инициировать никак не получается :
пробовал писать по-разному
СчетЗатрат = ПланыСчетов.Хозрасчетный.ОсновноеПроизводство;
//.НайтиПоКоду("20.01");
//.НайтиПоНаименованию("Основное Производство");
потом запускаю когда
//СчетЗатратПриИзменении(СчетЗатрат);
то в переменной СчетЗатрат - строка "20.01"
а если запускать обычную треб.накл. - то там СчетЗатрат = ПолеВвода ( чтоето? )
и вот уже параметрэтот.значение = "20.01"
а у меня, есс-но, на "20.01".значение ругается
что мне написать в параметре при запуске СчетЗатратПриИзменени ?
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
18.07.2013, 09:35 4
При заполнении счета надо запустить эту процедуру или её содержимое, или его часть
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
Процедура СчетЗатратПриИзменении(Элемент)
 
    РаботаСДиалогами.ПриВыбореСчетаВТабличномПоле(Элемент.Значение,
        Субконто1, ЭлементыФормы.Субконто1,
        Субконто2, ЭлементыФормы.Субконто2,
        Субконто3, ЭлементыФормы.Субконто3,
        ПодразделениеЗатрат, ЭлементыФормы.ПодразделениеЗатрат);
                                 
    Подразделение = Неопределено;
    РаботаСДиалогами.УстановитьПодразделениеПоСчету(
        ПодразделениеЗатрат, СчетЗатрат, Организация, Подразделение);
    
    Если ЭлементыФормы.Субконто2.ОграничениеТипа = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура.ТипЗначения Тогда
        ЭлементыФормы.Субконто2.Доступность = Ложь;
        ЭлементыФормы.Субконто2.Значение = "Из табличной части";
    ИначеЕсли (2 <= СчетЗатрат.ВидыСубконто.Количество()) и (ЗначениеЗаполнено(СчетЗатрат)) Тогда
        ЭлементыФормы.Субконто2.Доступность = Истина;
    КонецЕсли;
    Если ЭлементыФормы.Субконто3.ОграничениеТипа = ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура.ТипЗначения Тогда
        ЭлементыФормы.Субконто3.Доступность = Ложь;
    ИначеЕсли (3 <= СчетЗатрат.ВидыСубконто.Количество()) и (ЗначениеЗаполнено(СчетЗатрат)) Тогда
        ЭлементыФормы.Субконто3.Доступность = Истина;
    КонецЕсли;
    
    Если НалоговыйУчетУСН.ПрименениеУСН(Организация, Дата) И ОтражениеВУСН = Перечисления.ОтражениеВУСН.ПустаяСсылка() Тогда
        ОтражениеВУСН = Перечисления.ОтражениеВУСН.Принимаются;
    КонецЕсли;
    
    УстановитьВидимость();
    
КонецПроцедуры // СчетЗатратПриИзменении
0
Yulunga
372 / 266 / 69
Регистрация: 22.04.2013
Сообщений: 1,701
Записей в блоге: 1
Завершенные тесты: 1
18.07.2013, 15:02  [ТС] 5
"так и я за шо" )
когда я запускаю эту процедуру с параметром СчетЗатрат, которому я присвоил значение, то передаётся просто "20.01"
а когда она запускает, то там
свойство значение тип
Элемент ПолеВвода ПолеВвода

вот и спрашиваю - что за зверь такой и как мне вроде как и 20.01 присвоить, но тока чтоб свойство "значение" было 20.01, а не сам параметр ?

Добавлено через 1 час 22 минуты
1C
1
СчетЗатратПриИзменении(ПланыСчетов.Хозрасчетный.ОсновноеПроизводство);
оказалось всё проще некуда )
сорри.
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
19.07.2013, 14:49 6
Элемент - это Элементы.СчетЗатрат.Значение. Контрол.
Попробуйте ограничиться
1C
1
2
3
4
5
РаботаСДиалогами.ПриВыбореСчетаВТабличномПоле(СчетЗатрат,
        Субконто1, ЭлементыФормы.Субконто1,
        Субконто2, ЭлементыФормы.Субконто2,
        Субконто3, ЭлементыФормы.Субконто3,
        ПодразделениеЗатрат, ЭлементыФормы.ПодразделениеЗатрат);
0
19.07.2013, 14:49
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.07.2013, 14:49

После чистки ноута не работает ентер.
У меня ноутбук Samsung R60+. Начну с того, что в какое то время у меня полетел DrWeb. Я решил...

Javascript перенос строки при нажатии ентер
есть код, наложения текста на изображение, но при нажатии на ентер, на картинке не отображается...

Как убрать в ленте первый ентер и последний?
как убрать в ленте первый ентер и последний


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru