Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.53/17: Рейтинг темы: голосов - 17, средняя оценка - 4.53
korish
0 / 0 / 0
Регистрация: 30.06.2011
Сообщений: 46
1

Получить значение из тега XML

16.07.2013, 11:44. Просмотров 3357. Ответов 1
Метки нет (Все метки)

Есть XML файл такой структуры
XML
1
2
3
4
5
6
7
8
9
10
<?xml version="1.0" encoding="utf-8"?>
<rests>
    <product id="6041389" cat="Аксессуары к сумкам" cat_top="АКСЕССУАРЫ" brand="CASE LOGIC" artikul="DCS101" name="acc CASE LOGIC DCS101 (Black)" price="12.00" status="1" guarant="" scu="1" price_scu="12.00" url="http://******1723202.html" photo="http://******/1466481.jpg" ukt="4202929800"   statusRP="0" qtyRP="Нет"  RPrice="20.00" RPrice_UAH="159.00" barcode="085854226929" spec_rate="0">
        <descr>Ремень для зеркальных фотокамер, системных фотокамер и ультразумов
                Материал: Нейлон
                Размер: 9.4 x 1 x 36.6 см
                Вес: 100 г
        </descr>
    </product>
</rests>
из него вытаскиваю инфу таким способом

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Чтение = Новый ЧтениеXML;
    Чтение.ОткрытьФайл("**.xml");
    Пока Чтение.Прочитать() Цикл
        Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
            Если Чтение.Имя="product" Тогда
                Пока Чтение.ПрочитатьАтрибут() Цикл
                    Если Чтение.Имя="id" Тогда
                        Сообщить("id: "+Чтение.Значение);
                    КонецЕсли;
                    Если Чтение.Имя="cat" Тогда
                        Сообщить("cat: "+Чтение.Значение);
                    КонецЕсли;  
                КонецЦикла;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
Никак не получается получить значения из тега <descr></descr>. Подскажите что не так делаю?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.07.2013, 11:44
Ответы с готовыми решениями:

XML. Получить значение тега
Здравствуйте, допустим имеется такой документ: Текст 1 Текст 3 Текст 2 Мне надо...

XML reader - получить значение тега
Получаю значение из XML следующим образом: if (reader.Name == &quot;Book&quot;) ...

Получить значение тега из файла xml в текстовое поле
Всем привет. Как можно получить значение тега &lt;UserName&gt; из файла xml в текстовое поле на форме?

Получить элементы xml по имени тега
К примеру есть xml документ &lt;xml&gt; &lt;A&gt; &lt;SomeElement1&gt;blah&lt;/SomeElement1&gt; ...

XML: по имени элемента (тега) и/или имени атрибута у элемента (у тега) выдать соответствующее значение
Есть некий XML файл. . &lt;?xml version=&quot;1.0&quot; encoding=&quot;windows-1251&quot;?&gt; &lt;ТКвит ...

1
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
16.07.2013, 14:31 2
Как-то так:
1C
1
2
3
4
5
6
7
8
Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
            Если Чтение.Имя="descr" Тогда
                  Чтение.Прочитать();
                   Если Чтение.ТипУзла = ТипУзлаXML.ТекстТогда
                           Сообщить("descr: "+Чтение.Значение); 
                   КонецЕсли;
            КонецЕсли;
КонецЕсли;
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.07.2013, 14:31

Переименовать значение тега в XML
здравствуйте! нужно переименовать значение тега, после выполнения кода ничего не меняется и...

Как вытащить значение тега из xml в php5
как вытащить значение тега из xml в php5 &lt;?xml version=&quot;1.0&quot; encoding=&quot;UTF-8&quot;?&gt; &lt;Entities...

Получить значение из тега <p> по id
Пример кода: &lt;p id=&quot;1&quot;&gt;12&lt;/p&gt; &lt;p id=&quot;2&quot;&gt;67&lt;/p&gt; &lt;p id=&quot;3&quot;&gt;32&lt;/p&gt; Надо в js получить 12, 67...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru