Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/6: Рейтинг темы: голосов - 6, средняя оценка - 5.00
SHSerg
58 / 58 / 25
Регистрация: 01.11.2012
Сообщений: 282
1

Цены в УТ 11

18.07.2013, 11:02. Просмотров 1045. Ответов 5
Метки нет (Все метки)

Подскажите, где в УТ 11 лежат цены номенклатуры? Нужно из программы на Delphi получить список товаров с ценами. Из справочника Номенклатура беру артикул и наименование, но не могу найти цены.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.07.2013, 11:02
Ответы с готовыми решениями:

Подставление вида цены и цены из регистра сведений
Такое дело... Есть док - Продажи. ТЧ - Товары. Нужно, чтобы При Изменении...

Изменение цены
Доброго времени суток. В 1с v7.7 Торговля + Склад в прайс листе меняют цену...

Ут 10.3 Цены на период
Всем привет. Ут 10.3 У поставщика в файле(файл присылается) есть строки...

УТ 10 Учетные цены
Доброго времени! Подскажите плз, откуда в УТ 10 можно "выдрать" учетную цену...

Формат цены
Добрый день! Может подскажет кто в 1с во внешнем отчета сделать формат цены...

5
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
18.07.2013, 11:21 2
цены в регистре св. ЦеныНоменклатуры (по типу и валюте)
1
SHSerg
58 / 58 / 25
Регистрация: 01.11.2012
Сообщений: 282
18.07.2013, 11:47  [ТС] 3
duk337, спасибо. А как из delphi получить эти цены? Можете привести пример запроса?
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
18.07.2013, 12:11 4
при чём здесь делфи? Из делфи вам оле или ком создать. И одинэсовским запросом или просто функцией срезпоследних
0
SHSerg
58 / 58 / 25
Регистрация: 01.11.2012
Сообщений: 282
18.07.2013, 12:22  [ТС] 5
duk337, вот я это и имею ввиду. Можете привести текст запроса для получения цены?
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
19.07.2013, 14:56 6
допустим, в РеалТиУ подглядеть, и увидим такую строчку в модуле формы (1268):
ЦеныРассчитаны = ЗаполнитьЦеныПоВидуЦенСервер(ВидЦен);
в процедуре
1C
1
2
3
4
5
6
7
8
9
10
11
&НаКлиенте
Процедура ЗаполнитьЦеныПоВидуЦен(Команда)
    Если ПродажиКлиент.ПроверитьНеобходимостьЗаполненияЦенПоВидуЦен(Объект, "Товары", "Товары") Тогда
        ВидЦен = ПродажиКлиент.ВыбратьВидЦен(Объект.ЦенаВключаетНДС, Истина);
        Если ЗначениеЗаполнено(ВидЦен) Тогда
            ЦеныРассчитаны = ЗаполнитьЦеныПоВидуЦенСервер(ВидЦен);
            ПродажиКлиент.ОповеститьОбОкончанииЗаполненияЦенПоВидуЦен(ЦеныРассчитаны, ВидЦен);
        КонецЕсли;
    КонецЕсли;
    СкидкиНаценкиКлиент.СброситьФлагСкидкиРассчитаны(ЭтаФорма);
КонецПроцедуры // ЗаполнитьЦеныПоВидуЦен()
установить курсор, нажать ф12
0
19.07.2013, 14:56
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.07.2013, 14:56

Расчет цены
При изменении параметра "Коэффициент" автоматически пересчитывается...

Тип цены
Всем дорбрый день! Помогите с проблемой такого рода,есть список контрагентов и...

Вычисление Цены
Только начала изучать 1С и возникли сложности( Должны продаваться билеты на...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru