Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
tgarl
357 / 351 / 81
Регистрация: 15.02.2012
Сообщений: 1,351
1

не понимаю

18.07.2013, 11:49. Просмотров 371. Ответов 0
Метки нет (Все метки)

в 1с ут 10,3 есть внешний обработчик для выгрузки на сайт проблема в том что группы одноуровневые я зашел в формы и добавил поле Дерево в которое нужно указать код к какой группе принадлежит текущая группа
но вот как теперь построить дерево в xml не понимаю
вот код
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
Процедура ВыгрузитьОсновныеРеквизитыГруппыДляКлассификатора(ОбъектCML, Группа)
    
    ИдГруппы = СформироватьИдентификаторТовара(Группа.Ссылка);
    ЗаписатьТекстовойУзел(ОбъектCML, "Ид", ИдГруппы);
    ИмяГруппы = Группа.Наименование;
    ЗаписатьТекстовойУзел(ОбъектCML, "Наименование", ФорматНаименованияДляCML(ИмяГруппы));
    
КонецПроцедуры
 
Процедура ВыгрузитьГруппыРекурсивно(ОбъектCML, ДеревоГрупп);
    
    НужноВыгружатьГруппы = Ложь;
    
    Для Каждого СтрокаДерева Из ДеревоГрупп Цикл
    
        Если НЕ СтрокаДерева.ЭтоГруппа Тогда
            Продолжить;
        КонецЕсли;
        
        Если Не НужноВыгружатьГруппы Тогда
            
            ОбъектCML.ЗаписатьНачалоЭлемента("Группы");
            НужноВыгружатьГруппы = Истина;
            
        КонецЕсли;
        
        ОбъектCML.ЗаписатьНачалоЭлемента("Группа");
        ВыгрузитьОсновныеРеквизитыГруппыДляКлассификатора(ОбъектCML, СтрокаДерева);
        
        Если СтрокаДерева.Строки.Количество() > 0 Тогда
            ВыгрузитьГруппыРекурсивно(ОбъектCML, СтрокаДерева.Строки);
        КонецЕсли;  
        ОбъектCML.ЗаписатьКонецЭлемента();
        
    КонецЦикла; 
    
    Если НужноВыгружатьГруппы Тогда
        ОбъектCML.ЗаписатьКонецЭлемента();
    КонецЕсли;
    
КонецПроцедуры
сейчас получается так
XML
1
2
3
4
5
6
7
8
9
10
<Группы>
            <Группа>
                <Ид>9374b575-8393-47bf-a0e8-6844f6ad8bb8</Ид>
                <Наименование>с рисунком</Наименование>
            </Группа>
            <Группа>
                <Ид>16596ed0-2522-4286-b874-3bbfc562816f</Ид>
                <Наименование>однотонный</Наименование>
            </Группа>
</Группы>
а должно так если у группы однотонный в поле дерево указан код группы с рисунком
XML
1
2
3
4
5
6
7
8
9
10
11
<Группы>
            <Группа>
                <Ид>9374b575-8393-47bf-a0e8-6844f6ad8bb8</Ид>
                <Наименование>с рисунком</Наименование>
            
                   <Группа>
                        <Ид>16596ed0-2522-4286-b874-3bbfc562816f</Ид>
                        <Наименование>однотонный</Наименование>
                    </Группа>
                       </Группа>
</Группы>
подскажите если можете как подправить
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.07.2013, 11:49
Ответы с готовыми решениями:

1c 8.0 подскажите не понимаю
Добрый день коллеги , вопрос есть такой , есть 1С которые считывают через штрих код данные...

Переиндексация: не понимаю
Может ли кто-нибудь объяснить, почему на мощной машине гл. бухгалтера переиндексация маленькой базы...

Не понимаю
как написать формулу?

НУ не понимаю я!
Есть таблица, всё связано, работает замечательно. Но есть 1 но! Выбираю нужную мне запись и хочу...

Не понимаю...
При запросе в Яндексе &quot;*.имя_сайта.ru&quot; он выдает что &quot;Нашлось 2 млн страниц&quot;, причем в списке он...

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.07.2013, 11:49

С++ не понимаю
1. сумму элементов массива с нечетными номерами; 2. сумму элементов массива, расположенных между...

Не понимаю???
Пишу в Яндексе &quot;бпн&quot;, искать! Мой сайт на 4 месте, а среди Украинских соответственно первый......

Не понимаю
Всем привет.Прошу совета. Дело в том,что я сейчас поступил в тех. ВУЗ.И все бы ничего,да только на...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru