Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
Vogde
0 / 0 / 1
Регистрация: 03.01.2013
Сообщений: 75
1

Ссылка на документ

19.07.2013, 09:17. Просмотров 999. Ответов 2
Метки нет (Все метки)

Всем привет. В отчете (дополнительная внешняя обработка) необходимо чтобы в поле Документ выдавалась ссылка на этот документ.

Вот код, подскажите где ошибка?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    Макет = ПолучитьМакет("Основной");
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
    ОбластьИтого = Макет.ПолучитьОбласть("Итого");
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    УслугиСМКОстаткиИОбороты.Поставщик.Ссылка КАК Поставщик,
                   |    УслугиСМКОстаткиИОбороты.ДокументПоставщика.Ссылка КАК ДокументПоставщика,
                   |    УслугиСМКОстаткиИОбороты.Регистратор,
                   |    УслугиСМКОстаткиИОбороты.СуммаДокументаНачальныйОстаток КАК СуммаДокументаНачальныйОстаток,
                   |    УслугиСМКОстаткиИОбороты.СуммаДокументаПриход КАК СуммаДокументаПриход,
                   |    УслугиСМКОстаткиИОбороты.СуммаДокументаРасход КАК СуммаДокументаРасход,
                   |    УслугиСМКОстаткиИОбороты.СуммаДокументаКонечныйОстаток КАК СуммаДокументаКонечныйОстаток
                   |ИЗ
                   |    РегистрНакопления.УслугиСМК.ОстаткиИОбороты ( &НачалоПериода, &КонецПериода, Авто,  ,Поставщик = &Поставщик) КАК УслугиСМКОстаткиИОбороты
                   |ИТОГИ
                   |    СУММА(СуммаДокументаНачальныйОстаток),
                   |    СУММА(СуммаДокументаПриход),
                   |    СУММА(СуммаДокументаРасход),
                   |    СУММА(СуммаДокументаКонечныйОстаток)
                   |ПО
                   |    ОБЩИЕ,
                   |    Поставщик,
                   |    ДокументПоставщика";
                   
                    Если Не ЗначениеЗаполнено(Контрагент) Тогда
    
                        Запрос.Текст = СтрЗаменить(Запрос.Текст,"Поставщик = &Поставщик","");    
    
                    КонецЕсли;
                    
    Запрос.УстановитьПараметр("НачалоПериода", НачалоПериода);
    Запрос.УстановитьПараметр("КонецПериода", КонецПериода);
    Запрос.УстановитьПараметр("Поставщик", Контрагент);
    
    Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
    
    // Общие итоги
    
    ИтогоНаНачало = 0;
    ИтогоПриход = 0;
    ИтогоРасход = 0;
    ИтогоНаКонец =0;
    
    ЭлементыФормы.Результат.Очистить();
    ЭлементыФормы.Результат.Вывести(ОбластьЗаголовок);
    ЭлементыФормы.Результат.Вывести(ОбластьШапка);
    
    Пока Выборка.Следующий() Цикл
    
        ИтогоНаНачало = Выборка.СуммаДокументаНачальныйОстаток;
        ИтогоПриход = Выборка.СуммаДокументаПриход;
        ИтогоРасход = Выборка.СуммаДокументаРасход;
        ИтогоНаКонец = Выборка.СуммаДокументаКонечныйОстаток;
        
        ВыборкаПоставщик = Выборка.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
        
        ЭлементыФормы.Результат.НачатьАвтогруппировкуСтрок();
        // Поставщик
        Пока ВыборкаПоставщик.Следующий() Цикл
        
            ОбластьСтрока.Параметры.ПоставщикДокумент = ВыборкаПоставщик.Поставщик;
            ОбластьСтрока.Параметры.Реализация = " ";
            ОбластьСтрока.Параметры.НаНачало = ВыборкаПоставщик.СуммаДокументаНачальныйОстаток;
            ОбластьСтрока.Параметры.Приход = ВыборкаПоставщик.СуммаДокументаПриход;
            ОбластьСтрока.Параметры.Расход = ВыборкаПоставщик.СуммаДокументаРасход;
            ОбластьСтрока.Параметры.НаКонец = ВыборкаПоставщик.СуммаДокументаКонечныйОстаток;
            
            Элементыформы.Результат.Вывести(ОбластьСтрока,1,"Поставщик");
            
            // ДокументПоставщика
            
            ВыборкаДокументПоставки = ВыборкаПоставщик.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
            
            Пока ВыборкаДокументПоставки.Следующий() Цикл
            
                 ОбластьСтрока.Параметры.ПоставщикДокумент = ВыборкаДокументПоставки.ДокументПоставщика;
                 ОбластьСтрока.Параметры.Реализация = " ";
                 ОбластьСтрока.Параметры.НаНачало = ВыборкаДокументПоставки.СуммаДокументаНачальныйОстаток;
                 ОбластьСтрока.Параметры.Приход = ВыборкаДокументПоставки.СуммаДокументаПриход;
                 ОбластьСтрока.Параметры.Расход = " ";
                 ОбластьСтрока.Параметры.НаКонец = ВыборкаДокументПоставки.СуммаДокументаКонечныйОстаток;
                 
                 ЭлементыФормы.Результат.Вывести(ОбластьСтрока,2,"Документ");
                 
                 // Реализация
                 
                 ВыборкаРеализация = ВыборкаДокументПоставки.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
                 
                 Пока ВыборкаРеализация.Следующий() Цикл
                     
                    Если ЗначениеЗаполнено (ВыборкаРеализация.Регистратор) И ТипЗнч(ВыборкаРеализация.Регистратор) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
                          
                        ОбластьСтрока.Параметры.ПоставщикДокумент = " ";
                        ОбластьСтрока.Параметры.Реализация = Строка(ВыборкаРеализация.Регистратор.Контрагент)+ ": " + ВыборкаРеализация.Регистратор;
                        ОбластьСтрока.Параметры.НаНачало = " ";
                        ОбластьСтрока.Параметры.Приход = " ";
                        ОбластьСтрока.Параметры.Расход = ВыборкаРеализация.СуммаДокументаРасход;
                        ОбластьСтрока.Параметры.НаКонец = " ";
                    
                        ЭлементыФормы.Результат.Вывести(ОбластьСтрока,3,"Реализация");
                        
                    КонецЕсли; 
                            
                 КонецЦикла; 
                
            
            КонецЦикла;  
        КонецЦикла; 
    КонецЦикла;              
    
    ЭлементыФормы.Результат.ЗакончитьАвтогруппировкуСтрок();
    
        ОбластьИтого.Параметры.НаНачало = ИтогоНаНачало;
        ОбластьИтого.Параметры.Приход = ИтогоПриход;
        ОбластьИтого.Параметры.Расход = ИтогоРасход;
        ОбластьИтого.Параметры.НаКонец = ИтогоНаКонец;
        
        ЭлементыФормы.Результат.Вывести(ОбластьИтого);
        
    
КонецПроцедуры
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.07.2013, 09:17
Ответы с готовыми решениями:

Ссылка на документ в 1С 8
Всем привет. Как можно получить данные из открытого,текущего документа, в другой модуль программы?...

Как сравнить "этот" документ и документ Док
В модуле формы документа делаем вот такой код Док=СоздатьОбъект("Документ.РасчетНалоговПолн");...

Как перенести продублировать данные из справочника.ЕдиницыИзмерения.Ссылка в справочник КлассификаторЕдиницИзмерения.Ссылка
Ну вапрос таков есть два справочника 1)КлассификаторЕдиницИзмерения и 2) ЕдиницыИзмерения нужна...

в запросе ссылка на текущий документ
Добрый день! Помогите разобраться. Конфигурация 1С8 УТ. Создаю в модуле менеджера функцию...

Отчет, ссылка на документ через регистр накопления
Доброго времени суток, такая проблема: есть документ, есть регистр накопления, есть отчет. В...

2
wade25
145 / 145 / 3
Регистрация: 25.03.2011
Сообщений: 512
19.07.2013, 10:23 2
ОбластьСтрока.Параметры.ПоставщикДокумент = ВыборкаПоставщик.Поставщик;
Меняй на ВыборкаДокументПоставки.ДокументПоставщика;

Если все остальное верно, то норм должно будет быть)
0
Vogde
0 / 0 / 1
Регистрация: 03.01.2013
Сообщений: 75
19.07.2013, 11:15  [ТС] 3
Цитата Сообщение от wade25 Посмотреть сообщение
ОбластьСтрока.Параметры.ПоставщикДокумент = ВыборкаПоставщик.Поставщик;
Меняй на ВыборкаДокументПоставки.ДокументПоставщика;

Если все остальное верно, то норм должно будет быть)
Нет это не То. В ВыборкаПоставщик передается имя поставщика а то о чем ты говоришь есть во второй выборке ВыборкаДокументПоставщика
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.07.2013, 11:15

Ссылка на подчиненный документ
Есть у меня 2 документа Путевой Лист и Списание путевого листа. Списание создается из путевого...

Не определяется ссылка на документ через оповещение()
Добрый день всем! Есть проблема, нахожусь в документе, из документа при заполнении ТЧ создаю новую...

ссылка на документ
Добрый день!Помогите пожалуйста советом. Существует следующая задача . Был создан договор,если по...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.