Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.86/7: Рейтинг темы: голосов - 7, средняя оценка - 4.86
SonicQ
274 / 176 / 16
Регистрация: 20.02.2012
Сообщений: 903
1

Получение итогов

22.07.2013, 17:39. Просмотров 1227. Ответов 13
Метки нет (Все метки)

Всем привет!

В общем дело такое, получаю итоги путем

1C
1
            мБухИтоги.РассчитатьИтоги("Хозрасчетный", Итоги, "Сумма", "Счет", мДатаНачалаПериодаОтчета, мДатаКонцаПериодаОтчета, , , , , , "Организация", мОргРасшифровка);
где
1C
1
мОргРасшифровка
опеределенная организация.
Вопрос: Можно и КАК можно засунуть туда массив, прежде исключив пару троек организаций, так как эти организации закрылись?

Делаю так:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
Функция ПолучитьМассивОрганизаций ();
    Код1 = Справочники.Организации.НайтиПоКоду("232").Код;  
    Код2 = Справочники.Организации.НайтиПоКоду("411").Код;  
    Код3 = Справочники.Организации.НайтиПоКоду("651").Код;  
    
    МассивОрганизушек = новый массив;
    МассивОрганизушек.Добавить(Код1);
    МассивОрганизушек.Добавить(Код2);
    МассивОрганизушек.Добавить(Код3);
    
    
    Запрос = новый запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    Организации.Ссылка
                   |ИЗ
                   |    Справочник.Организации КАК Организации
                   |ГДЕ
                   |    НЕ Организации.Код В ИЕРАРХИИ (&Код)";
Запрос.УстановитьПараметр("Код", МассивОрганизушек);                
РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выгрузить();
 
МассивОрг = новый массив;
 
Для каждого Стр из Выборка цикл
МассивОрг.Добавить(Стр);
 
КонецЦикла;
 
Возврат МассивОрг;
 
    
    
КонецФункции
и вместо
1C
1
мОргРасшифровка
втыкаю туда массив, но ничего не меняется. Получаю совсем не такой результат.

Подскажите, может как то в
1C
1
мБухИтоги.РассчитатьИтоги(***)
как то можно прописать условие (отбор), проштудировал все процедуру, так и не нашел
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.07.2013, 17:39
Ответы с готовыми решениями:

Вывод итогов в отчёте
Здравствуйте! Делаю внешний отчёт на основе Универсального. Как вывести в...

Создание Итогов в Excel
В Excel есть команда ИТОГИ , которая формирует промежуточные итоги, позволяет...

Вывод итогов в запросе
Мне нужно чтобы в итоге не учитывалось кол-во выпуск по статьям затрат но по...

Запрос к регистру накопления с расчетом итогов 1с 8.2
Есть регистр накопления, в котором хранятся записи в разрезе организаций,...

Разбивка по периодам внутри бух.итогов
Добрый день! Нужно реализовать возможность разбивки по периодам внутри периода...

13
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
23.07.2013, 09:31 2
1C
1
Процедура РассчитатьИтоги(Знач РегистрБухгалтерии = 0, Итоги = Неопределено, Ресурсы = Неопределено, Группировки = "", НачалоПериода = Неопределено, КонецПериода = Неопределено, Периодичность = "Период", Счета = Неопределено, ВидыСубконто = Неопределено, КорСчета = Неопределено, ВидыКорСубконто = Неопределено, Фильтры = Неопределено, Значение1 = Неопределено, Значение2 = Неопределено, Значение3 = Неопределено, Значение4 = Неопределено, Значение5 = Неопределено, Значение6 = Неопределено, Значение7 = Неопределено, Значение8 = Неопределено, Значение9 = Неопределено) Экспорт
разберитесь, кушает ли эта процедура массив. Скорее, по отдельным значениям.

Добавлено через 1 минуту
Обработка.БухгалтерскиеИтоги
0
Fenomen
898 / 875 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
23.07.2013, 09:49 3
Цитата Сообщение от SonicQ Посмотреть сообщение
МассивОрг.Добавить(Стр);
Вы здесь добавляете в массив не ссылку на организацию, а строку таблицы значений!
0
SonicQ
274 / 176 / 16
Регистрация: 20.02.2012
Сообщений: 903
23.07.2013, 10:11  [ТС] 4
Цитата Сообщение от Fenomen Посмотреть сообщение
Вы здесь добавляете в массив не ссылку на организацию, а строку таблицы значений!
Сделать вот так

1C
1
мБухИтоги.РассчитатьИтоги("Хозрасчетный", Итоги, "Сумма", "Счет", мДатаНачалаПериодаОтчета, мДатаКонцаПериодаОтчета, , , , , , "Организация", [B]мОргРасшифровка.ссылка[/B]);
???

или вместо массива использовать таблицу значений?

В целом если использовать ТЗ то можно указать прямо
1C
1
мОргРасшифровка.ссылка
, то есть брать определенную ячейку из ТЗ. Я так думаю

Добавлено через 6 минут
Цитата Сообщение от SonicQ Посмотреть сообщение
В целом если использовать ТЗ то можно указать прямо
Код 1C
1
мОргРасшифровка.ссылка
, то есть брать определенную ячейку из ТЗ. Я так думаю
Но при таком способе, необходимо будет делать цикл, чтобы перебрать все строки ТЗ. Это не вариант

Добавлено через 9 минут
Прикол вообще!

Когда запрос

1C
1
2
3
4
5
6
7
    Запрос = новый запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |   Организации.Ссылка
    |ИЗ
    |   Справочник.Организации КАК Организации
    |ГДЕ
    |    Организации.Код В ИЕРАРХИИ (&Код)";
То есть без НЕ, итоги считает правильно

А когда

1C
1
2
3
4
5
6
7
    Запрос = новый запрос;
    Запрос.Текст = "ВЫБРАТЬ
    |   Организации.Ссылка
    |ИЗ
    |   Справочник.Организации КАК Организации
    |ГДЕ
    |   НЕ Организации.Код В ИЕРАРХИИ (&Код)";
теряет 2 организации из трех. Не понимаю(
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
23.07.2013, 10:45 5
Цитата Сообщение от SonicQ Посмотреть сообщение
Не понимаю(
да разберитесь с процедурой в обработке - и всего делов. Что она делает с параметрами Значение1...9. Мне вот, например, недосуг
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
23.07.2013, 10:46 6


Это
1C
1
2
3
 Код1 = Справочники.Организации.НайтиПоКоду("232").Код;  
    Код2 = Справочники.Организации.НайтиПоКоду("411").Код;  
    Код3 = Справочники.Организации.НайтиПоКоду("651").Код;
равно

1C
1
2
3
 Код1 = "232";  
    Код2 = "411";  
    Код3 = "651";
Найдите 10 отличий
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
23.07.2013, 10:53 7
Ой, не говори... Взять хотя бы это
1C
1
2
3
МассивОрганизушек = новый массив;
......
МассивОрг = новый массив;
получать массив из массива запросом...

Добавлено через 42 секунды
просто не в этом суть
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
23.07.2013, 10:53 8
Заменяем все что ты написал на это:

1C
1
2
3
4
5
6
МассивОрганизушек = новый Массив;
МассивОрганизушек.Добавить(Справочники.Организации.НайтиПоКоду("232"));
МассивОрганизушек.Добавить(Справочники.Организации.НайтиПоКоду("411"));
МассивОрганизушек.Добавить(Справочники.Организации.НайтиПоКоду("651"));
 
Возврат МассивОрганизушек;

Процедура рассчитать итоги не принимает массив
0
SonicQ
274 / 176 / 16
Регистрация: 20.02.2012
Сообщений: 903
23.07.2013, 10:56  [ТС] 9
Мне нужно их исключить, а не по ним сформировать, вот и два массива. Вопрос закрыт. Спасибо
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
23.07.2013, 10:56 10
Можно только по одной организации получать итоги
0
SonicQ
274 / 176 / 16
Регистрация: 20.02.2012
Сообщений: 903
23.07.2013, 11:01  [ТС] 11
их 50, причем 3 из них закрывается... зачем мне по одной!)))

PS: промолчу...
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
23.07.2013, 11:03 12
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
МассивОрганизушек = новый Массив;
МассивОрганизушек.Добавить(Справочники.Организации.НайтиПоКоду("232"));
МассивОрганизушек.Добавить(Справочники.Организации.НайтиПоКоду("411"));
МассивОрганизушек.Добавить(Справочники.Организации.НайтиПоКоду("651"));
 
ИтогиОрганизаций = Новый Соотвествие;
 
Для каждого Элемент из МассивОрганизушек Цикл
    СтруктураИтогов = Новый Структура("НачальныйОстатокДт");
    мБухИтоги.РассчитатьИтоги("Хозрасчетный",СтруктураИтогов , "Сумма", "Счет", мДатаНачалаПериодаОтчета, мДатаКонцаПериодаОтчета, , , , , , "Организация", Элемент);
   ИтогиОрганизаций.Вставить(Элемент,СтруктураИтогов);
КонецЦикла;
 
//Получаем соотвествие с ключом - Организация и Значением ИТОГИ
Добавлено через 1 минуту
Цитата Сообщение от SonicQ Посмотреть сообщение
их 50, причем 3 из них закрывается... зачем мне по одной!)))
PS: промолчу...
Эта процедура умеет только по ОДНОЙ организации получать ИТОГИ

Не по теме:

Лучше промолчите.... :)

1
SonicQ
274 / 176 / 16
Регистрация: 20.02.2012
Сообщений: 903
23.07.2013, 11:11  [ТС] 13
Цитата Сообщение от Dethmontt Посмотреть сообщение
Эта процедура умеет только по ОДНОЙ организации получать ИТОГИ
Мои результаты показывают обратное.. Но все равно спасибо за ваше внимание
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
23.07.2013, 11:49 14
Цитата Сообщение от SonicQ Посмотреть сообщение
Мне нужно их исключить, а не по ним сформировать, вот и два массива.
Да, извини, "НЕ" не прочитал.
0
23.07.2013, 11:49
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
23.07.2013, 11:49

7.7 Получение Почты
Добрый день! Задача такая: на почтовый ящик приходят письма с заказами от...

Получение сальдо
Здравствуйте. Версия программы : 1С 7.7 Комплексная конфигурация, редакция 4.5...

Получение остатка
Вообщем есть регистр остатков СуммаОплат; Измерения: Год...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru