Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
sanapad
0 / 0 / 0
Регистрация: 03.07.2013
Сообщений: 3
1

Подставить значение переменной

23.07.2013, 13:49. Просмотров 1216. Ответов 2
Метки нет (Все метки)

Для элементов формы документа: ИмяПункта1, ИмяПункта2...ИмяПункта5, нужно поставить свойство видимость в значении ложь. Подскажите, как это сделать с помощью цикла?
Следующие коды не работают, т.к. "поле объекта не обнаружено ИмяПункта".

1C
1
2
3
4
5
6
7
&НаКлиенте
Процедура СкрытьПункт (Команда)
Для число = 1 ПО 5 Цикл
        ИмяПункта = "Пункт"+число;  
        Элементы.ИмяПункта.Видимость = Ложь;
        КонецЦикла;
КонецПроцедуры
1C
1
2
3
4
5
6
&НаКлиенте
Процедура СкрытьПункт (Команда)
Для число = 1 ПО 5 Цикл
    Элементы.Пункт[число].Видимость = Ложь;
        КонецЦикла;
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.07.2013, 13:49
Ответы с готовыми решениями:

В реквизит документа подставить значение реквизита справочника
Всем привет, кто может помогите! Вообщем, у меня есть справочник сотрудники с реквизитом норма...

Получить значение переменной, используя в качестве оператора строку
Добрый день! Есть переменная "Элемент" которая содержит много разных свойств(Возможно неправильный...

Подставить значение в поле документа
Всем доброго времени суток! Такой вопрос, дорогие форумчане. Сразу прошу не серчать - я новичёк в...

Как автоматически подставить значение в поле
1. Есть справочник Контрагенты и подчиненный ему справочник ВидДоговоров, и есть документ...

Подставить значение из регистра сведений в ТЧ документа
есть регистр сведений который хранит информацию о номерах в гостинице.(Номер - тип...

2
Dethmontt
Модератор
Эксперт 1С
2653 / 2443 / 418
Регистрация: 10.03.2011
Сообщений: 8,742
Записей в блоге: 1
Завершенные тесты: 1
23.07.2013, 14:08 2
1C
1
2
3
4
5
6
7
&НаКлиенте
Процедура СкрытьПункт (Команда)
Для число = 1 ПО 5 Цикл
        ИмяПункта = "ИмяПункта"+число;  
        Элементы[ИмяПункта].Видимость = Ложь;
        КонецЦикла;
КонецПроцедуры
1
sanapad
0 / 0 / 0
Регистрация: 03.07.2013
Сообщений: 3
23.07.2013, 15:39  [ТС] 3
Спасибо, помогло! Проблема была в лишней точке после "элементы".
1C
1
Элементы[ИмяПункта].Видимость = Ложь;
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
23.07.2013, 15:39

Пропадает значение переменной
В программировании 1С не очень силен. Есть внешняя обработка самописная простая, выгружает...

Присвоить значение переменной
В переменную "ДляВывода" не заносятся данные. Что не так? Мне она нужна, чтобы занести ее в...

Значение переменной в окне обработки
Добрый день. С 1С7.7 ранее не работала. Сейчас срочно нужно дописать обработку. А именно: есть...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru