Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/3: Рейтинг темы: голосов - 3, средняя оценка - 5.00
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
1

Операции с массивом

14.08.2013, 14:32. Просмотров 519. Ответов 4
Метки нет (Все метки)

Добрый день всем!

Есть такая ситуация:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
// ===================================
 
Процедура ЧтотоТут()
 
МассивСчет = Новый массив;
МассивСчет.Добавить(ПланыСчетов.Хозрасчетный.НайтиПоКоду("60.01"));
 
// Если подставить МассивСчет.найти() работает
 
ПолучитьМассивРезультата = ПолучениеРезультата(МассивСчет );
 
КонецПроцедуры
 
//======================================
 
Функция ПолучениеРезультата(мСчет)
 
Если мСчет.Найти(ПланыСчетов.Хозрасчетный.НайтиПоКоду("68.05.1")) = Неопределено Тогда // А тут не работает
//ЧтоТоТутСчитаем
Иначе
//Иначе ЧтоТоТутСчитаем
КонецЕсли;
 
Возврат ЧтоТоТутСчитаем;
 
КонецФункции
 
// =====================================
Как это можно объяснить и что делать? Спасибо.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.08.2013, 14:32
Ответы с готовыми решениями:

Операции с массивом
У меня есть двумерный массив arA(x,y). Можно ли как-нибудь совершать действия не с массивом, а с...

Операции с массивом
сгенерировать массив из целочисленных чисел размерностью в 10 элементов ,инициализировать его...

Операции с массивом
Дан массив В(5х5) Найти среднее арифметическое элементов каждой строки, проверить равенство средних...

Операции с массивом
Массив x размером n=20 ввести произвольно записать в текстовый файл прочитать из текстового файла...

Операции с массивом
Всех с наступающим Новым Годом! Подскажите как можно сделать следующее: Есть $item_gallery...

4
Joker_vad
Эксперт 1С
473 / 411 / 92
Регистрация: 26.09.2012
Сообщений: 1,841
14.08.2013, 15:12 2
А что не работает то
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
14.08.2013, 15:30  [ТС] 3
Цитата Сообщение от Joker_vad Посмотреть сообщение
А что не работает то
1C
1
2
{Форма.Форма.Форма(1753)}: Значение не является значением объектного типа (Найти)
    Если мСчет.Найти(ПланыСчетов.Хозрасчетный.НайтиПоКоду("68.05.1")) = Неопределено Тогда
То есть если Метод найти() использовать в процедуре Процедура ЧтотоТут() работает, а если передавать массив в функцию и там использовать метод найти() то не работает
0
Joker_vad
Эксперт 1С
473 / 411 / 92
Регистрация: 26.09.2012
Сообщений: 1,841
14.08.2013, 15:35 4
а у меня работает
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
14.08.2013, 15:37  [ТС] 5
Цитата Сообщение от Joker_vad Посмотреть сообщение
а у меня работает
Сори ... Передавал не существующий массив... Все работает
0
14.08.2013, 15:37
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.08.2013, 15:37

Операции с массивом
Для массива байтов, для каждого элемента массива сбросить 1-й и 2-й байт, установить 1 и 3-й, ...

Операции над массивом
подскажите как делать,особенно 2 и 3 Перепечатайте условие задачи. Настоятельно рекомендую на один...

Операции с массивом данных
Доброго времени суток! Не могу понять почему выбивает ошибку "индекс массива является недопустимым...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru