Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.64/25: Рейтинг темы: голосов - 25, средняя оценка - 4.64
fenlork
1 / 1 / 0
Регистрация: 26.07.2013
Сообщений: 69
1

Запрет на изменение редактирования элементов в группе Справочника

23.08.2013, 15:30. Просмотров 4486. Ответов 8
Метки нет (Все метки)

Делаю подписку на события ПередЗаписью. Есть справочник.МойСправочник, там есть группа "не изменять"-нужно запретить редактирование, перемещение, копирования из этой группы(отказ=истина), а вот добавлять и создавать новые можно.
1C
1
2
3
4
5
//Если Не Источник.ЭтоНовый() И (Источник.Родитель <> "не изменять"-)-не берет то что надо  
Тогда
Отказ = Истина;
Сообщить("Запрет!");
КонецЕсли;
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.08.2013, 15:30
Ответы с готовыми решениями:

1С:8.1 Запрет редактирования элементов формы через роли/права
Необходимо сделать недоступные поля в форме. Возможно ли решить эту проблему административно -...

Открытие Списка Справочника В Предопределенной Группе
Задача такая: на управляемой форме документа есть реквизит типа спр Контрагенты. Как сделать,...

Узнать, в какой группе расположен элемент справочника
Добрый вечер всем. Помогите сделать одну вещь - мне нужно запретить выбор элемента справочника...

Открыть заданный раздел справочника для редактирования. 1с77
Помогите идеями, как открыть заданный раздел справочника для редактирования в 1с77. Сам справочник...

Запрет редактирования
Здравствуйте. Имеется проблема данного характера: Есть приложение WF, компонент DataGridView(в...

8
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
23.08.2013, 16:36 2
Событие ПриОткрытии (либо ПриСозданииНаСервере в случае УФ) там проверяйте родителя и "отказ/возврат" если надо.
0
fenlork
1 / 1 / 0
Регистрация: 26.07.2013
Сообщений: 69
23.08.2013, 16:58  [ТС] 3
ограничены события v8.2 ред.1.3 режим Файловый
0
Миниатюры
Запрет на изменение редактирования элементов в группе Справочника  
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
23.08.2013, 18:30 4
Источник.Родитель... А какое свойство родителя указывает, что - "не изменять"? Он сам? Тогда сравнивайте с параметром, переменной, константой в конце концов, значение которых = этот родитель.
0
23.08.2013, 18:30
Dethmontt
Модератор
Эксперт 1С
2679 / 2460 / 427
Регистрация: 10.03.2011
Сообщений: 8,820
Записей в блоге: 1
Завершенные тесты: 1
24.08.2013, 01:12 5
Цитата Сообщение от fenlork Посмотреть сообщение
ограничены события v8.2 ред.1.3 режим Файловый
Подписки вообще не перехватывают события форм
0
fenlork
1 / 1 / 0
Регистрация: 26.07.2013
Сообщений: 69
25.08.2013, 19:50  [ТС] 6
ребят, подскажите , пож-ста код...
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
25.08.2013, 23:02 7
1C
1
Если Ложь Тогда Отказ=Истина;КонецЕсли;
Добавлено через 54 секунды
или
1C
1
Отказ=НевыполнениеКакого_тоУсловия();
0
Dethmontt
Модератор
Эксперт 1С
2679 / 2460 / 427
Регистрация: 10.03.2011
Сообщений: 8,820
Записей в блоге: 1
Завершенные тесты: 1
26.08.2013, 03:26 8
1C
1
2
3
Если Не Источник.ЭтоНовый() И (ЗначениеЗаполнено(Источник.Родитель) Тогда
   Отказ = (Источник.Родитель.Наименование = "не изменять");
КонецЕсли;
0
fenlork
1 / 1 / 0
Регистрация: 26.07.2013
Сообщений: 69
26.08.2013, 12:19  [ТС] 9
1C
1
2
3
4
Если источник.ссылка.ПринадлежитЭлементу(Справочники.номенклатура.НайтиПоКоду("Ц0000014353")) Тогда
    отказ=истина;
    Сообщить("нельзя");
КонецЕсли;
0
26.08.2013, 12:19
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.08.2013, 12:19

Запрет редактирования
Добрый день, на подформе стоит запрет редактирования на свойстве текущая запись, если нет написей...

Запрет на выбор подгруппы справочника
Здравствуйте уважаемые форумчани. Есть документ Оказание услуги, в табличной части документа есть...

Автосервис. Добавление стандартного списка работ из справочника с возможностью редактирования
Добрый день! Товарищ попросил сделать простенькую базу для его гаражного автосервиса. Не могу...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru