Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.90/10: Рейтинг темы: голосов - 10, средняя оценка - 4.90
leotom
1 / 1 / 0
Регистрация: 20.08.2013
Сообщений: 12
1

Заполнение ТЧ Документа из Реквизитов справочника

23.08.2013, 17:07. Просмотров 1910. Ответов 14
Метки нет (Все метки)

нужно заполнить ТЧ документа из Реквизита справочника.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
&НаКлиенте
Процедура КлиентПриИзменении(Элемент)
Объект.Телефоны = ПолучитьТелефоны(Объект.Клиент);
ЗаполнениеТабЧасти();
КонецПроцедуры
 
&НаСервере
Процедура ЗаполнениеТабЧасти()
Объект.ОплатаКурсов.Очистить();
Для Каждого ТекСтрока Из Объект.Клиент.ИзучаемыеКурсы Цикл
НоваяСтрока=Объект.ОплатаКурсов.Добавить();
НоваяСтрока.Курс=ТекСтрока.Курс;
КонецЦикла ;
 
Для Каждого ТекСтрока Из [B][I]Объект.ОплатаКурсов.Курс.Ссылка.Стоимость[/I][/B] Цикл
НоваяСтрока=Объект.ОплатаКурсов.Добавить();
НоваяСтрока.СтоимостьКурса =ТекСтрока.СтоимостьКурса;
КонецЦикла
КонецПроцедуры
 
 &НаСервереБезКонтекста
Функция ПолучитьТелефоны(Студент)
Возврат Студент.Телефоны;
КонецФункции
При изменении выдает ошибку «Поле объекта не обнаружено (Курс)
Если в палитре свойств Поля «СтоимостьКурса», в ячейки «ПутьКДанным» ставлю «Объект.ОплатаКурсов.Курс.Ссылка.Стоимость »
Тогда все работает, только меняется название поля в табличной части «ОплатаКурса» , вместо «СтоимостьКурса» становиться «Стоимость».
Вопрос :
Как при изменении поля «Клиент» в документе «ВнесениеОплаты» программно прописать Автозаполнение полей «Курс» и «Стоимость Курса»
Автозаполнение поля «Курс» проблем не вызвало. А вот со стоимостью проблемно.
Прошу помощи.
0
Миниатюры
Заполнение ТЧ Документа из Реквизитов справочника   Заполнение ТЧ Документа из Реквизитов справочника   Заполнение ТЧ Документа из Реквизитов справочника  

Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.08.2013, 17:07
Ответы с готовыми решениями:

Заполнение реквизита табличной части документа (строки, из справочника наименования, внутри документа)
Здравствуйте. Волею судеб нужно сваять пару документов в 1с 77. Вроде бы как все шло нормально,...

Автоматическое заполнение полей документа данными из справочника
Помогите пожалуйста с написанием модуля. есть справочник сотрудники с реквизитами: табельный...

Перенос реквизитов справочника в документ
Есть справочник Товары с реквизитами Автор и Журнал. Есть документ Договор с реквизитами Счет и...

Установка реквизитов формы элемента справочника (Пл. - 7.7,Бух. - 4.5)
Необходимо программно снимать на форме элемента справочника флажок, как сделать это? Пл. - 7.7,Бух....

Перенос реквизитов справочника номенклатуры в документ Поступление ТМЦ
Здравствуйте! Есть справочник "Номенклатура" с реквизитами: Код Наименование, Артикул, Есть...

14
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
23.08.2013, 18:42 2
по-моему, циклит просто. Переполнение стека номеров в тч... типа Неопределено.Курс - нет такого поля
0
leotom
1 / 1 / 0
Регистрация: 20.08.2013
Сообщений: 12
23.08.2013, 20:54  [ТС] 3
Смотрел в отладчике - при первом же проходе цикла - выдает ошибку.
Не могу понять в чем дело.

Добавлено через 1 час 13 минут
Так что получается, эту задачу ( в упр.формах) можно решить
только интерактивными методами.

Т.е. ставить в палитре свойств Поля «СтоимостьКурса» -->
--> "ПутьКДанным» -- > Объект.ОплатаКурсов.Курс.Ссылка.Стоимость »

А в коде нет ?!
0
Dethmontt
Модератор
Эксперт 1С
2653 / 2443 / 418
Регистрация: 10.03.2011
Сообщений: 8,746
Записей в блоге: 1
Завершенные тесты: 1
23.08.2013, 21:22 4
Каша.

Добавлено через 2 минуты
В ТЧ "ОплатаКурсов" у курса какой путь к данным?

Добавлено через 8 минут
Ставишь путь к данным - объект.ОплатаКурсов.СтоимостьКурса

Тогда сможешь менять курс так:
1C
1
2
НоваяСтрока.Курс=ТекСтрока.Курс;
НоваяСтрока.СтоимостьКурса=ТекСтрока.Курс.СтоимостьКурса;
1
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
23.08.2013, 21:53 5
Цитата Сообщение от leotom Посмотреть сообщение
Смотрел в отладчике - при первом же проходе цикла - выдает ошибку.
вполне вероятно, что ошибка перехватывается при попытке добавить данные до их получения.

Добавлено через 1 минуту
Голову включить, да? Цикл по таблице с добавлением записи по каждой записи таблицы. Это не абсурд?
1
leotom
1 / 1 / 0
Регистрация: 20.08.2013
Сообщений: 12
23.08.2013, 22:42  [ТС] 6
Поставил путь к данным -"Объект.ОплатаКурсов.СтоимостьКурса".
1C
1
2
3
4
5
6
7
8
9
Процедура ЗаполнениеТабЧасти()
    Объект.ОплатаКурсов.Очистить();
    Для Каждого ТекСтрока Из Объект.Клиент.ИзучаемыеКурсы Цикл
    НоваяСтрока=Объект.ОплатаКурсов.Добавить();
    НоваяСтрока.Курс=ТекСтрока.Курс;
    НоваяСтрока.СтоимостьКурса=ТекСтрока.Курс.СтоимостьКурса;
    КонецЦикла;
    
КонецПроцедуры
Выдает ошибку
{Документ.ВнесениеОплаты.Форма.ФормаДокумента.Форма(14)}: Поле объекта не обнаружено (СтоимостьКурса)
НоваяСтрока.СтоимостьКурса=ТекСтрока.Курс.СтоимостьКурса;

Добавлено через 22 минуты
Компиляция &НаСервере
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
23.08.2013, 23:20 7
Цитата Сообщение от leotom Посмотреть сообщение
ТекСтрока.Курс.СтоимостьКурса
троллинг?
0
Dethmontt
Модератор
Эксперт 1С
2653 / 2443 / 418
Регистрация: 10.03.2011
Сообщений: 8,746
Записей в блоге: 1
Завершенные тесты: 1
24.08.2013, 01:09 8
Попробуйте

НоваяСтрока.СтомостьКурса = НоваяСтрока.Курс.Стоимость;
0
leotom
1 / 1 / 0
Регистрация: 20.08.2013
Сообщений: 12
24.08.2013, 05:54  [ТС] 9
Не выходит
Пишет
{Документ.ВнесениеОплаты.Форма.ФормаДокумента.Форма(15)}: Поле объекта не обнаружено (СтомостьКурса)
НоваяСтрока.СтомостьКурса = НоваяСтрока.Курс.Стоимость;
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
24.08.2013, 16:48 10
leotom, да разберитесь Вы в своих метаданных!
Во-первых, структуры, содержащие дубли значений - маст дай. А у Вас кругом - Курсы да Стоимость... Если уж Вы запутались, то нам просто б*г велел...
Либо выкладывайте сюда конфу - если кто найдёт время её смотреть...
0
leotom
1 / 1 / 0
Регистрация: 20.08.2013
Сообщений: 12
25.08.2013, 19:45  [ТС] 11
Изучаю книгу "Программирование и визуальная разработка" С.Кашаев.
Там рассмотрена эта конфигурация. Решил немного дополнить ее.
Добавил в ТЧ ("ОплатаКурсов") документа ("ВнесениеОплаты") новый реквизит "СтоимостьКурса".
Установил в палитре свойств Поля «СтоимостьКурса»,
«ПутьКДанным» --> «Объект.ОплатаКурсов.Курс.Ссылка.Стоимость . ВсеОк
В документе "ВнесениеОплаты" при открытие реквизита "Клиент" автоматически заполняются
следующие поля: - Телефоны, Курс, СтоимостьКурса.

Потом решил программным способом в процедуре КлиентПриИзменении(Элемент)
сделать автоматическое заполнение поля "СтоимостьКурса" в ТЧ (ОплатаКурсов).
Прикрепляю копию БД - это если кто захочет посмотреть.

Оно не горит, но хочется понять возможно ли программным способом сделать
автоматическое заполнение ТЧ документа из реквизита справочника.
Или в упр.приложении в упр.форме это возможно лишь только
через прямое указание в «ПутьКДанным»
0
Вложения
Тип файла: rar БД_Прог и Визразработка_1.0.2.rar (95.3 Кб, 13 просмотров)
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
25.08.2013, 22:59 12
ну нету стоимости в ТЧ справочника Клиенты, и чо?
0
leotom
1 / 1 / 0
Регистрация: 20.08.2013
Сообщений: 12
25.08.2013, 23:23  [ТС] 13
Так вот как вытащить реквизит "Стоимость" из "Справочник - Курсы"
В принципе задача через ПутьКДанным решается, а программное решение пока для меня в тумане,
в какую строну идти, если через "Объект" не получается, может через Запросы?
0
Dethmontt
Модератор
Эксперт 1С
2653 / 2443 / 418
Регистрация: 10.03.2011
Сообщений: 8,746
Записей в блоге: 1
Завершенные тесты: 1
26.08.2013, 03:03 14
Два варианта документа твой и добавил еще один документ! (Обрати внимание что в твоем варианте я удалил один реквизит из табличной части!!!)
БД_Прог и Визразработка_1.0.3.rar
0
leotom
1 / 1 / 0
Регистрация: 20.08.2013
Сообщений: 12
26.08.2013, 04:39  [ТС] 15
Спасибо за ответ !
0
26.08.2013, 04:39
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.08.2013, 04:39

Максимальное количество реквизитов документа
Кто знает: существуют ли ограничения, накладываемые 1С или dbf или SQL, на максимальное количество...

Автоматическое изменение значений реквизитов документа
У документа имеются следующий реквизиты: фильм, зал, стоимость, вместимость. При изменении...

Реализация системы безопасности на уровне реквизитов документа
Необходимо сделать возможность управления уровнем доступа к реквизитам одного документа в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru