Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
Dobryak007
0 / 0 / 0
Регистрация: 24.08.2013
Сообщений: 5
1

Написать функцию не могу понять этот язык!

24.08.2013, 22:19. Просмотров 827. Ответов 9
Метки нет (Все метки)

Задание такое : ФАМИЛИЯ ИМЯ ОТЧЕСТВО написано в верхнем регистре. Написать функцию, которая будет приводить к виду Фамилия И. О. используя функции ПОКА, ЕСЛИ, ПодСтрока, ВНИЗ .
Решить надо циклом опираясь на то что они разделены пробеломи. ФИО это одна переменная, разбивать на Ф , И, О не надо.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
24.08.2013, 22:19
Ответы с готовыми решениями:

Добрий вечер !Напишите мне кто-нибудь пожалуйста эту программу с комментариями, чтобы я смогла разобраться, потому что никак не могу понять этот язык
создать файл записей (фамилия клиента, паспортные данные, № счета, сумма вклада) с зашифрованным №...

Как понять поставленную задачу. Не могу понять этот полиморфизм
A software academy teaches two types of courses: local courses that are held in some of the...

Не могу понять что значит этот код
Здравствуйте.Не могу понять что значит эта функция в программе: void...

Не могу понять для чего этот тестер
Нашел на складе тестер,не могу понять для чего он.

Не могу понять, что за язык используется
Попал сайт в руки, не могу понять что за язык скриптов в нём используется? Это стоит в начале и...

9
Joker_vad
Эксперт 1С
472 / 410 / 92
Регистрация: 26.09.2012
Сообщений: 1,830
24.08.2013, 22:34 2
Также как в старом добром Паскале. Копируешь все до первого пробела и один символ после. Ищешь второй пробел и копируешь символ после. Ну еще в процессе точки расставляешь
1
redsool
0 / 0 / 0
Регистрация: 24.08.2013
Сообщений: 5
24.08.2013, 22:35 3
Любая строка есть массив символов (можно циклом пройти). Зная это, открываем синтаксис-помощник - общее описание встроенного языка - встроенные функции - функции для строк.

Этих знаний хватит, чтобы решить Вашу задачу)
0
Dobryak007
0 / 0 / 0
Регистрация: 24.08.2013
Сообщений: 5
24.08.2013, 22:48  [ТС] 4
Цитата Сообщение от Joker_vad Посмотреть сообщение
Также как в старом добром Паскале. Копируешь все до первого пробела и один символ после. Ищешь второй пробел и копируешь символ после. Ну еще в процессе точки расставляешь
а как эти функции между собой пересекаются на этом языке ?? вот я чего понять не могу.
0
Joker_vad
Эксперт 1С
472 / 410 / 92
Регистрация: 26.09.2012
Сообщений: 1,830
24.08.2013, 23:07 5
Пока = while, подстрока = copy, Если = if
1
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
24.08.2013, 23:27 6
Цитата Сообщение от Dobryak007 Посмотреть сообщение
а как эти функции между собой пересекаются на этом языке ?? вот я чего понять не могу.
можете включить "eng", хотя, какой смысл, если типовые решения на "ru"
Цитата Сообщение от Dobryak007 Посмотреть сообщение
ФАМИЛИЯ ИМЯ ОТЧЕСТВО
- на латинице?
0
Dobryak007
0 / 0 / 0
Регистрация: 24.08.2013
Сообщений: 5
26.08.2013, 00:38  [ТС] 7
Цитата Сообщение от duk337 Посмотреть сообщение
можете включить "eng", хотя, какой смысл, если типовые решения на "ru" - на латинице?
нет на русском. надо написать функцию используя только 4 встроенные функции Пока, если , подстрока, вниз!
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
26.08.2013, 02:20 8
А что за функция такая подстрока?
0
Dobryak007
0 / 0 / 0
Регистрация: 24.08.2013
Сообщений: 5
26.08.2013, 11:50  [ТС] 9
Цитата Сообщение от Dethmontt Посмотреть сообщение
А что за функция такая подстрока?
ПодСтрока (строка, начало,[длинна])
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
26.08.2013, 21:37 10
Сколько раз можно использовать Пока, если , подстрока, вниз! ???

Добавлено через 9 минут
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
&НаКлиенте
Процедура Команда1(Команда)
    
    Сообщить(ПривестиФИОКВиду("ПЕТРОВ ИВАН ИВАНОВИЧ"));
    
КонецПроцедуры
 
 
//Привести к виду Петров И.И.
//Условие:
//Можно использовать только функции
//Сред() = Подстрока
//Нрег() = Вниз
//и операторы 
//Если КонецЕсли и Пока Цикл
&НаКлиенте
Функция ПривестиФИОКВиду(Знач Фио)
    
    Флаг=Истина;
    сч=1;
    НовоеФио = сред(Фио,1,1);
    Пока Истина Цикл
        сч=сч+1;
        Если Сред(Фио,сч,1)="" Тогда
            Возврат НовоеФио;
        КонецЕсли;  
        Если Флаг тогда
            НовоеФио = НовоеФио+НРег(Сред(ФИО,сч,1));
        КонецЕсли;  
        Если Сред(Фио,сч,1) = " " Тогда
            Флаг=Ложь;
            сч=сч+1;
            НовоеФио = НовоеФио+Сред(фИО,сч,1)+".";
        КонецЕсли;
    КонецЦикла;
    
КонецФункции
0
26.08.2013, 21:37
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.08.2013, 21:37

Не могу понять как работает этот код в деталях
dg1->Rows->Clear();//Очищяет в датагриде строки ifstream infile...

Не могу понять для чего нужен этот участок кода
Не могу понять что он делает !!! Так то понятно что метод FileExists поверяет директорию на наличие...

Не могу понять этот код перевода с двоичной системы в десятичную, обьясните пожалуйста
int biennial_transformer(void) { char ch; long long n; do { ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru