Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
Albionus
0 / 0 / 0
Регистрация: 18.07.2013
Сообщений: 13
1

Запрос по регистру

26.08.2013, 16:14. Просмотров 734. Ответов 1
Метки нет (Все метки)

Здравствуйте уважаемые форумчане , прошу объяснить пока не понимающему человеку о запросах в 1С 7.7 , не могу понять почему при запросе в таблице отображаются только 2 последних введенных товара? хотя в течении 7 дней были введены разные товары.

Заранее Огромное Спасибо всем кто откликнется.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
//*******************************************
// Процедура генерации запроса Сформировать.
//
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Док = Регистр.ОстаткиТоваров.ТекущийДокумент;
    |Товар = Регистр.ОстаткиТоваров.Товар; 
    |Склад = Регистр.ОстаткиТоваров.Склад;
    |Количество = Регистр.ОстаткиТоваров.ОстатокТовара;
    |Цена = Регистр.ОстаткиТоваров.СтоимостьТовара;
    |Расходы = Регистр.ОстаткиТоваров.Расходы;
    |Функция КонОстТов = КонОст(Количество);
    
    |Группировка Товар;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
 
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    
    Пока Запрос.Группировка("Товар") = 1 Цикл
        // Заполнение полей Сформировать
        Таб.ВывестиСекцию("Сформировать");
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.08.2013, 16:14
Ответы с готовыми решениями:

Запрос По Регистру В 7.7
В базе есть отчет, который раньше работал правильно Потом в регистр добавили измерение и отчет...

Запрос По Регистру Бухгалтерии
Догадываюсь, что программисты "любят" регистр бухгалтерии. Мне вот приходится осваивать. Задача...

Запрос к регистру накоплений
ВЫполняю запрос, а вытащить данные не получается из него(данные не отображаются в табличном...

8.1 Запрос по регистру бухгалтерии
Нужно создать отчет по остаткам по Д 60.2 и кредиту 60.1. При этом остатки должны выводиться только...

Запрос к регистру сведений в УТ
Доброго времени! Скажите пожалуйста, как передать в параметр запроса к регистру сведений несколько...

1
Xomych
667 / 589 / 90
Регистрация: 01.11.2012
Сообщений: 2,090
26.08.2013, 17:03 2
Ну видимо остаток есть только по этим товарам
1
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.08.2013, 17:03

Запрос к регистру накопления с расчетом итогов 1с 8.2
Есть регистр накопления, в котором хранятся записи в разрезе организаций, складов и номенклатуры....

Построить запрос по непереодическому регистру сведений
Доброго времени суток господа программисты ! Вопрос в следующем: Есть непериодический регистр...

Запрос По Регистру Продажи Возвращает Пустую Дату
Добрый день, уважаемые знатоки!!! Давненько не обращался за помощью, но возникла реально...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru