Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
Albionus
0 / 0 / 0
Регистрация: 18.07.2013
Сообщений: 13
1

Сложение в таблице

27.08.2013, 20:54. Просмотров 787. Ответов 10
Метки нет (Все метки)

Всем Привет , вопрос такой : после запроса в таблице отображается цена на разные товары(ну и соответственно и разная цена) возможно ли такое чтобы ячейки с ценой складывались в одну сумму и отображались в другой ячейке и в другой секции?

Извиняюсь за возможную некорректность моих вопросов.
Заранее огромная благодарность за ответ и понимание!
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.08.2013, 20:54
Ответы с готовыми решениями:

Сложение больших чисел
Ребят необходимо сложит два больших числа (до 30-ти знаков). Как это сделать?...

картинка в таблице
Реально ли засунуть картинки в строки таблицы формы так, чтобы каждая картинка...

Вкладки в таблице
Доброго всем времени суток! Подскажите конфа 8.2, есть справочник, в нем некие...

Поиск в Таблице значений (7.7)
Здравствуйте. Возник срочный вопрос по поиску в Таблице значений. Есть...

Обращение к таблице значений
Есть документ, он состоит из 3-х таблиц значений. Как из другого документа или...

10
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
27.08.2013, 20:59 2
наверно да
0
Albionus
0 / 0 / 0
Регистрация: 18.07.2013
Сообщений: 13
27.08.2013, 21:02  [ТС] 3
ладно как сложить все цены в одну сумму
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
27.08.2013, 21:26 4
цена1 + цена2 + ... + ценаN

переформулируйте или хоть в картинках покажите
1
Albionus
0 / 0 / 0
Регистрация: 18.07.2013
Сообщений: 13
27.08.2013, 21:33  [ТС] 5
Сложение в таблице


вот где "Всего" там сумма сложенных цен должна быть

соответственно если товары будут пополнятся тогда и цены складываться
0
Xomych
665 / 588 / 89
Регистрация: 01.11.2012
Сообщений: 2,084
27.08.2013, 21:38 6
Всего=Цена1*кол1+Цена2*кол2 и т.д.
1
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
27.08.2013, 21:40 7
Цитата Сообщение от Xomych Посмотреть сообщение
Всего=Цена1*кол1+Цена2*кол2 и т.д.
это не "сумма сложенных цен"

Добавлено через 18 секунд
запрос в студию
1
Albionus
0 / 0 / 0
Регистрация: 18.07.2013
Сообщений: 13
27.08.2013, 21:41  [ТС] 8
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Док = Регистр.ОстаткиТоваров.ТекущийДокумент;
    |Изготовитель = Регистр.ОстаткиТоваров.Товар.Изготовитель;
    |Страна =  Регистр.ОстаткиТоваров.Товар.Страна;
    |Товар = Регистр.ОстаткиТоваров.Товар;
    |Артикул = Регистр.ОстаткиТоваров.Товар.Артикул;
    |Склад = Регистр.ОстаткиТоваров.Склад;
    |Количество = Регистр.ОстаткиТоваров.ОстатокТовара;
    |Цена = Регистр.ОстаткиТоваров.СтоимостьТовара;
    |Расходы = Регистр.ОстаткиТоваров.Расходы;
    |Функция КонОстТов = КонОст(Количество);
    |Условие (Товар в выбТовар);
    |Условие (Изготовитель в выбИзготовитель );
    |Условие (Страна в выбСтрана);
    |Группировка Товар;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
 
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    
    Пока Запрос.Группировка("Товар") = 1 Цикл
        // Заполнение полей Сформировать
         Если флСклад = 1 Тогда
        Таб.ТолькоПросмотр(1);
        Таб.ПрисоединитьСекцию("Склад");
            КонецЕсли;
        Таб.ВывестиСекцию("Сформировать");
    КонецЦикла;
       Таб.ТолькоПросмотр(1);
       Таб.ВывестиСекцию("Всего");
 
     
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
27.08.2013, 21:41 9
Albionus, наверно прав Xomych, и вам нужна таки итоговая стоимость всего на складе, а не сумма цен?
1
Xomych
665 / 588 / 89
Регистрация: 01.11.2012
Сообщений: 2,084
27.08.2013, 21:42 10
Цитата Сообщение от wladimir_ui Посмотреть сообщение
это не "сумма сложенных цен"

Добавлено через 18 секунд
запрос в студию
Ну, ты знаешь, я просто подумал, что человек неправильно выразился
1
Albionus
0 / 0 / 0
Регистрация: 18.07.2013
Сообщений: 13
27.08.2013, 22:00  [ТС] 11
Точна сейчас попробую оттуда капнуть..

Добавлено через 16 минут
Спасибо огромное получилось,добавил просто фунцию , просто думал что можно как-то в таблице это делать,а оказалось все намного проще
0
27.08.2013, 22:00
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
27.08.2013, 22:00

поискт по таблице значений
у меня при переборе строк ТЗ ищется соответствие в ТЗЦены. Если находится...

Как отслеживать изменения в таблице?
Существует большой коллектив, насчитывающий несколько сотен сотрудников. Есть...

Изменение данных в "системной" таблице 1С
Доброе время суток, господа. Конфигурация 1С Зарплата+кадры. Взял Российскую...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru