Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
1

Форма Списка

28.08.2013, 16:50. Просмотров 1129. Ответов 10
Метки нет (Все метки)

Подскажите, у меня есть документ, если он подписан то редактирование в нем запрещено, я хочу создать новый документ кнопкой Добавить копирование подписанный документ, он остается не активным, как можно делать чтобы при добавлении копирование документ снова был активным.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
28.08.2013, 16:50
Ответы с готовыми решениями:

форма списка
Вот смотрите, на формесписка, пустые суммы -это те суммы которые указаны в документа на закладке...

Форма списка Документа
Я заполняю документ Форма и провожу, он отобразился в форме списка, потом заполняю и провожу...

отбор в форма списка
1с 8.1 Необходимо чтобы в форме списка выводились лишь те записи которые удовлетворяют...

Форма списка (добавление флажка)
Здравствуйте. Вот такая небольшая загвоздка вышла, нужно решить следующую задачу: в форме списка...

Форма списка документа не обновляет поле
Формы управляемые, в форме документа добавлена собственная кнопка, при нажатии которой документ...

10
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
28.08.2013, 21:23 2
В событии ДокументСписокПередНачаломДобавления(Элемент, Отказ, Копирование) есть реакция на копирование. Как правило, вопросов не возникает по поводу, какие реквизиты очистить, если поднят флажок "Копирование"
1
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
29.08.2013, 11:23  [ТС] 3
duk337, Сделал
1C
1
2
3
4
5
6
7
8
9
10
Процедура СписокПередНачаломДобавления(Элемент, Отказ, Копирование)
    
        ЭлементыФормы.Дата1.Доступность = Истина;
        ЭлементыФормы.Дата2.Доступность = Истина;
        ЭлементыФормы.ФормаПЗ.Доступность =Истина;
        ЭлементыФормы.Форма.Колонки.Номенклатура.Доступность = Истина;
        ЭлементыФормы.Форма.Колонки.Количество.Доступность = Истина;
        ЭлементыФормы.Форма.Колонки.Цена.Доступность = Истина;
 
КонецПроцедуры
Тепер реквизиты постоянно активны а мне нужно только после копирования чтобы были активны
0
Augusto
70 / 70 / 1
Регистрация: 18.12.2012
Сообщений: 390
29.08.2013, 12:36 4
Ты не доступность включай, а Подписан = Ложь делай

Добавлено через 4 минуты
Или условие ставь
1C
1
2
3
Если Копирование Тогда
 ...
КонецЕсли;
1
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
29.08.2013, 15:36  [ТС] 5
Augusto, я не могу обратиться к Подписан. Реквизит этот в форме документа а не в писке как к нему обратиться?
0
Augusto
70 / 70 / 1
Регистрация: 18.12.2012
Сообщений: 390
29.08.2013, 16:01 6
Если честно, не знаю. Как вариант воткнуть его в форму списка.
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
29.08.2013, 16:26 7
Ermak27, не трогай форму списка, колупай модуль формы элемента

1C
1
2
3
4
5
6
Процедура ПриОткрытии()
........
    Если ЭтоНовый() Тогда
        Если ПараметрОбъектКопирования <> Неопределено Тогда
            подписан = ХренТоТам
.....
1
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
29.08.2013, 16:32 8
ну и бардак. надо сделать по-людски: реквизит "статус документа" (или как там у Вас), по которому в форме регулируется доступность. А при копировании его сбрасывать. в "Новый" или в "Ложь" или как там у Вас
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
29.08.2013, 16:47  [ТС] 9
wladimir_ui, не работает

1C
1
2
3
    Если ЭтоНовый() и ПараметрОбъектКопирования <> Неопределено Тогда
        ЭлементыФормы.Подписан.Значение = Ложь;
    КонецЕсли;
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
29.08.2013, 16:54 10
duk337, при "ДокументСписокПередНачаломДобавления" новый объект еще не существует


Цитата Сообщение от Ermak27 Посмотреть сообщение
wladimir_ui, не работает

1C
1
2
3
    Если ЭтоНовый() и ПараметрОбъектКопирования <> Неопределено Тогда
        ЭлементыФормы.Подписан.Значение = Ложь;
    КонецЕсли;
ЭлементыФормы тоже не трогай, реквизит зануляй
Подписан = Ложь
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
29.08.2013, 17:16 11
ЭлементыФормы.Подписан.Значение = Ложь; - это чушь собачья, поскольку событие в форме списка, а не объекта. А я весь синт.пом наизусть не помню. Кроме того При открытии если это новый достаточно.
0
29.08.2013, 17:16
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.08.2013, 17:16

Вычисляемая колонка. Форма списка справочника
Всем доброго дня! Меня зовут Юлия, я учусь программировать на 1С 8.2. Обращаюсь ко всем, кто более...

Форма списка документа Реализация товаров и услуг
Помогите пожалуйста!!! Нужно добавить новую колонку, в которой будет отражаться задолженость...

Форма списка на табличном поле (класс ПоставщикДанных)
Все привет. 1С v7.7 Нужна помощь вот в каком вопросе. Переписываю стандартную форму списка...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru