Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.82/17: Рейтинг темы: голосов - 17, средняя оценка - 4.82
fenlork
1 / 1 / 0
Регистрация: 26.07.2013
Сообщений: 69
1

Сделать Банковский счет-основным

29.08.2013, 15:00. Просмотров 3303. Ответов 5
Метки нет (Все метки)

// v.8.2 конфа ред.1.3, файловая///
Задача:сделать в спр. Контрагенты на закладке "счета и договоры"такую функцию, чтобы при записи нового банковсного счета-сделалась проверка, если уже есть основной банковский счет-то просто записать, если нет , то записанный назначить основным.
Что наработанно(не совсем то, что надо): в модуле Элемента спр.контрагенты в процедуре перед записью
1C
1
2
3
4
5
6
7
8
9
10
11
12
ПроверитьПометкуКнопкиУстановкиОсновногоБанковскогоСчета();
 
   Если ЭлементыФормы.БанковскиеСчета.ТекущиеДанные = Неопределено Тогда
        Возврат;
    КонецЕсли; 
    
    Если НЕ ЗначениеЗаполнено(ЭлементыФормы.БанковскиеСчета.ТекущиеДанные.Ссылка) Тогда
        Возврат;
    КонецЕсли;
    если элементыформы.основнойБанковскийСчет=Справочники.БанковскиеСчета.ПустаяСсылка() тогда
    ОсновнойБанковскийСчет =ЭлементыФормы.БанковскиеСчета.ТекущаяСтрока.Ссылка;
    КонецЕсли;
при дабавление элемента нового-проверяеться, если уже основной установлен(кнопкой)-то ничего не делает, если не установлен, то еще нужно дополнительно нажать "записать" спрКонтрагенты" и тагда-о чудо! Но так делать нельзя-нужно делать это все в спр.Банковские счета и при записи элемента-сразу делать проверку на основной. Помогите переделать код или хотя бы подскажите-т.к. плохо ориентируюсь в синтаксисе((спасибо заранее

Добавлено через 31 минуту
10.
1C
1
основнойБанковскийСчет=Справочники.БанковскиеСчета.ПустаяСсылка() тогда
Добавлено через 3 часа 10 минут
может хоть кто нить , что посоветует?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.08.2013, 15:00
Ответы с готовыми решениями:

УНФ. Как изменить банковский счет в уже созданных счетах на оплату?
1С Предприятие 8.3 Управление небольшой фирмой 1.6 у предприятия в системе 2 банковских счёта....

банковский счет
написал программу банковский счет... видимо синтаксис не правильный помогите разобраться должно...

Класс «Банковский счет»
задание: Разработать класс «Банковский счет», обеспечить возможность добавления и снятия денег со...

Банковский счет в Google Checkout
Недавно опубликовал приложение в Google Play. Если я не укажу информацию о банковском счете в...

Разработать класс, инкапсулирующий банковский счет
Разработать класс, инкапсулирующий банковский счет (номер счета, баланс, ФИО владельца, валюта...

5
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
29.08.2013, 15:27 2
в спр.Банковские счета при записи(а лучше после записи) элемента смотрите - есть ли у контрика основной счет, и если нету - влупляйте

Добавлено через 2 минуты
конфа ред.1.3 - что это?
0
fenlork
1 / 1 / 0
Регистрация: 26.07.2013
Сообщений: 69
29.08.2013, 15:38  [ТС] 3
упп

Добавлено через 2 минуты
примерчик можно?плохо знаком с языком
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
29.08.2013, 19:23 4
для формы элемента спр.БанковскийСчет допилите в событие ПослеЗаписи код
1C
1
2
3
4
5
6
7
Процедура ПослеЗаписи()
    Если Владелец.ОсновнойБанковскийСчет = Справочники.БанковскиеСчета.ПустаяСсылка() Тогда
        Контра = Владелец.ПолучитьОбъект();
        Контра.ОсновнойБанковскийСчет = Ссылка;
        Контра.Записать()
    КонецЕсли
КонецПроцедуры
Добавлено через 1 минуту
как то так...

Добавлено через 4 минуты
упп можно? плохо знаком с предметом
1
fenlork
1 / 1 / 0
Регистрация: 26.07.2013
Сообщений: 69
30.08.2013, 11:50  [ТС] 5
Было б еще здорово выделить основнойсчет выделить-жирным шрифтом...
0
fastumgel
32 / 32 / 3
Регистрация: 11.02.2012
Сообщений: 91
30.08.2013, 14:15 6
1C
1
2
3
4
5
6
7
8
9
10
11
Перем мЖирныйШрифт;
 
Процедура ДоговорыПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
 
    Если ЗначениеЗаполнено(ДанныеСтроки.Ссылка) И ЭтотОбъект.ОсновнойДоговорКонтрагента = ДанныеСтроки.Ссылка Тогда
        ОформлениеСтроки.Шрифт = мЖирныйШрифт;
    КонецЕсли;
 
КонецПроцедуры
 
мЖирныйШрифт  = Новый Шрифт(,, Истина);
под себя подправишь
1
30.08.2013, 14:15
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.08.2013, 14:15

Создать класс Банковский Счет с полями
Создать класс Банковский Счет с полями: номер счета, валюта, остаток, дата открытия, имя...

Вкладчик положил на банковский счет n рублей
Вкладчик положил на банковский счет n рублей. Каждый год на сумму вклада начисляется k процентов...

Анонимный банковский счет + ATM карта
Здравствуйте! Существует возможность поставки в Россию на эксклюзивных условиях анонимных счетов...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru