Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.58/12: Рейтинг темы: голосов - 12, средняя оценка - 4.58
BVladimir2
15 / 15 / 0
Регистрация: 26.02.2013
Сообщений: 355
1

8.3 Упр.приложение - Как "красивее" записать элемент справочника ?

01.09.2013, 15:00. Просмотров 2272. Ответов 6
Метки нет (Все метки)

Необходимо при записи нового элемента справочника создать др.элементы с указанием ссылки на этот основной элемент - если делать это в модуле объекта в обработчике "перед записью" то еще нет ссылки на основной элемент, а если в обработчике "при записи" то объект уже не новый. Вопрос, собственно как мне в одной, желательно, транзакции записать и новый основной элемент и создать др. элементы с правильными ссылками ?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.09.2013, 15:00
Ответы с готовыми решениями:

Cоздать ссылку на реквизит "Наименование" справочника "Специалисты" из справочника "ЗаявкаНаОбучениеКлиентов"
Пожалуйста, подскажите. Необходимо создать ссылку на реквизит "Наименование"...

8.3 Упр.прил. - Как "раскрыть" COM объект ?
Ситуация такая - есть действующее CОМ соеденение с Excel, задача - определить...

8.3 Упр.Прил.: Получить ссылку на элемент справочника из базы 7.7 ?
Есть два справочника в базе на 7.7- в одном из справочников ("ПасТех") есть...

8.3 Упр.Прил.: Получить ссылку на элемент Подчиненного справочника из базы 7.7 ?
Подключаюсь к базе 1С 7.7. через СОМ, беру данные из нужн. справочника...

Не получается скопировать выделенные строчки из справочника "Сотрудники" в форму "Выбор"
Здравствуйте! У меня опыта работы с 1С мало поэтому хотел попросить помощи у...

6
Xomych
665 / 588 / 89
Регистрация: 01.11.2012
Сообщений: 2,080
01.09.2013, 15:27 2
Проверку поставь, если элементы уже созданы, то дальше, если нет, то создаешь
0
BVladimir2
15 / 15 / 0
Регистрация: 26.02.2013
Сообщений: 355
01.09.2013, 15:38  [ТС] 3
Цитата Сообщение от Xomych Посмотреть сообщение
Проверку поставь, если элементы уже созданы, то дальше, если нет, то создаешь
Не то, мне нужно создавать др.элементы только если основной элемент новый, и в ревизитах этих создаваемых элементов должна быть ссылка на основной еще не записанный элемент...
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
01.09.2013, 16:27 4
Цитата Сообщение от BVladimir2 Посмотреть сообщение
если делать это в модуле объекта в обработчике "перед записью" то еще нет ссылки на основной элемент
Используйте
1C
1
2
НоваяСсылка = Справочники.ВашСправочник.ПолучитьСсылку(Новый УникальныйИдентификатор());
УстановитьСсылкуНового(НоваяСсылка);
Соответственно в других элементах используете переменную НоваяСсылка, для указания создаваемого элемента.
1
BVladimir2
15 / 15 / 0
Регистрация: 26.02.2013
Сообщений: 355
01.09.2013, 20:28  [ТС] 5
Так и сделал - только просто ПолучитьСсылку без уник.индетефикатора.Но думалось, может есть какой "красивый" способ с обработчиками там или еще чего...
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
01.09.2013, 21:23 6
Где то встречал в типовых такую фигню:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
//Код не скопирован, а написан по памяти (и имена переменных)
Перем глЭтоНовый Экспорт;
 
Процедура ПередЗаписью(Отказ)
   
   глЭтоНовый = ЭтоНовый();
 
КонецПроцедуры
 
Процедура ПриЗаписи()
 
   Если глЭтоНовый Тогда
       //Это новый и есть ссылка
   КонецЕсли;
 
КонецПроцедуры
1
BVladimir2
15 / 15 / 0
Регистрация: 26.02.2013
Сообщений: 355
02.09.2013, 17:11  [ТС] 7
Цитата Сообщение от Dethmontt Посмотреть сообщение
Где то встречал в типовых такую фигню:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
//Код не скопирован, а написан по памяти (и имена переменных)
Перем глЭтоНовый Экспорт;
 
Процедура ПередЗаписью(Отказ)
   
   глЭтоНовый = ЭтоНовый();
 
КонецПроцедуры
 
Процедура ПриЗаписи()
 
   Если глЭтоНовый Тогда
       //Это новый и есть ссылка
   КонецЕсли;
 
КонецПроцедуры

Красиво ! Спасибо.
0
02.09.2013, 17:11
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.09.2013, 17:11

ЗуП -> добавление картинки в форму списка "справочника сотрудники"
Здравствуйте уважаемые программисты . приму любой совет от знающих людей ....

Как отображать нужное поле справочника в текстовом поле? (упр)
У меня есть 2 справочника: Товары и СтраныПроизводители. В...

Для заданого 0<=n<=200.Расматриваемого как возраст человека,вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет".
МОЙ ВОЗРАСТ. Для заданого 0&lt;=n&lt;=200.Расматриваемого как возраст...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru