Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.90/10: Рейтинг темы: голосов - 10, средняя оценка - 4.90
OlgaN
7 / 7 / 5
Регистрация: 24.05.2012
Сообщений: 26
1

Нужно создать документ "Перемещение"

01.09.2013, 22:41. Просмотров 1908. Ответов 5
Метки нет (Все метки)

Добрый день!

Изучаю 1С, стоит задание - создать документ "Перемещение", который бы перемещал товары со склада на склад (регистр "ОстаткиНоменклатуры"), Склады - отдельный справочник. Сделала конструктором движений - в 1С: Предприятие провожу, ошибки не выдает, но ноль реакции (по регистру не проходит). Догадываюсь, что стоит написать запрос, который должен бы получать данные из регистра "ОстаткиНоменклатуры" и собственно документа, и потом это как-то использовать в создании движений, но не понимаю, как. Помогите, пожалуйста

Спасибо!

З.Ы.: 1С Предприятие 8.2, Каркасная конфигурация

З.З.Ы.: Если что, пока обработка проведения выглядит так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Процедура ОбработкаПроведени(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
 
    // регистр ОстаткиНоменклатуры Расход
    Движения.ОстаткиНоменклатуры.Записывать = Истина;
    Для Каждого ТекСтрокаТовары Из Товары Цикл
        Движение = Движения.ОстаткиНоменклатуры.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
        Движение.Период = Дата;
        Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
        Движение.Склад = СкладОтправитель;
        Движение.Партия = Ссылка;
        Движение.Количество = ТекСтрокаТовары.Количество;
    КонецЦикла;
    
    Движения.ОстаткиНоменклатуры.Записывать = Истина;
    Для Каждого ТекСтрокаТовары Из Товары Цикл
        Движение = Движения.ОстаткиНоменклатуры.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Движение.Период = Дата;
        Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
        Движение.Склад = СкладПолучатель;
        Движение.Партия = Ссылка;
        Движение.Количество = ТекСтрокаТовары.Количество;
    КонецЦикла;
 
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.09.2013, 22:41
Ответы с готовыми решениями:

Создать универсальный документ "Поступления"
Помогитеили хотя бы подскажите, как создать универсальный документ, который...

Сохранить документ "Счет" в формате Excel по кнопке на форме
Добрый день печать счета происходит из документа ЗаказКлиента, печать - Счет на...

Ввод начальных остатков колонка "Партия (документ поставки)"
В документе ввод начальных остатков по 10 счету существует колонка...

Необходимо проверить исправен и работает ли документ "ГТД по импорту" в 1c
Необходимо проверить исправен и работает ли документ "ГТД по импорту" в 1c

УПП. Документ "УстановкаЦенНоменклатуры"
Доброго времени суток. Люди, может кто сталкивался с этим документом, помогите...

5
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
01.09.2013, 22:54 2
НА первый взгляд все верно. Движения должны быть.
1
Kubus
20 / 20 / 0
Регистрация: 29.08.2013
Сообщений: 57
01.09.2013, 22:55 3
Название предопределенной процедуры неполное
1C
1
Процедура ОбработкаПроведени(Отказ, Режим)
, "я" в конце нет. Может из-за этого не проводит.
Да. и с 16 по 19 строки кода можно удалить, конструктор не оптимален
1
OlgaN
7 / 7 / 5
Регистрация: 24.05.2012
Сообщений: 26
01.09.2013, 23:21  [ТС] 4
Цитата Сообщение от Kubus Посмотреть сообщение
Название предопределенной процедуры неполное
1C
1
Процедура ОбработкаПроведени(Отказ, Режим)
, "я" в конце нет. Может из-за этого не проводит.
Да. и с 16 по 19 строки кода можно удалить, конструктор не оптимален
Спасибо, дело было именно в "я".
0
Dethmontt
01.09.2013, 23:35
  #5

Не по теме:

Ужс... На форум такое постить...

0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
02.09.2013, 08:37 6
Да нормально... Это-то как раз штатная, доступная любому прогеру ошибка (снёс случайно символ - и в голову не придёт проверить)... Вот если б табличной части не было...

Добавлено через 7 минут
Хотя вот хочу добавить: первое же действие в подобном случае - точка останова в обработке проведения. Второе - озадачиться фактом "неостанова" при проведении...
0
02.09.2013, 08:37
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.09.2013, 08:37

1С 8.2 Розница - "Текущая цена розницы", "Остаток" в форме элемента "Номенклатура"
Всем добрый день! Нужна помощь. В Форму элемента "Номенклатура" нужно...

Для заданого 0<=n<=200.Расматриваемого как возраст человека,вывести фразу вида: "Мне 21 год", "Мне 32 года", "мне 12 лет".
МОЙ ВОЗРАСТ. Для заданого 0&lt;=n&lt;=200.Расматриваемого как возраст...

Cоздать ссылку на реквизит "Наименование" справочника "Специалисты" из справочника "ЗаявкаНаОбучениеКлиентов"
Пожалуйста, подскажите. Необходимо создать ссылку на реквизит &quot;Наименование&quot;...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru