Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.71/24: Рейтинг темы: голосов - 24, средняя оценка - 4.71
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
1

Внешний регламентированный отчет

02.09.2013, 13:52. Просмотров 4843. Ответов 20
Метки нет (Все метки)

Всем привет!

Написал свой регламентированный отчет, формируется и записывается в документ "Регламентированный отчет" нормально, также при повторном открытии его все данные получаю... но ... не получается заполнить ячейку макета.

конструкция типовых регл. отчетов такая :

Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
    // восстановим сохраненные данные редактируемых ячеек
    СписокСохранения.Свойство( "ПоказателиОтчета", ПоказателиОтчета );
 
    Для Каждого ПоказателиСтраницы Из ПоказателиОтчета Цикл
        ИмяТекТабличноеПоле = ПоказателиСтраницы.Ключ;
        ТекТабличноеПоле    = ЭлементыФормы[ИмяТекТабличноеПоле];
        ПоказателиТаблПоле  = ПоказателиСтраницы.Значение;
 
        Для Каждого Показатель Из ПоказателиТаблПоле Цикл
            ИмяПоказателя       = Показатель.Ключ;
            ЗначениеПоказателя  = Показатель.Значение;
 
            // установим значение в таблице
            Попытка
                ТекТабличноеПоле.Области[ИмяПоказателя].Значение = ЗначениеПоказателя;
            Исключение
            КонецПопытки;
        КонецЦикла;
    КонецЦикла;


но так как он внешний ,
1C
1
ТекТабличноеПоле.Области[ИмяПоказателя].Значение = ЗначениеПоказателя;
не работает

пробовал такие варианты как :

1C
1
2
3
4
5
    Макет = ЭлементыФормы.ПолеТабличногоДокумента1;
 
    Макет.Области[ИмяПоказателя].Значение = ЗначениеПоказателя;
    Макет.Область(ИмяПоказателя).Значение = ЗначениеПоказателя;
    Макет.Области.Получить(ИмяПоказателя).Значение = ЗначениеПоказателя;
не работает...

Подскажите, может кто сталкивался. Спасибо.

Добавлено через 4 часа 29 минут
Есть идеи?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
02.09.2013, 13:52
Ответы с готовыми решениями:

Регламентированный отчет
Возможно ли с нуля создать регламентированный отчет в 1с, чтобы он встраивался в конфигурацию ...

Регламентированный отчет 1с 8
Как можно изменить регламентированный отчет, который загружается из пользовательского режима? в...

Регламентированный отчет 1с 8 УТ
Как добавить самописный отчет в дерево конфигурации, чтобы он отображался в справочнике...

Внешний отчет 1С 8.1
Народ, помогите!!!! работаю в 1С 8.1 "Управление торговлей", в программировании совершенно не шарю....

Составить внешний отчет 1с-8.2
Ребята, подскажите последовательность действий для создания внешнего отчета. Реализация по...

20
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
02.09.2013, 20:37 2
вряд ли...
Цитата Сообщение от SonicQ Посмотреть сообщение
свой регламентированный отчет
это нонсенс
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
02.09.2013, 22:54  [ТС] 3
Цитата Сообщение от duk337 Посмотреть сообщение
это нонсенс
ну почему же , запилил отчет, используя механизм регламентированных отчетов, реализовал сохранения его в документ "Регламентированный отчет", все сохраняется, и при инициализации сохраненных данных получаю сохраненные данные, но вот заполнить их в макет не получается
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
02.09.2013, 23:01 4
duk337, создание своих рег. отчетов - нормальная практика.
SonicQ, ну а ИмяТекТабличноеПоле, что содержит?
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
02.09.2013, 23:21  [ТС] 5
Fenomen, сейчас не могу сказать, все на работе =(
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
03.09.2013, 02:08 6
Цитата Сообщение от Fenomen Посмотреть сообщение
duk337, создание своих рег. отчетов - нормальная практика.
Цитата Сообщение от SonicQ Посмотреть сообщение
запилил отчет, используя механизм регламентированных отчетов,
ладно, сдаюсь... Только как-то в голову не приходило называть самописный отчет регламентированным: чукча не налоговый инспектор и не юрист, а, скорее, нарушитель... Или я что-то путаю?
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
03.09.2013, 06:54  [ТС] 7
Цитата Сообщение от duk337 Посмотреть сообщение
отчет регламентированным
то есть не внешний (Сервис - дополнит. внеш. отчеты и обработки и тд ... ) а отчеты - регламентированные отчеты - и он появляется в списке, юзаешь его как и все остальные
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
03.09.2013, 14:39 8
понял : Не "по смыслу", а "по технике запуска"
0
WebNum
-8 / 18 / 3
Регистрация: 27.08.2013
Сообщений: 104
03.09.2013, 16:48 9
Думаю сначала надо смотреть в отладчик, там все будет ясно
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
03.09.2013, 21:26  [ТС] 10
WebNum, покажешь как его отлаживать :-D ??? Ибо он внешний, и храниться черт пойми где, отладчиком не получается его проверить
0
WebNum
-8 / 18 / 3
Регистрация: 27.08.2013
Сообщений: 104
03.09.2013, 21:32 11
Цитата Сообщение от SonicQ Посмотреть сообщение
он внешний, и храниться черт пойми где
И что? не найти его теперь? 1С какая?
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
03.09.2013, 21:49  [ТС] 12
Цитата Сообщение от WebNum Посмотреть сообщение
1С какая?
такая с желтым ярлыком =) ....

шучу... 1С Написанная с нуля, в общем после загрузки в спр. "регл. отчеты", внешнего отчета, он храниться в файле xml, где-то на сервере, то есть точку остановы никак не поставить, => не посмотреть никак

Добавлено через 45 секунд
в целом механизм этих отчетов, если хочешь, можно посмотреть в БП
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
03.09.2013, 22:16 13
Цитата Сообщение от SonicQ Посмотреть сообщение
то есть точку остановы никак не поставить, => не посмотреть никак
Это вы сильно ошибаетесь. Отчет сохраняется локально в как файл ИмяВременногоФайла.erf в каталог временных файлов. И потом из него запускается как внешний отчет. См. процедуру B]РегламентированнаяОтчетность.РеглОтчеты[/B].

Так что нужно просто открыть этот временный файл в конфигураторе и поставить точку останова в нем.
1
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
03.09.2013, 22:20  [ТС] 14
Цитата Сообщение от Fenomen Посмотреть сообщение
Это вы сильно ошибаетесь. Отчет сохраняется локально в как файл ИмяВременногоФайла.erf в каталог временных файлов. И потом из него запускается как внешний отчет. См. процедуру B]РегламентированнаяОтчетность.РеглОтчеты[/B].

Так что нужно просто открыть этот временный файл в конфигураторе и поставить точку останова в нем.
окей, пробну =)
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
05.09.2013, 10:08  [ТС] 15
Fenomen, и как же отладить этот отчет, не нашел его я.... вот что прописано при загрузки отчета в ИБ

1C
1
2
3
4
5
6
7
8
9
10
    // загружаем внешний отчет в справочник
    Состояние("Загрузка внешнего отчета...");
    Попытка
        ОбъектЭлемент.ВнешнийОтчетХранилище = Новый ХранилищеЗначения(Новый ДвоичныеДанные(ОбъектОтчет.ИспользуемоеИмяФайла), Новый СжатиеДанных(9));
    Исключение
        Предупреждение("Не удалось загрузить внешний отчет:
                        |
                        |" + ИнформацияОбОшибке().Описание);
        Возврат Ложь;
    КонецПопытки;
где реквизит "ВнешнийОтчетХранилище" имеет тип "ХранилищеЗначения"
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
05.09.2013, 19:11 16
SonicQ, я же написал см. процедуру РегламентированнаяОтчетность.РеглОтчеты. В ней отчет сохраняется как файл на диске. Его и нужно открывать отладчиком.
1
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
06.09.2013, 10:57  [ТС] 17
Fenomen, нашел этот временный файл типа **\Local\Temp\v8_5DDD_1d.tmp .... и как же быть дальше?

Добавлено через 16 секунд
Чем его открыть?

Добавлено через 48 минут
прям беда с этим отчетом
0
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
06.09.2013, 11:57 18
Цитата Сообщение от SonicQ Посмотреть сообщение
Чем его открыть?
А что много вариантов? Конфигуратором конечно.
1
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
06.09.2013, 12:16  [ТС] 19
Цитата Сообщение от Fenomen Посмотреть сообщение
А что много вариантов? Конфигуратором конечно.
открывается как текстовый файл

Добавлено через 5 секунд
ура!!!

Добавлено через 8 секунд
Без отладки все получилось

Добавлено через 1 минуту
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
    // Покажем макет в табличном документе
    мТаблица = ЭлементыФормы.ПолеТабличногоДокументаФормаОтчета;
    мТаблица.Очистить();
    Макет = ЭтотОбъект.ПолучитьМакет("Макет");
    мТаблица.Вывести(Макет);
    
    Для Каждого ПоказателиСтраницы Из ПоказателиОтчета Цикл
        ИмяТекТабличноеПоле = ПоказателиСтраницы.Ключ;
        ТекТабличноеПоле    = ЭлементыФормы[ИмяТекТабличноеПоле];
        ПоказателиТаблПоле  = ПоказателиСтраницы.Значение;
 
        Для Каждого Показатель Из ПоказателиТаблПоле Цикл
            ИмяПоказателя       = Показатель.Ключ;
            ЗначениеПоказателя  = Показатель.Значение;
            
            // установим значение в таблице
            Попытка
            мТаблица.Области[ИмяПоказателя].Значение = ЗначениеПоказателя;  
            Исключение
            Сообщить("Не удалось присвоить значение!" );
            КонецПопытки;
        КонецЦикла;
        
    КонецЦикла;
Запилил получения макета, а потом присвоил ячейкам значение =) Уф .... Неделю возился, а было все просто

Добавлено через 1 минуту
косяк был в том, что изначально я пытался присвоить значение еще не полученному макету... ппц
1
Fenomen
899 / 876 / 8
Регистрация: 15.03.2012
Сообщений: 2,680
06.09.2013, 23:32 20
Цитата Сообщение от SonicQ Посмотреть сообщение
открывается как текстовый файл
А если бы открыл его как erf, сэкономил бы кучу времени.
2
06.09.2013, 23:32
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
06.09.2013, 23:32

Внешний отчет о скидках
С Новым Годом! Подскажите пожста как реализовать отчет о скидках которые были поставлены в ручную....

Не работает внешний отчет
1С:Бухгалтерия 8.2 Создаю внешний отчет для выгрузки документов Списание с расчетного счета в...

Внешний отчет по справочнику
Вопрос вот в чем: есть справочник контрагенты,ему подчинен справочник договора,и в свою очередь...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru