Форум программистов, компьютерный форум, киберфорум
Наши страницы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/8: Рейтинг темы: голосов - 8, средняя оценка - 4.75
Aisha12
0 / 0 / 0
Регистрация: 01.08.2013
Сообщений: 39
1

Как редактировать запрос в отчете 1С: 7.7

22.10.2013, 15:07. Просмотров 1452. Ответов 4
Метки нет (Все метки)

1С: Предприятие 7.7 (сетевая версия), конфигурация абонентный отдел (версия 1.0). Есть отчеты за Период и за дату. В отчете по периоду в печатной форме есть столбец Тип абонента (абонент имеет счетчик или нет). Его мы выбираем в диалоге формы
Как редактировать запрос в отчете 1С: 7.7

в модуле отчета прописан запрос на добавление вида абонента, точно так же надо сделать и в отчете по дате. Сделала идентично, но в отчете этот столбец не выходит. что делаю неправильно? Вот запрос в модуле Отчета за период
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
    зап=СоздатьОбъект("Запрос");
    тз= "//{{ЗАПРОС(зап)
    |Период с начало по конец;
    |абонент = ЖурналРасчетов.основной.Объект;
    |типабонента = ЖурналРасчетов.основной.Объект.Вид;
    |зРайон = ЖурналРасчетов.основной.Объект.Район;
    |зМРайон = ЖурналРасчетов.основной.Объект.МикроРайон;
    |зУлица = ЖурналРасчетов.основной.Объект.Улица;
    |зКонтр = ЖурналРасчетов.основной.Объект.Контролер;
    |сумма = ЖурналРасчетов.основной.Результат;
    |вр = ЖурналРасчетов.основной.ВидРасч;
    |дНач = ЖурналРасчетов.основной.ДатаНачала;
    |Функция нс = Сумма(сумма) когда((вр=ВидРасчета.НачальноеСальдо) и (дНач=Начало));
    |Функция кОплате = Сумма(сумма) когда(вр=ВидРасчета.Начислено);
    |Функция Оплачено = Сумма(сумма) когда(ВР=ВидРасчета.Оплата);
    |Функция Пеня = Сумма(сумма) когда(ВР=ВидРасчета.Пеня);
    |Функция суммаСумма = Сумма(сумма);
    |";
    
    Если ГрРн=1 Тогда
        тз=тз+"
        |Группировка зРайон;";
    КонецЕсли;  
    Если ГрМРн=1 Тогда
        тз=тз+"
        |Группировка зМРайон;";
    КонецЕсли;  
    Если ГрУл=1 Тогда
        тз=тз+"
        |Группировка зУлица;";
    КонецЕсли;  
    Если ГрКонтр=1 Тогда
        тз=тз+"
        |Группировка зКонтр;";
    КонецЕсли;  
    
    тз=тз+"
    |Условие(зРайон в Район);
    |Условие(зМРайон в Микрорайон);
    |Условие(зУлица в Улица);
    |Условие(зКонтр в Контролер);
    |";
    Если Вид=2 Тогда
        ТЗ=ТЗ + "
        |Условие(типабонента <> Перечисление.ВидыАбонентов.НетСчетчика);";
    ИначеЕсли Вид=3 Тогда
        ТЗ=ТЗ + "
        |Условие(типабонента <> Перечисление.ВидыАбонентов.ЕстьСчетчик);";
    КонецЕсли;           
    тз=тз + "
    |Группировка абонент без групп;
    |"//}}ЗАПРОС
вот печатная форма Отчета за период

Как редактировать запрос в отчете 1С: 7.7


И я просто вставила в отчет кусочек запроса отсюда в отчет по дате. Запросы как то по другому редактируются?
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.10.2013, 15:07
Ответы с готовыми решениями:

Запрос SQL в справочники и выведение этого запроса в отчете
Версия 8.3, справочник: компании, два столбца: код и название 1) Есть пустой...

Как редактировать форму СФ_выданный?
Здравствуйте, я новичок в 1С. Можно ли в 1С 7.7 редактировать форму выбора...

Как в отчете вывести в таблицу реквизит?
Как в отчете вывести в таблицу реквизит из документа? (1С 8.1) Надо чтобы при...

Запрос в отчете с СКД
У меня есть такой запрос: ВЫБРАТЬ МашинноеВремя.Дата КАК Дата,...

Как показать в отчете отрицательные значения
Пожалуйста помогите.Первый раз создал отчет.Версия 1С 8.2 У меня там есть...

4
Xomych
598 / 535 / 73
Регистрация: 01.11.2012
Сообщений: 1,903
22.10.2013, 15:26 2
А в нужной таблице макета этот столбец есть?
0
Aisha12
0 / 0 / 0
Регистрация: 01.08.2013
Сообщений: 39
22.10.2013, 15:31  [ТС] 3
Ну я его добавила тоже
0
Xomych
598 / 535 / 73
Регистрация: 01.11.2012
Сообщений: 1,903
22.10.2013, 16:00 4
Добавили, но столбца нет? Или он пустой? Или отбор не работает?
1
Aisha12
0 / 0 / 0
Регистрация: 01.08.2013
Сообщений: 39
22.10.2013, 16:28  [ТС] 5
все разобралась сама) спасибо!!
0
22.10.2013, 16:28
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.10.2013, 16:28

Как заполнить поля в отчете через запрос?
Нужно чтобы строки в отчете заполнялись с помощью запроса

Как объединить три таблицы в одну и редактировать ее через запрос?
Подскажите пожалуйста. Как сделать редактируемую таблицу. У меня есть три...

Как в Delphi в отчете вывести данные которые берутся через SQL запрос
Здравствуйте))) Есть три таблицы:Заказ:Номер клиента,Номер заказа(ID)и т.д. и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru