Форум программистов, компьютерный форум CyberForum.ru

Программирование Android

Войти
Регистрация
Восстановить пароль
 
Рейтинг: Рейтинг темы: голосов - 41, средняя оценка - 4.76
Slon747
59 / 37 / 1
Регистрация: 24.08.2013
Сообщений: 423
#1

INSTALL_FAILED_OLDER_SDK - Программирование Android

30.11.2013, 11:05. Просмотров 5353. Ответов 3
Метки нет (Все метки)

IntelliJ IDEA

Создал новый проект.
При попытке запуска на устройстве получаю сообщение INSTALL_FAILED_OLDER_SDK.
Установил более старый SDK, но не помогло. После чего создал еще один новый проект и успешно запустил его.
Сравниваю свойства этих двух проектов и не вижу разницы.
В чем же дело?
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
NiRamz
211 / 211 / 16
Регистрация: 26.12.2010
Сообщений: 691
30.11.2013, 11:08     INSTALL_FAILED_OLDER_SDK #2
версия андроида какая на устройстве?
и какая выставлена в проекте?
Slon747
59 / 37 / 1
Регистрация: 24.08.2013
Сообщений: 423
30.11.2013, 11:56  [ТС]     INSTALL_FAILED_OLDER_SDK #3
Цитата Сообщение от NiRamz Посмотреть сообщение
версия андроида какая на устройстве?
и какая выставлена в проекте?
На устройстве 4.1.1
В обоих проектах в пункте "Project SDK" выставлен "Android 4.0 Platform (java version 1.7.0_45)"
Один проект запускается, а другой показывает эту ошибку.

Добавлено через 43 минуты
Нашел различия в параметре <uses-sdk android:minSdkVersion="_номер_"/> в манифесте.
ivan92
0 / 0 / 1
Регистрация: 30.01.2013
Сообщений: 188
27.06.2014, 15:47     INSTALL_FAILED_OLDER_SDK #4
Slon747, спасибо! Очень-очень выручил)
Yandex
Объявления
27.06.2014, 15:47     INSTALL_FAILED_OLDER_SDK
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru