Форум программистов, компьютерный форум CyberForum.ru

Программирование Android

Войти
Регистрация
Восстановить пароль
 
Рейтинг: Рейтинг темы: голосов - 13, средняя оценка - 4.62
Kosmonaftus
0 / 0 / 0
Регистрация: 10.11.2011
Сообщений: 32
#1

Eclipse не могу запустить эмулятор Андроида - Android

06.12.2013, 13:06. Просмотров 1655. Ответов 2
Метки нет (Все метки)

Моя первая программа Hello World, все сделал как надо и эмулятор создан и все ... но вот такой лог запуска:
[2013-12-06 09:55:35 - Emulator] extension WGL_ARB_make_current_read was not found
[2013-12-06 09:55:35 - Emulator] could not load func glBindBuffer
[2013-12-06 09:55:35 - Emulator] could not load func glBlendEquationSeparate
[2013-12-06 09:55:35 - Emulator] could not load func glBufferData
[2013-12-06 09:55:35 - Emulator] could not load func glBufferSubData
[2013-12-06 09:55:35 - Emulator] could not load func glDeleteBuffers
[2013-12-06 09:55:35 - Emulator] could not load func glGenBuffers
[2013-12-06 09:55:35 - Emulator] could not load func glGetBufferParameteriv
[2013-12-06 09:55:35 - Emulator] could not load func glIsBuffer
[2013-12-06 09:55:35 - Emulator] could not load func glStencilFuncSeparate
[2013-12-06 09:55:35 - Emulator] could not load func glIsShader
[2013-12-06 09:55:35 - Emulator] could not load func glUniform1f
[2013-12-06 09:55:35 - Emulator] could not load func glUniform1fv
[2013-12-06 09:55:35 - Emulator] could not load func glUniform1i
[2013-12-06 09:55:35 - Emulator] could not load func glUniform1iv
[2013-12-06 09:55:35 - Emulator] could not load func glUniform2f
[2013-12-06 09:55:35 - Emulator] could not load func glUniform2fv
[2013-12-06 09:55:35 - Emulator] could not load func glUniform2i
[2013-12-06 09:55:35 - Emulator] could not load func glUniform2iv
[2013-12-06 09:55:35 - Emulator] could not load func glUniform3f
[2013-12-06 09:55:35 - Emulator] could not load func glUniform3fv
[2013-12-06 09:55:35 - Emulator] could not load func glUniform3i
[2013-12-06 09:55:35 - Emulator] could not load func glUniform3iv
[2013-12-06 09:55:35 - Emulator] could not load func glUniform4f
[2013-12-06 09:55:35 - Emulator] could not load func glUniform4fv
[2013-12-06 09:55:35 - Emulator] could not load func glUniform4i
[2013-12-06 09:55:35 - Emulator] could not load func glUniform4iv
[2013-12-06 09:55:35 - Emulator] could not load func glUniformMatrix2fv
[2013-12-06 09:55:35 - Emulator] could not load func glUniformMatrix3fv
[2013-12-06 09:55:35 - Emulator] could not load func glUniformMatrix4fv
[2013-12-06 09:55:35 - Emulator] could not load func glAttachShader
[2013-12-06 09:55:35 - Emulator] could not load func glBindAttribLocation
[2013-12-06 09:55:35 - Emulator] could not load func glCompileShader
[2013-12-06 09:55:35 - Emulator] could not load func glCreateProgram
[2013-12-06 09:55:35 - Emulator] could not load func glCreateShader
[2013-12-06 09:55:35 - Emulator] could not load func glDeleteProgram
[2013-12-06 09:55:35 - Emulator] could not load func glDeleteShader
[2013-12-06 09:55:35 - Emulator] could not load func glDetachShader
[2013-12-06 09:55:35 - Emulator] could not load func glLinkProgram
[2013-12-06 09:55:35 - Emulator] could not load func glUseProgram
[2013-12-06 09:55:35 - Emulator] could not load func glValidateProgram
[2013-12-06 09:55:35 - Emulator] could not load func glGetActiveAttrib
[2013-12-06 09:55:35 - Emulator] could not load func glGetActiveUniform
[2013-12-06 09:55:35 - Emulator] could not load func glGetAttachedShaders
[2013-12-06 09:55:35 - Emulator] could not load func glGetAttribLocation
[2013-12-06 09:55:35 - Emulator] could not load func glGetProgramInfoLog
[2013-12-06 09:55:35 - Emulator] could not load func glGetShaderiv
[2013-12-06 09:55:35 - Emulator] could not load func glGetShaderInfoLog
[2013-12-06 09:55:35 - Emulator] could not load func glGetShaderSource
[2013-12-06 09:55:35 - Emulator] could not load func glGetUniformfv
[2013-12-06 09:55:35 - Emulator] could not load func glGetUniformiv
[2013-12-06 09:55:35 - Emulator] could not load func glGetUniformLocation
[2013-12-06 09:55:35 - Emulator] could not load func glShaderSource
[2013-12-06 09:55:35 - Emulator] could not load func glStencilMaskSeparate
[2013-12-06 09:55:35 - Emulator] could not load func glBindBuffer
[2013-12-06 09:55:35 - Emulator] could not load func glBlendEquationSeparate
[2013-12-06 09:55:35 - Emulator] could not load func glBufferData
[2013-12-06 09:55:35 - Emulator] could not load func glBufferSubData
[2013-12-06 09:55:35 - Emulator] could not load func glDeleteBuffers
[2013-12-06 09:55:35 - Emulator] could not load func glGenBuffers
[2013-12-06 09:55:35 - Emulator] could not load func glGetBufferParameteriv
[2013-12-06 09:55:35 - Emulator] could not load func glIsBuffer
[2013-12-06 09:55:41 - HelloWorld] New emulator found: emulator-5554
[2013-12-06 09:55:41 - HelloWorld] Waiting for HOME ('android.process.acore') to be launched...
[2013-12-06 10:00:36 - HelloWorld] emulator-5554 disconnected! Cancelling 'com.example.helloworld.MainActivity activity launch'!

Во первых запускается если отдельно то только минимальная конфигурация 256 озу ... остальные тупо висят по часу и надпись ANDROID переливается ... все. То эклипс не мог импортировать главный класс Object. Я не понимаю что это такое убогое ПО для написания - Eclipse или оно имеет какие то специфические требования под железо, ну там рам больше 2 гигов ...? Поясните пожалуйста
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.12.2013, 13:06     Eclipse не могу запустить эмулятор Андроида
Посмотрите здесь:

Не работает эмулятор в Eclipse Android
Android Не могу настроить эмулятор adndroid
Android 2d игра для андроида
eclipse DDMS вкладка File Explorer не могу раскрыть папку data Android
Не могу запустить AWD Manager Android
Не получается запустить эмулятор в eclipse Android
Android Эмулятор Андроида и сокеты
Android Не могу проект запустить (AndroidStudio)
Не могу найти ошибку в программном коде Eclipse, Android Android
Верстка для андроида Android
Android Не могу запустить эмулятор
Android Не могу запустить эмулятор Андроида на Windows 7

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
SanchezPluz
49 / 49 / 1
Регистрация: 31.10.2012
Сообщений: 478
07.12.2013, 09:07     Eclipse не могу запустить эмулятор Андроида #2
Eclipse + ADT всегда были убогими. Наконец-то до вас тоже дошло это.
Забудьте про эмулятор. Вероятность в 90% гласит, что он у вас просто не загрузится. Такая же проблема была и у меня. Решается легко: если есть доступное устройство для теста приложения, то подключаете его к ПК, нажимаете по проекту "Run" -> "Android Application...". До этого должен обязательно включен режим разработчика с отладкой через USB.
GukZiLLA
35 / 35 / 2
Регистрация: 30.11.2013
Сообщений: 102
07.12.2013, 12:49     Eclipse не могу запустить эмулятор Андроида #3
Перед использованием эмулятора сделайте это http://habrahabr.ru/company/intel/blog/146114/

У меня все летает как на телефоне, а иногда и быстрее. Использую эмулятор nexus 7 с памятью 512
Yandex
Объявления
07.12.2013, 12:49     Eclipse не могу запустить эмулятор Андроида
Ответ Создать тему
Опции темы

Текущее время: 16:57. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru