Форум программистов, компьютерный форум, киберфорум
Наши страницы
Программирование Android
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
mr_holmes
0 / 0 / 0
Регистрация: 07.02.2013
Сообщений: 16
1

Создание Activity

07.09.2014, 20:49. Просмотров 839. Ответов 9
Метки нет (Все метки)

Добрый день!
При создании нового проекта возникает проблема - Eclipse ту хочет создавать Activity с версией android 2.3.3.
Пишет ошибку " This template requires a build target API version of at least 14, and the current version is 10". Если выбрать версию компиляции начиная с 4.0, то всё нормально. НО
Эмулятор запускается только 2.3.3, на 4.0 очевидно мощности не хватает, поэтому очень нужно компилировать именно в 2.3.3.
Помогите пожалуйста
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
07.09.2014, 20:49
Ответы с готовыми решениями:

Создание Activity в другом Activity
Нормально ли создавать экземпляр какого-либо Activity в текущем Activity? Дело...

Создание нового Activity
Прошел примерно день как скачал Android Studio, многому научился, и затупил как...

Создание и вызов второго Activity
Добрый день! Немного запутался с ООП в проекте суть в следующем: Имеем...

Создание фона для Activity
Хочу создать фон для активити.. в дальнейшем буду его сжимать до...

Динамическое создание элементов на другом activity
В чем суть: Нажимаем кнопку в лэйауте1, после чего создается ImageButton на...

9
YuraAAA
1578 / 1319 / 282
Регистрация: 25.10.2009
Сообщений: 3,436
Записей в блоге: 2
08.09.2014, 11:11 2
mr_holmes, а если не ставить галочку "Create activity" и создать её руками?

Не по теме:

P.S. Выкидывайте eclipse, ставьте androd studio или intellij idea

0
Pablito
08.09.2014, 11:22
  #3

Не по теме:

да, давайте при каждом сообщении или варнинге советовать снести эклипс, так же проще жить

0
YuraAAA
08.09.2014, 11:26
  #4

Не по теме:

Паблито, у каждого второго с ним проблемы. Может действительно стоит?:)

0
chizz
08.09.2014, 11:43
  #5

Не по теме:

YuraAAA, у каждого второго видимо руки кривые.

0
Pablito
2767 / 2198 / 744
Регистрация: 12.05.2014
Сообщений: 7,711
Завершенные тесты: 1
08.09.2014, 11:46 6
Такое предупреждение выдается если при создании нового проекта Compile With выбрать ниже API 14.
Если там выбрать хотя бы API14 то все создается нормально.
1
chizz
983 / 502 / 102
Регистрация: 19.03.2013
Сообщений: 3,109
Записей в блоге: 19
Завершенные тесты: 1
08.09.2014, 11:49 7
Паблито, создается-то оно создается, но аффтар пишет, что эмулятор у него не запускается. Но это уже другой вопрос.
0
Pablito
2767 / 2198 / 744
Регистрация: 12.05.2014
Сообщений: 7,711
Завершенные тесты: 1
08.09.2014, 11:55 8

Не по теме:

а я отвечал не автору :)


а по эмулятору мало информации, что значит "не запускается"?
0
mr_holmes
0 / 0 / 0
Регистрация: 07.02.2013
Сообщений: 16
08.09.2014, 16:20  [ТС] 9
Версия эмулятора 2.3.3 нормально запускается примерно через 2-5 мин.
А вот версии 4.2 и 4.4 и по пол часа - часу висели и так и не загружались.
То есть API по любому нужно 10 версия. Может установить JDK 7 версии, или есть более ранняя версия Eclipse?
Или же подскажите пожалуйста, как создать пустое Activity в ручную.
0
Pablito
2767 / 2198 / 744
Регистрация: 12.05.2014
Сообщений: 7,711
Завершенные тесты: 1
08.09.2014, 16:38 10
В свойствах виртуального устройства, которое не запускается, можно попробовать найти опцию "Use host GPU" и сменить состояние этого флажка на противоположное.
0
08.09.2014, 16:38
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
08.09.2014, 16:38

Создание окон в navigation drawer activity
Ребят, всем привет. Пытаюсь создать фрагменты в navigation drawer activity, но...

Создание суперкласса для всех Activity
Господа,доброго времени суток! Возник следующий вопрос: у меня есть несколько...

Создание сервера, запускающего разные Activity
Добрый день. Возникла такая проблема. Есть приложение под андроид, которое...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru