Форум программистов, компьютерный форум CyberForum.ru
Наши страницы

Программирование Android

Войти
Регистрация
Восстановить пароль
 
Рейтинг: Рейтинг темы: голосов - 22, средняя оценка - 4.95
semiromid
7 / 7 / 2
Регистрация: 28.08.2014
Сообщений: 177
#1

ERROR: x86 emulation currently requires hardware acceleration - Программирование Android

09.10.2014, 20:22. Просмотров 2682. Ответов 2
Метки нет (Все метки)

Здравствуйте. Помогите пожалуйста разобраться с ошибкой.
До того как я столкнулся с этой ошибкой , эмуляторы на платформе "Intel Atom(x86) запускались нормально. Я пытался установить библиотеку support-v7 , и предположительно после этого начала возникать эта ошибка . Что бы избавиться от неё ,я переустановил SDK и Ecliopse, но ошибку так и не смог устранить.

При запуске AVD, виртуального мобильного устройства с платформой "Intel Atom(x86)" , вылетает ошибка, и само устройство не запускается.

Starting emulator for AVD 'r777'
emulator: ERROR: x86 emulation currently requires hardware acceleration!
Please ensure Intel HAXM is properly installed and usable.
CPU acceleration status: HAX kernel module is not installed!
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.10.2014, 20:22
Здравствуйте! Я подобрал для вас темы с ответами на вопрос ERROR: x86 emulation currently requires hardware acceleration (Программирование Android):

Ошибка в Android Studio: "x86 emulation currently requires hardware acceleration" - Программирование Android
C:\Users\karr\AppData\Local\Android\sdk\tools\emulator.exe -netdelay none -netspeed full -avd Nexus_S_API_19 emulator: ERROR: x86...

Genymotion: unable to set OpenGL hardware acceleration for the virtual device - Программирование Android
ошибка при запуске виртуальной машины :( как исправить? Добавлено через 21 час 14 минут хелп !!!

Трабл с установкой Snow Leopard на ViryualBox (Hardware acceleration is not available on your system) - Mac OS
Получаю вот такое так же,при старте машины получаю такую ошибку,VT-x/AMD-V hardware acceleration is not available on your system. Certain...

This kernel requires an x86-64 CPU but only detected on i686 CPU при установке Kali - Debian Linux
Не могу установить kali на виртуалку - this kernel requires an x86-64 CPU but only detected on i686 CPU.

Ошибка dvd-rom "hardware error (logical unit communication parity error)". - DVD, Blu-ray
Кто-нибудь знает, что значит эта ошибка - "hardware error (logical unit communication parity error)". Выскакивает при записи диска....

Error C2109: subscript requires array or pointer - C++
В функциях Poisk и Show компилятор пишет, что индекс i в элементе массива x должен иметь указатель на тип объекта. Не могу понять,...

2
Pablito
2476 / 1960 / 611
Регистрация: 12.05.2014
Сообщений: 6,863
Завершенные тесты: 1
10.10.2014, 09:45 #2
ну и что непонятно?
надо скачать и поставить haxm
0
semiromid
7 / 7 / 2
Регистрация: 28.08.2014
Сообщений: 177
10.10.2014, 14:20  [ТС] #3
Эмулятор у меня запускался и без hamx .
Когда второй раз переустанавливал Eclipse и SDK , то удалил папку ".android" C:\Users\MyComputer\.android , там был AVD и возможно что-то еще. После этого начал запускаться эмулятор. Но после установки в "AndroidSDKManager" какого-то API , опять появилась эта ошибка, предположительно после "Intel x86 Atom_64 System Image". После его удаления , проблема остаётся . Буду проверять дальше. Я устанавливал все пакеты.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.10.2014, 14:20
Привет! Вот еще темы с ответами:

Error C2109: subscript requires array or pointer type - C++
Доброго времени суток! Подскажите, пожалуйста, что нужно изменить, чтобы пропала ошибка error C2109: subscript requires array or pointer...

Синий экран Bsod an uncorrectable hardware error - BSOD
Нужна помощь. Вот данные ошибки: A problem has been detected and windows has ben shut down to prevent damage to your computer. The...

*ERROR* radeon kernel modesetting for R600 or later requires firmware-linux-nonfree - Linux
Добрый день. Как исправить ошибку *ERROR* radeon kernel modesetting for R600 or later requires firmware-linux-nonfree. У меня стоит...

Ошибка fatal error C1190: managed targeted code requires and '/clr' option - C++/CLI
У меня в проекте есть форма и dll. Пытаюсь скомпилировать, выдается ошибка: fatal error C1190: managed targeted code requires and '/clr'...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru