Форум программистов, компьютерный форум CyberForum.ru
Наши страницы

Программирование Android

Войти
Регистрация
Восстановить пароль
 
alexjj09
2 / 2 / 0
Регистрация: 04.05.2013
Сообщений: 61
#1

Использованеи materialdesign - Программирование Android

24.11.2014, 14:27. Просмотров 367. Ответов 3
Метки нет (Все метки)

Решил оформление приложения обновить под lollipop, поменял в android studio
Java
1
buildToolsVersion "21.0.2"
поставил
Java
1
compile "com.android.support:appcompat-v7:21.0.2"
Однако при создании темы

XML
1
2
3
<style name="AppThemeMaterial" parent="android:Theme.Material">
        <!-- Customize the Material elements here -->
    </style>

выдает такую ошибку - android:Theme.Material requires API level 21 (current min is 15)

Что подскажите? заранее спасибо
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Spelcrawler
527 / 497 / 111
Регистрация: 12.03.2014
Сообщений: 1,649
Завершенные тесты: 1
24.11.2014, 19:08 #2
alexjj09,
Цитата Сообщение от alexjj09 Посмотреть сообщение
android:Theme.Material requires API level 21 (current min is 15)
А если перевести? Хотя бы гуглом? Очень хитро вы хотите использовать все новшества новой ос на старой. Ошибка из-за того что sdk 21 версии доступно только с 21 же версией api.
0
alexjj09
2 / 2 / 0
Регистрация: 04.05.2013
Сообщений: 61
24.11.2014, 20:13  [ТС] #3
Да проблема решилась, просто не нужно на эту ошибку внимания обращать. А насчет
Очень хитро вы хотите использовать все новшества новой ос на старой.
Никаких хитростей )) Appcompat же есть. И я его подключил. Вопрос был в том, может я еще чтото забыл сделать.
0
Netscape
373 / 360 / 48
Регистрация: 02.10.2009
Сообщений: 712
Записей в блоге: 4
24.11.2014, 20:51 #4
Java
1
targetSdkVersion 21
0
24.11.2014, 20:51
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru