Форум программистов, компьютерный форум CyberForum.ru

Не удается подключить NotificationCompat для старых версий - Android

Восстановить пароль Регистрация
 
vindigo
18 / 18 / 3
Регистрация: 15.05.2014
Сообщений: 77
04.07.2015, 12:31     Не удается подключить NotificationCompat для старых версий #1
Всем привет! Такая проблема: не удается подключить NotificationCompat для старых версий. Ругается на строчку:
Java
1
nBld = new NotificationCompat.Builder(context);
вот gradle, как видно библиотека подключена:

Java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
apply plugin: 'com.android.application'
 
android {
    compileSdkVersion 22
    buildToolsVersion "22.0.1"
 
    defaultConfig {
        applicationId "com.myapp.app"
        minSdkVersion 14
        targetSdkVersion 22
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}
 
dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile 'com.android.support:appcompat-v7:22.2.0'
    compile 'com.android.support:support-v4:22.2.0'
}
import android.support.v4.app.*; импорт присутствует, переустановка студии, обновление всего до последних версий ничего не дало, есть идеи?
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.07.2015, 12:31     Не удается подключить NotificationCompat для старых версий
Посмотрите здесь:

Android Одновременное использование новых и старых методов под разные версии андроида
Android TextView глючит на старых версиях Android и в теме Holo
Разные темы оформления меню на старых устройствах Android
Не удается подключить планшет к компьютеру что бы тестировать приложение Android
Не удается законнектиться к БД Android
Android Не удается создать mediaplayer
Android Не удается создать меню!
Android Как подключить библиотеки для работы с файлами?
Исключить из контроля версий файлы среды Android
Android Google maps метод поиска фрагмента карт на разметке для разных версий андроид
Android Разрешение на создание файла для разных версий ОС
Знак рубля в старых андроидах Android

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Mikalai
248 / 224 / 91
Регистрация: 11.01.2015
Сообщений: 642
04.07.2015, 16:19     Не удается подключить NotificationCompat для старых версий #2
Может это поможет
vindigo
18 / 18 / 3
Регистрация: 15.05.2014
Сообщений: 77
04.07.2015, 23:31  [ТС]     Не удается подключить NotificationCompat для старых версий #3
Mikalai, спасибо, собственно, оттуда все и срисовывалось, или может я чего-то не заметил? Так и не понял в чем проблема, создал НОВЫЙ проект, перекинул все туда и заработало. Тридцать раз уже пожалел, что на студию перешел...
Yandex
Объявления
04.07.2015, 23:31     Не удается подключить NotificationCompat для старых версий
Ответ Создать тему
Опции темы

Текущее время: 22:49. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru