Форум программистов, компьютерный форум, киберфорум
Наши страницы
Программирование Android
Войти
Регистрация
Восстановить пароль
 
илья9696
120 / 120 / 70
Регистрация: 15.11.2014
Сообщений: 543
Завершенные тесты: 3
#1

Не открывает старые проекты - Программирование Android

04.09.2016, 01:21. Просмотров 826. Ответов 13
Метки нет (Все метки)

Обновил android studio до 2.1, и наверно зря. Старый проект не получается открыть. Создаю эмулятор, запускаю, но окнo debugged не появляется, и в самом эмуляторе естественно не отображается мое приложение.

Есть такая надпись..
Migrate Project to Gradle?
This project does not use the Gradle build system. We recommend that you migrate to using the Gradle build system.

Что нужно сделать? Я так понял указать путь к gradle в моем старом проекте
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.09.2016, 01:21
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Не открывает старые проекты (Программирование Android):

Старые добрые мячики (CatchTheBall)
https://play.google.com/store/apps/details?id=com.mercury2002.catchtheball...

Как реализовать следующие проекты
Добрый вечер! Скажите, подскажите как реализовать следующие проекты: 1....

Как отлаживать проекты в убунту?
Я всегда работал под WINDOWS в Android Studio а мне сейчас нужно вести отладку...

Eclipse: есть ли возможность группировать проекты?
При открытии проектов с примерами (из SDK, книг, и др. источников) все они...

Существующие сборки\проекты\фреймворки Android-приложений
Приветствую всех! Мое изучение Андройд СДК продолжается, и его цель -...

Не открываются старые проекты
VS 2015 Community не может открыть проекты, сделанные год и более назад на VS...

13
Pablito
2652 / 2134 / 726
Регистрация: 12.05.2014
Сообщений: 7,450
Завершенные тесты: 1
04.09.2016, 11:32 #2
Цитата Сообщение от илья9696 Посмотреть сообщение
Migrate Project to Gradle?
ну там знак вопроса наверное куда-то можно нажать что бы мигрировать
0
илья9696
120 / 120 / 70
Регистрация: 15.11.2014
Сообщений: 543
Завершенные тесты: 3
04.09.2016, 12:53  [ТС] #3
Нет.
0
Миниатюры
Не открывает старые проекты  
Mikalai
262 / 238 / 95
Регистрация: 11.01.2015
Сообщений: 666
04.09.2016, 13:14 #4
илья9696, попробуй по другому открыть. File -> New -> Import Project
0
Pablito
2652 / 2134 / 726
Регистрация: 12.05.2014
Сообщений: 7,450
Завершенные тесты: 1
04.09.2016, 13:21 #5
я бы просто выбрал в меню File - Open и указал папку с проектом
лично так мигрировал пару проектов
0
илья9696
120 / 120 / 70
Регистрация: 15.11.2014
Сообщений: 543
Завершенные тесты: 3
04.09.2016, 13:43  [ТС] #6
Не выходит, описанными вами способами

Добавлено через 1 минуту
Скорее всего из-за того, что на разных компах делал

Добавлено через 27 секунд
Мб имя пакета, апи, итд итп, что-то из этого не совпадает
0
ExFau$t
520 / 475 / 101
Регистрация: 08.05.2012
Сообщений: 2,381
04.09.2016, 13:48 #7
илья9696, создай новый проект пустой, в папку с ним скопируй папку src и файл манифеста, свои либы ещё, а содержание градле вставь вручную.
0
илья9696
120 / 120 / 70
Регистрация: 15.11.2014
Сообщений: 543
Завершенные тесты: 3
04.09.2016, 14:03  [ТС] #8
Что именно писать в градле? И в каком, их 2
0
Pablito
2652 / 2134 / 726
Регистрация: 12.05.2014
Сообщений: 7,450
Завершенные тесты: 1
04.09.2016, 14:04 #9
Цитата Сообщение от илья9696 Посмотреть сообщение
Скорее всего из-за того, что на разных компах делал
Добавлено через 27 секунд
Мб имя пакета, апи, итд итп, что-то из этого не совпадает
причем тут имя пакета вообще?
все там импортируется
0
ExFau$t
520 / 475 / 101
Регистрация: 08.05.2012
Сообщений: 2,381
04.09.2016, 14:18 #10
илья9696, в тот градле что в новом проекте сгенерился надо вставить содержание градле импортируемого проекта. Этот метод работает 100%.
0
илья9696
120 / 120 / 70
Регистрация: 15.11.2014
Сообщений: 543
Завершенные тесты: 3
04.09.2016, 14:37  [ТС] #11
Error : ( 1, 1) A problem occurred evaluating project ':app'.
> Failed to apply plugin [id 'com.android.application']
> Minimum supported Gradle version is 2.14.1. Current version is 2.8. If using the gradle wrapper, try editing the distributionUrl in
0
ExFau$t
520 / 475 / 101
Регистрация: 08.05.2012
Сообщений: 2,381
04.09.2016, 14:50 #12
илья9696, в корневом градле поменяй версию на требуемую или градле новый установи.
0
илья9696
120 / 120 / 70
Регистрация: 15.11.2014
Сообщений: 543
Завершенные тесты: 3
04.09.2016, 14:52  [ТС] #13
Обновить градл в студии можно? Или надо качать откуда либо
0
CoolMind
421 / 404 / 65
Регистрация: 06.10.2012
Сообщений: 1,732
05.09.2016, 10:02 #14
Цитата Сообщение от илья9696 Посмотреть сообщение
Обновить градл в студии можно?
Можно через студию, она сама скачивает тот градл, который указан. Можно вручную и положить в папку, но я не пробовал.
0
05.09.2016, 10:02
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
05.09.2016, 10:02
Привет! Вот еще темы с решениями:

Не могу открыть старые проекты
Вобщем все началось с переустановки ОС, на С ++ я работаю недели 2-3. Мои...

собрать старые проекты в AVR Studio 4.19 и выше.
Всем доброго времени суток. Очередной вопрос от начинающего.. Пытаясь собрать...

После переустановки ОС не открываются старые проекты Sony Vegas 13
После переустановки операционной системы не открываются старые проекты. Сони...

Куда идти с компаковского DVF дальше, чтобы старые проекты работали?
Здравствуйте ! Писал я кое-что под XP и DVF 6.0 6.5 6.6 ,освоил QuicWin -все...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru