Форум программистов, компьютерный форум CyberForum.ru

Сборка приложения в AS (совместимость >= Android 4.0) - Android

Войти
Регистрация
Восстановить пароль
 
kozak95
34 / 34 / 10
Регистрация: 01.11.2013
Сообщений: 319
13.09.2016, 18:00     Сборка приложения в AS (совместимость >= Android 4.0) #1
Подскажите, как правильно собрать приложение. Приложение должно работать в Android 4.0 и выше
В манифесте указываю

<uses-sdk android:minSdkVersion="14"

Какая версия sdk должна стоять в gradle?
У меня так:

Java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
apply plugin: 'com.android.application'
 
android {
    compileSdkVersion 23
    buildToolsVersion "21.0.1"
 
    defaultConfig {
        applicationId "com.kozachok.mymediaplayer"
        minSdkVersion 14
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}
 
dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.3.0'
    compile 'com.android.support:design:23.3.0'
}
Но на шестом андроиде не запускается...

Добавлено через 4 минуты
По идее можно компилировать и compileSdkVersion 14 и все ровно должно работать на 23 api или я ошибаюсь?
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.09.2016, 18:00     Сборка приложения в AS (совместимость >= Android 4.0)
Посмотрите здесь:

Сборка Android приложения Android
Сборка приложения, NDK Android
Android Сборка приложения NDK sample в Eclipse
Android Вылет приложения из-за android:background
Запуск приложения с загрузкой android Android
Сборка Qt под Android Android
Android Token из приложения Android
Анимация текста Android приложения Android
Заставка для приложения android Android
Android Изменение приложения на android
Android Android NDK сборка проекта
Android Ant и сборка приложения

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Паблито
не спать!
1882 / 1616 / 500
Регистрация: 12.05.2014
Сообщений: 5,836
Завершенные тесты: 1
13.09.2016, 18:12     Сборка приложения в AS (совместимость >= Android 4.0) #2
в манифесте уже можно не указывать версии sdk, только в build.gradle
Цитата Сообщение от kozak95 Посмотреть сообщение
Но на шестом андроиде не запускается...
ну наверное там ошибку какую-то пишет в логах
Alexvp
107 / 71 / 8
Регистрация: 03.08.2014
Сообщений: 344
13.09.2016, 18:24     Сборка приложения в AS (совместимость >= Android 4.0) #3
Попробуйте обновить buildToolsVersion до 24
Yandex
Объявления
13.09.2016, 18:24     Сборка приложения в AS (совместимость >= Android 4.0)
Ответ Создать тему
Опции темы

Текущее время: 07:50. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru