Форум программистов, компьютерный форум, киберфорум
Наши страницы
Программирование Android
Войти
Регистрация
Восстановить пароль
 
Eugen167
0 / 0 / 0
Регистрация: 03.06.2015
Сообщений: 115
1

Ошибка при сборке проекта (gradle)

06.10.2016, 15:53. Просмотров 416. Ответов 8
Метки нет (Все метки)

Вообщем, делаю тренировочное приложение, чтобы научиться работать с БД MySQL. Вроде код прописал все ок, но при компиляции ошибка:
Ошибка при сборке проекта (gradle)


Я следую предложению компилятора и добавляю строки sourceCompatibility = "1.7" и targetCompatibility = "1.7" в greadle-файл, после чего снова запускаю компиляцию, тогда эта ошибка пропадает и появляется новая ошибка:
Ошибка при сборке проекта (gradle)


Что делать?
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.10.2016, 15:53
Ответы с готовыми решениями:

Ошибка при сборке "This version of Android Studio is incompatible with the Gradle Plugin used"
Сегодня обновил студию, теперь при сборке проекта вылетает с ошибкой: Error...

Ошибка синхронизации Gradle при попытке создания проекта Android в IntelliJ IDEA
Всем доброго времени суток. Собственно проблема с которой столкнулся в...

Ошибка при сборке проекта после переименования класса
Всем доброго времени суток!Мне нужна помощь в создании приложений на...

Android, Gradle: проверка параметра при отладке и сборке подписанного файла
Приветствую, коллеги! Всем хорошего кода. В проекте есть переменная (класса),...

Ошибка Gradle при добавлении Espresso
Проблема с добавлением библиотеки Espresso как зависимость при помощи Gradle. ...

8
Pablito
2731 / 2166 / 735
Регистрация: 12.05.2014
Сообщений: 7,575
Завершенные тесты: 1
06.10.2016, 15:55 2
Цитата Сообщение от Eugen167 Посмотреть сообщение
добавляю строки sourceCompatibility = "1.7" и targetCompatibility = "1.7" в
что за бред?
0
Eugen167
0 / 0 / 0
Регистрация: 03.06.2015
Сообщений: 115
06.10.2016, 16:00  [ТС] 3
Цитата Сообщение от Паблито Посмотреть сообщение
Сообщение от Eugen167
добавляю строки sourceCompatibility = "1.7" и targetCompatibility = "1.7" в
что за бред?
Как я понял компилятор требует их добавить, что я и делаю. Дополнительно об этой ошибке я почитал на форуме и там был такой вариант. После чего те ошибки пропадают и появляется эта ошибка. Но видимо это не тот вариант, что нужно делать, я уже все перепробовал, вообщем я не знаю как исправить этот косяк...(
0
Pablito
2731 / 2166 / 735
Регистрация: 12.05.2014
Сообщений: 7,575
Завершенные тесты: 1
06.10.2016, 16:06 4
Цитата Сообщение от Eugen167 Посмотреть сообщение
как исправить этот косяк
их надо убрать
0
Eugen167
0 / 0 / 0
Регистрация: 03.06.2015
Сообщений: 115
06.10.2016, 16:09  [ТС] 5
Цитата Сообщение от Паблито Посмотреть сообщение
Сообщение от Eugen167
как исправить этот косяк
их надо убрать
когда убираю их, снова появляется ошибка, что на первой картинке
0
Pablito
2731 / 2166 / 735
Регистрация: 12.05.2014
Сообщений: 7,575
Завершенные тесты: 1
06.10.2016, 16:16 6
тогда их надо дописывать не в build.gradle уровня проекта, а уровня модуля
XML
1
2
3
4
5
6
7
8
android {
 
 
    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_7
        targetCompatibility JavaVersion.VERSION_1_7
    }
}
0
Eugen167
0 / 0 / 0
Регистрация: 03.06.2015
Сообщений: 115
06.10.2016, 16:23  [ТС] 7
Цитата Сообщение от Паблито Посмотреть сообщение
тогда их надо дописывать не в build.gradle уровня проекта, а уровня модуля
Не сработало, появился первый набор ошибок
0
Pablito
2731 / 2166 / 735
Регистрация: 12.05.2014
Сообщений: 7,575
Завершенные тесты: 1
06.10.2016, 16:27 8
надо видеть не скриншоты, а весь код обоих файлов build.gradle
и манифеста
0
Eugen167
0 / 0 / 0
Регистрация: 03.06.2015
Сообщений: 115
08.10.2016, 12:22  [ТС] 9
Цитата Сообщение от Паблито Посмотреть сообщение
надо видеть не скриншоты, а весь код обоих файлов build.gradle
и манифеста
Проблема решена. Суть ее в том, что я использовал слишком новую библиотеку JDBC для поключения к БД. Android Studio новые версии этого драйвера не поддерживает.
0
08.10.2016, 12:22
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
08.10.2016, 12:22

Запуск проекта с gradle
Всем привет. Никогда не пользовался gradle, часто смотреть примеры на github,...

Ошибка при сборке сертифицированного релиза
Пытаюсь собрать 4 релиз(сертифицированный) приложения но мне android studio...

Gradle sync failed: Invalid Gradle JDK configuration found
Спустя пару часов все таки решил открыть тему. Intellij IDEA 15.0.2 ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru