Форум программистов, компьютерный форум CyberForum.ru

Приложение несовместимо с вашими устройствами - Android

Восстановить пароль Регистрация
 
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
27.10.2016, 20:30     Приложение несовместимо с вашими устройствами #1
Всем доброго времени суток!!!
Есть такая проблема, после публикации приложения в google play (после процедуры обработки приложения), нахожу приложение, выбираю его, просматриваю и вижу это
Миниатюры
Приложение несовместимо с вашими устройствами  
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
27.10.2016, 20:35  [ТС]     Приложение несовместимо с вашими устройствами #2
Мой отрывок из манифеста, может здесь кроется причина?
XML
1
2
<uses-feature android:name="android.hardware.touchscreen" android:required="true" />
<supports-screens android:anyDensity="true"/>
Alexvp
107 / 71 / 8
Регистрация: 03.08.2014
Сообщений: 344
27.10.2016, 22:06     Приложение несовместимо с вашими устройствами #3
Проверьте минимальную версию SDK вашего приложения и версию андроида вашего девайса.
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
27.10.2016, 22:26  [ТС]     Приложение несовместимо с вашими устройствами #4
Там все в порядке

Добавлено через 3 минуты
XML
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
apply plugin: 'com.android.application'
 
android {
    compileSdkVersion 23
    buildToolsVersion "24.0.3"
    defaultConfig {
        applicationId "ru.object941.keen"
        minSdkVersion 16
        targetSdkVersion 23
        versionCode 4
        versionName "1.0.1"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}
 
dependencies {
    compile fileTree(include: ['*.jar'], dir: 'libs')
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })
    compile 'com.android.support:design:23.4.0'
    testCompile 'junit:junit:4.12'
}
Alexvp
107 / 71 / 8
Регистрация: 03.08.2014
Сообщений: 344
27.10.2016, 22:44     Приложение несовместимо с вашими устройствами #5
А версия андроида на девайсе?
Паблито
не спать!
1785 / 1519 / 471
Регистрация: 12.05.2014
Сообщений: 5,544
Завершенные тесты: 1
27.10.2016, 22:50     Приложение несовместимо с вашими устройствами #6
это смотрится через браузер на компе?
какие там устройства привязаны? там есть список девайсов
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
27.10.2016, 23:35  [ТС]     Приложение несовместимо с вашими устройствами #7
API 17 у меня
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
27.10.2016, 23:38  [ТС]     Приложение несовместимо с вашими устройствами #8
Да, я с компа смотрю.
Миниатюры
Приложение несовместимо с вашими устройствами  
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
27.10.2016, 23:41  [ТС]     Приложение несовместимо с вашими устройствами #9
Из Developer Console
Миниатюры
Приложение несовместимо с вашими устройствами  
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
27.10.2016, 23:44  [ТС]     Приложение несовместимо с вашими устройствами #10
XML
1
2
<uses-feature android:name="android.hardware.touchscreen" android:required="true" />
<supports-screens android:anyDensity="true"/>
Меня смущает во это. По умолчанию в манифесте такого не было, я сам писал уже.
Но и без этого дополнения, такая же ситуация была.
Паблито
не спать!
1785 / 1519 / 471
Регистрация: 12.05.2014
Сообщений: 5,544
Завершенные тесты: 1
28.10.2016, 11:41     Приложение несовместимо с вашими устройствами #11
GT-P5110 это планшет с версией 4.0 (API ~15)
GT-I8160 это вообще какой-то кал на версии 2.3 (API 9)
GT-S5830i такой же кал, как и предыдущий

вопросы есть, все понятно почему нет совместимых устройств?
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
28.10.2016, 11:50  [ТС]     Приложение несовместимо с вашими устройствами #12
GT-P5110 вот этот кал в Android Studio пишет API 17, я же на нем тестил.

Добавлено через 6 минут
Паблито, ты можешь подсказать, есть ли в 4.0 команда "grep" командной строки?
Паблито
не спать!
1785 / 1519 / 471
Регистрация: 12.05.2014
Сообщений: 5,544
Завершенные тесты: 1
28.10.2016, 11:51     Приложение несовместимо с вашими устройствами #13
у меня не было других объяснений почему так пишет, поэтому я просто взял и загуглил что это за устройства
гугл говорит что заметный % GT-P5110 имеет версию 4.0

а что там пишет студия - я отсюда не вижу
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
28.10.2016, 12:03  [ТС]     Приложение несовместимо с вашими устройствами #14
GT-P5110
Миниатюры
Приложение несовместимо с вашими устройствами   Приложение несовместимо с вашими устройствами  
Паблито
не спать!
1785 / 1519 / 471
Регистрация: 12.05.2014
Сообщений: 5,544
Завершенные тесты: 1
28.10.2016, 12:06     Приложение несовместимо с вашими устройствами #15
у меня закончились идеи, могу только сказать что это приложение показывает что оно совместимо с моими двумя девайсами - планшетом 4.1.1 и телефоном 5.+
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.10.2016, 15:58     Приложение несовместимо с вашими устройствами
Еще ссылки по теме:

Передача данных между устройствами Android
Допиленное узкоспециализированное приложение или неповоротливое многофункциональное приложение? Android
Прямой обмен координатами между устройствами Android

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
dedlovscky
-29 / 3 / 1
Регистрация: 06.03.2015
Сообщений: 110
30.10.2016, 15:58  [ТС]     Приложение несовместимо с вашими устройствами #16
Порыскал в доках и понял, что необходимо в манифесте прописать это
XML
1
2
3
4
<manifest ... >
    <supports-screens android:requiresSmallestWidthDp="value" />
    ...
</manifest>
value - наименьшая ширина в "dp" например 320dp.
Yandex
Объявления
30.10.2016, 15:58     Приложение несовместимо с вашими устройствами
Ответ Создать тему
Опции темы

Текущее время: 08:40. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Рейтинг@Mail.ru