Форум программистов, компьютерный форум CyberForum.ru

Программирование Android

Войти
Регистрация
Восстановить пароль
 
Antohsa
8 / 12 / 0
Регистрация: 18.10.2016
Сообщений: 115
#1

Не запускаются эмуляторы - Android

01.11.2016, 00:00. Просмотров 202. Ответов 6
Метки нет (Все метки)

Здравствуйте, всем..

Никак не могу запустить хоть какой-либо эмулятор на Win7-x64.

В Android Studio эмулятор запускается, появляется девайс и надпись "Android" и так весит вечно... =(((

Попробовал GenyMotion, там белый экран при запуске. Поковырял VirtualBox... если для конкретной виртуальной машины отключить сеть вовсе и запустить напрямую - запускается, но работает крайне медленно. Если запускать через Genymotion, то тот изменяет настройки и опять белый экран..

Что делать? Может быть перейти на сразу на реальное устройство или это плохой вариант?

Пожалуйста, помогите...
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
xaat
43 / 16 / 6
Регистрация: 05.12.2015
Сообщений: 65
01.11.2016, 08:38     Не запускаются эмуляторы #2
Цитата Сообщение от Antohsa Посмотреть сообщение
Что делать? Может быть перейти на сразу на реальное устройство или это плохой вариант?
Это лучший вариант.
Зачем эмулятор если есть реальное железо.
А вообще нужно решать эту проблему
Цитата Сообщение от Antohsa Посмотреть сообщение
В Android Studio эмулятор запускается, появляется девайс и надпись "Android" и так весит вечно... =(((
Паблито
резкий
1959 / 1694 / 525
Регистрация: 12.05.2014
Сообщений: 6,044
Завершенные тесты: 1
01.11.2016, 11:02     Не запускаются эмуляторы #3
проц какой и памяти сколько?
уппаратное ускорение включено в биосе?
Antohsa
8 / 12 / 0
Регистрация: 18.10.2016
Сообщений: 115
01.11.2016, 13:57  [ТС]     Не запускаются эмуляторы #4
Паблито, Процессор INTER Core 2 Quad
Памяти 8 ГБ.

Биос не трогал...

xaat, а отладка будет доступна? Вообще зачем эмулятор, если реальное устройство всегда под рукой? Проверить на "разном" железе и разрешении?
Паблито
резкий
1959 / 1694 / 525
Регистрация: 12.05.2014
Сообщений: 6,044
Завершенные тесты: 1
01.11.2016, 14:00     Не запускаются эмуляторы #5
в настройках виртуального устройства часто ставится по умолчанию 2 ядра
можно выставить 1 ядро - мне помогало когда только вышел 5-й андроид и на моем домашнем компе именно так все и выглядело

и я бы пробил на модели материнки, поддерживает ли она виртуализацию и проверил включена ли она в биосе
по-идее она там есть, раз все стартует, но проверить все равно не помешало бы
Antohsa
8 / 12 / 0
Регистрация: 18.10.2016
Сообщений: 115
01.11.2016, 14:03  [ТС]     Не запускаются эмуляторы #6
Как я писал, в VirtualBox эмулятор запускается, но только если отключить всю сеть...

Поковыряюсь в Биос...
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
21.12.2016, 11:09     Не запускаются эмуляторы
Еще ссылки по теме:

Не запускаются игры, требуется удалить все эмуляторы
Не запускаются приложения Дейтела Android
Эмуляторы андроид на Intel и Amd Android
Существуют ли эмуляторы PS3/4 ?
Android После обновления HAXM не запускаются эмуляторы

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
pazuk
0 / 0 / 0
Регистрация: 12.12.2016
Сообщений: 8
21.12.2016, 11:09     Не запускаются эмуляторы #7
Antohsa, если у Вас при запуске genymotion только белое поле в окне, то можете посмотреть какая версия opengl у Вас на компе. Вполне может оказаться, что она ниже 2.0. В этом случае нужно пробовать обновить драйвера видеокарты на последние и опять проверить версию opengl. Если стало 2.0 (или выше), то есть вероятность того, что белое поле пофиксится.
Yandex
Объявления
21.12.2016, 11:09     Не запускаются эмуляторы
Ответ Создать тему
Опции темы

Текущее время: 07:14. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru