Форум программистов, компьютерный форум CyberForum.ru

Не запускаются эмуляторы - Android

Восстановить пароль Регистрация
 
Antohsa
8 / 12 / 0
Регистрация: 18.10.2016
Сообщений: 112
01.11.2016, 00:00     Не запускаются эмуляторы #1
Здравствуйте, всем..

Никак не могу запустить хоть какой-либо эмулятор на Win7-x64.

В Android Studio эмулятор запускается, появляется девайс и надпись "Android" и так весит вечно... =(((

Попробовал GenyMotion, там белый экран при запуске. Поковырял VirtualBox... если для конкретной виртуальной машины отключить сеть вовсе и запустить напрямую - запускается, но работает крайне медленно. Если запускать через Genymotion, то тот изменяет настройки и опять белый экран..

Что делать? Может быть перейти на сразу на реальное устройство или это плохой вариант?

Пожалуйста, помогите...
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.11.2016, 00:00     Не запускаются эмуляторы
Посмотрите здесь:

программы эмуляторы
программы-эмуляторы.
Удалить эмуляторы Android Android
Windows 8, 8.1 Очень долго запускаются программы автозагрузки (или вообще не запускаются)
Не запускаются игры, требуется удалить все эмуляторы
Не запускаются приложения Дейтела Android
Эмуляторы андроид на Intel и Amd Android
Android После обновления HAXM не запускаются эмуляторы

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
xaat
40 / 13 / 6
Регистрация: 05.12.2015
Сообщений: 64
01.11.2016, 08:38     Не запускаются эмуляторы #2
Цитата Сообщение от Antohsa Посмотреть сообщение
Что делать? Может быть перейти на сразу на реальное устройство или это плохой вариант?
Это лучший вариант.
Зачем эмулятор если есть реальное железо.
А вообще нужно решать эту проблему
Цитата Сообщение от Antohsa Посмотреть сообщение
В Android Studio эмулятор запускается, появляется девайс и надпись "Android" и так весит вечно... =(((
Паблито
не спать!
1803 / 1537 / 478
Регистрация: 12.05.2014
Сообщений: 5,594
Завершенные тесты: 1
01.11.2016, 11:02     Не запускаются эмуляторы #3
проц какой и памяти сколько?
уппаратное ускорение включено в биосе?
Antohsa
8 / 12 / 0
Регистрация: 18.10.2016
Сообщений: 112
01.11.2016, 13:57  [ТС]     Не запускаются эмуляторы #4
Паблито, Процессор INTER Core 2 Quad
Памяти 8 ГБ.

Биос не трогал...

xaat, а отладка будет доступна? Вообще зачем эмулятор, если реальное устройство всегда под рукой? Проверить на "разном" железе и разрешении?
Паблито
не спать!
1803 / 1537 / 478
Регистрация: 12.05.2014
Сообщений: 5,594
Завершенные тесты: 1
01.11.2016, 14:00     Не запускаются эмуляторы #5
в настройках виртуального устройства часто ставится по умолчанию 2 ядра
можно выставить 1 ядро - мне помогало когда только вышел 5-й андроид и на моем домашнем компе именно так все и выглядело

и я бы пробил на модели материнки, поддерживает ли она виртуализацию и проверил включена ли она в биосе
по-идее она там есть, раз все стартует, но проверить все равно не помешало бы
Antohsa
8 / 12 / 0
Регистрация: 18.10.2016
Сообщений: 112
01.11.2016, 14:03  [ТС]     Не запускаются эмуляторы #6
Как я писал, в VirtualBox эмулятор запускается, но только если отключить всю сеть...

Поковыряюсь в Биос...
Yandex
Объявления
01.11.2016, 14:03     Не запускаются эмуляторы
Ответ Создать тему
Опции темы

Текущее время: 18:50. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Рейтинг@Mail.ru