Форум программистов, компьютерный форум, киберфорум
Наши страницы
Программирование Android
Войти
Регистрация
Восстановить пароль
 
Jylik
104 / 45 / 14
Регистрация: 06.03.2012
Сообщений: 732
#1

Минимальная версии Api

Вчера, 04:33. Просмотров 52. Ответов 2
Метки нет (Все метки)

Добрый день, утро, вечер...
Вопрос касательно Play market place, дело в том, что теперь перед обновлением программ, игр, требует установить минимальной, целевой версией android 8.0 - это значит, что телефоны с меньшей версией андройда не смогут получить эту программу, игру?!
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
Вчера, 04:33
Ответы с готовыми решениями:

Вывод в TextView версии API
Доброго времени суток всем) Такой вопрос, мне необходимо выводить версии API в...

Код под разные версии api
Доброго времени суток. Ребят после изучения delphi затем c# решил изучить...

Android SDK Manager не отображает платформы 2.3.3 (API 10), 2.3.1 (API 9). Как быть?
Добрый день! Использую Android Studio под Windows 7. Из-за несовместимости с...

Android Studio не дает работать с API 8 без установленного API 21
Удалил все не интересующие меня библиотеки и поставил только API Level 8. Но...

Ошибка minSDK(API 23, N preview) != deviceSDK(API 17)
Недавно начал учить андроид и возникла такая ошибка, когда я пытаюсь запустить...

2
Vladimir93
53 / 54 / 9
Регистрация: 28.06.2015
Сообщений: 234
Вчера, 10:42 #2
А как вы смогли соединить воедино минимальную, и целевую версию??? Если это совсем разные понятия.


Вот немного инфы полезной

android:minSdkVersion

An integer designating the minimum API Level required for the application to run. The Android system will prevent the user from installing the application if the system's API Level is lower than the value specified in this attribute. You should always declare this attribute.

android:targetSdkVersion

An integer designating the API Level that the application is targetting.

И к ноябрю мы будем иметь такие минимальные параметры

android:minSdkVersion = 14

android:targetSdkVersion = 26

И если верить гуглу то теперь каждый год целевую версию будем поднимать на 1. Что бы на засиживались на одном месте.

По сути, из маркета вкинут все версии ниже 4 - ки. Ну как выкинут, ни обновить, ни тем более релиз загрузить ниже 14.
А там глядишь сам плей до таких требований обновят и все.

Хотя уже сейчас версии библиотек адмоб и файрбэйс требуют мин 15 версии.
0
Jylik
104 / 45 / 14
Регистрация: 06.03.2012
Сообщений: 732
Вчера, 15:12  [ТС] #3
Vladimir93, не, я просто обновил SDK и у меня всё попёрло
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
Вчера, 15:12

Версии Андроид
Только начал изучать Android и возник вопрос по SDK. Установил SDK на винду,...

Версии по для успешной работы
Предлагаю сделать тему и прикрепить ее наверх. Пишите версию студии, ждк,...

Отображение версии приложения в xml
Можно ли как-то отображать версию приложения в текстовом поле EditText файла...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru