Форум программистов, компьютерный форум, киберфорум
Наши страницы
Программирование Android
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.55/22: Рейтинг темы: голосов - 22, средняя оценка - 4.55
SanchezPluz
49 / 49 / 8
Регистрация: 31.10.2012
Сообщений: 481
#1

Не работает эмулятор AVD

15.06.2013, 15:24. Просмотров 4085. Ответов 19
Метки нет (Все метки)

Здравствуйте!

После создания приложения начал его тестить через Android Virtual Device. Их два: для 2.3.6 и для 4.1 версий Android. Но при запуске и того, и того вылазит одинаковая картинка: вместо приложения появляется консоль с надписью ANDROID или же логотип с той же надписью с анимацией блика.
Вроде все правильно сделал: установил все пакеты для требуемых мне версий Android, поставил устройство "Tablet 10.1".
Может в чем-то проблема при самом создании виртуального устройства?
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.06.2013, 15:24
Ответы с готовыми решениями:

Не работает камера AVD
При запуске любого приложения на AVD которое использует камеру вылетает...

Не работает эмулятор
При запуске программы не запускается эмулятор. пишет в RUN...

Не работает эмулятор Android
Здравствуйте! Подскажите, пожалуйста, в чём может быть проблема. При запуске...

Не работает эмулятор в Eclipse
Здравствуйте, столкнулся с такой проблемой, при попытке открыть приложения с...

Не работает эмулятор на CPU от AMD
Доброго времени суток! Решил заняться программированием по андроид, не для...

19
V0v1k
1160 / 984 / 1
Регистрация: 28.06.2012
Сообщений: 3,462
15.06.2013, 16:11 #2
это процесс загрузки эмулятора.
0
SanchezPluz
49 / 49 / 8
Регистрация: 31.10.2012
Сообщений: 481
15.06.2013, 16:13  [ТС] #3
Цитата Сообщение от V0v1k Посмотреть сообщение
это процесс загрузки эмулятора.
Проверил. Постоял 4-5 минут. Результат тот же.
0
V0v1k
1160 / 984 / 1
Регистрация: 28.06.2012
Сообщений: 3,462
15.06.2013, 16:22 #4
все время был на переднем плане?
0
SanchezPluz
49 / 49 / 8
Регистрация: 31.10.2012
Сообщений: 481
15.06.2013, 16:39  [ТС] #5
Цитата Сообщение от V0v1k Посмотреть сообщение
все время был на переднем плане?
Естественно.
0
V0v1k
1160 / 984 / 1
Регистрация: 28.06.2012
Сообщений: 3,462
15.06.2013, 16:48 #6
тогда хз, может комп не тянет и нужно ждать минут 10-20...
1
SanchezPluz
49 / 49 / 8
Регистрация: 31.10.2012
Сообщений: 481
15.06.2013, 22:12  [ТС] #7
Цитата Сообщение от V0v1k Посмотреть сообщение
тогда хз, может комп не тянет и нужно ждать минут 10-20...
Комп имеет достаточно мощности, думаю. По крайней мере, лагов во время работы среды не наблюдалось ни разу.

Насчет 10-20 минут - учту, попробую.
Благодарю за отклик
0
SanchezPluz
49 / 49 / 8
Регистрация: 31.10.2012
Сообщений: 481
18.06.2013, 22:11  [ТС] #8
Собственно, ничего не получилось.
Ждал час - все та же одна "блестящая" картинка.
Есть способ, как сие решить?
0
Миниатюры
Не работает эмулятор AVD  
Best_Coder
0 / 0 / 0
Регистрация: 18.09.2014
Сообщений: 81
26.10.2014, 08:10 #9
Меня эта картинка тоже достала...короче у меня работает норм если выставить не большое разрешение и взять какую нибудь старую версию андройда..
0
semiromid
7 / 7 / 2
Регистрация: 28.08.2014
Сообщений: 179
26.10.2014, 08:20 #10
Я пытался запустить его на старом пентиуме 4 , ждал больше 1 часа пока запустится . Запустился , но лаги были жуткие . Причем я создал AVD с самыми минимальными требованиями.
0
vxg
Модератор
3247 / 2048 / 322
Регистрация: 13.01.2012
Сообщений: 7,930
26.10.2014, 08:56 #11
Цитата Сообщение от SanchezPluz Посмотреть сообщение
Собственно, ничего не получилось
в логе среды появляется ли сообщение красным шрифтом о том что связь с эмулятором потеряна - если да, то ждать бесполезно - запуск не удался, закрывайте эмулятор руками, пытайтесь еще раз
-иногда помогает не шевелиться во время запуска
-иногда помогает изменить настройки эмулятора (дернуть хотя бы на 1 МБ размер памяти вверх или вниз) - при этом происходит обновление конфигурации и он может сам "починиться"
-иногда помогает убрать аппаратную клавиатуру в настройках эмулятора
1
Rube
911 / 559 / 88
Регистрация: 13.02.2014
Сообщений: 2,074
26.10.2014, 17:16 #12
DDMS - reset ADB и не надо ничего перезапускать.
0
vxg
Модератор
3247 / 2048 / 322
Регистрация: 13.01.2012
Сообщений: 7,930
26.10.2014, 17:53 #13
Цитата Сообщение от Rube Посмотреть сообщение
DDMS - reset ADB и не надо ничего перезапускать
увы - нет, не выходит. после появления фразы
emulator-5554 disconnected! Cancelling 'com.example.xxx.MainActivity activity launch'!
может помочь только закрытие эмулятора и повторный запуск
в DDMS список устройств пуст - там просто нечего перезапускать - видимо устройство отваливается до того как его увидит среда
0
Armagedo
209 / 209 / 60
Регистрация: 22.08.2014
Сообщений: 644
26.10.2014, 20:31 #14
Best_Coder,
https://www.youtube.com/watch?v=BgAgNBI498Y
0
Best_Coder
0 / 0 / 0
Регистрация: 18.09.2014
Сообщений: 81
26.10.2014, 23:46 #15
Armagedo,Спасибо!)
0
Rube
911 / 559 / 88
Регистрация: 13.02.2014
Сообщений: 2,074
27.10.2014, 08:37 #16
Цитата Сообщение от vxg Посмотреть сообщение
DDMS список устройств пуст - там просто нечего перезапускать
Там галочка есть, вот в ней пункт только один доступен - reset. А список пуст, да. А так советую Genymotion - земля и небо по сравнению с стандартным.
0
vxg
Модератор
3247 / 2048 / 322
Регистрация: 13.01.2012
Сообщений: 7,930
27.10.2014, 12:12 #17
Цитата Сообщение от Rube Посмотреть сообщение
Там галочка есть, вот в ней пункт только один доступен - reset. А список пуст, да.
да, действительно, DDMS, стрелочка вниз в меню над списком устройств, reset, работает, спасибо
0
Best_Coder
0 / 0 / 0
Регистрация: 18.09.2014
Сообщений: 81
30.10.2014, 15:45 #18
Кто-нибудь знает как решить данную проблему в Genymotion?
все фаерволы с антивирусами поотключал всё равно не хочет работать
0
yourfanat
5 / 5 / 0
Регистрация: 30.10.2013
Сообщений: 180
30.10.2014, 16:29 #19
Советую тестировать на реальном устройстве. Из за слабого компа очень долго мучался с эмулятором, потом плюнул и купил себе Nexus 7. Тестировать одно удовольствие
1
Best_Coder
0 / 0 / 0
Регистрация: 18.09.2014
Сообщений: 81
31.10.2014, 15:22 #20
У меня явно какая то проблема с адресацией внутренней...

Добавлено через 22 часа 42 минуты
Ставлю android X86 рядом с windows 7 в процессе установки соглашаюсь на добавление GRUB а он после перезагрузки не появляется и всё остаётся как было...так и должно быть?
0
31.10.2014, 15:22
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.10.2014, 15:22

Android Studio, не работает эмулятор
Здравствуйте. Недавно хотел заняться андроид- программированием. До этого...

Не работает эмулятор в Android Studio
При запуске любого виртуального устройства (и arm, и x86) рано или поздно...

Не работает эмулятор и отладка по USB
Подскажите, пожалуйста, что не так?


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru