Форум программистов, компьютерный форум CyberForum.ru

Ошибка - Android

Восстановить пароль Регистрация
 
Flash_2oo9
3 / 3 / 0
Регистрация: 31.10.2012
Сообщений: 142
16.07.2013, 15:28     Ошибка #1
Eclipse выдает такое "Call requires API level 9 (current min is 8): android.content.SharedPreferences.Editor#apply"

на строчку:
Java
1
preferencesEditor.apply();
Как мне исправить? Как я понял, просит повысить уровень до 9.
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
MonStar
19 / 19 / 3
Регистрация: 10.04.2011
Сообщений: 225
16.07.2013, 15:34     Ошибка #2
API level меняется в файле AndroidManifest.xml
Выглядит так
XML
1
2
3
<uses-sdk
        android:minSdkVersion="14"
        android:targetSdkVersion="17" />
Flash_2oo9
3 / 3 / 0
Регистрация: 31.10.2012
Сообщений: 142
16.07.2013, 15:40  [ТС]     Ошибка #3
Спасибо, за быстрый ответ.
Все заработало
Yandex
Объявления
16.07.2013, 15:40     Ошибка
Ответ Создать тему
Опции темы

Текущее время: 22:48. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru