С Новым годом! Форум программистов, компьютерный форум, киберфорум
Наши страницы

Программирование Android

Войти
Регистрация
Восстановить пароль
 
Рейтинг: Рейтинг темы: голосов - 125, средняя оценка - 4.70
WaNdera
0 / 0 / 0
Регистрация: 08.05.2013
Сообщений: 5
#1

Ошибка при установке приложения Андроид - Программирование Android

30.08.2013, 01:06. Просмотров 15675. Ответов 7
Метки нет (Все метки)

Создана и протестированна программа eclipse+SDK. В AVD все работает. Таргет версия 4,0,0. При установке на планшет apk файла, версия андроид 4,2,2 происходит ошибка разбора пакета. Как это лечится?
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.08.2013, 01:06
Здравствуйте! Я подобрал для вас темы с ответами на вопрос Ошибка при установке приложения Андроид (Программирование Android):

Ошибка при создание приложения на Андроид - Программирование Android
Делаю первое приложения в Netbias, вот такая ошибка при создание проекта

Ошибка при создании приложения под андроид - Программирование Android
Здравствуйте, уже неделю не пойму как исправить несколько ошибок в коде. Изучать стал недавно, поэтому еще очень тяжело... первая ошибка...

Загрузка статической БД при установке приложения - Программирование Android
Вообщем задача стоит следующая, есть некая стандартная БД вшитая в апк файл. Необходимо при установке перегнать ее на телефон, так как...

Как добавить действие (удаление файла) при установке приложения - Программирование Android
Есть база данных, которая при открытии приложения проверяется на наличие ее в data/data и при отсутствии копируется туда из assets. Но при...

Ошибка при вызове приложения из другого приложения - Программирование Android
Сделано два простеньких приложения и я хочу чтобы одно приложение запускало другое. В приложении, которое будет запущено установлен фильтр...

ошибка при установке Android SDk на eclipse - Программирование Android
сколько уже раз не пытался из каких источников не ставил постоянно при установке ADt плагина: warning You are installing software that...

7
MegaSinner
91 / 87 / 3
Регистрация: 09.04.2010
Сообщений: 746
30.08.2013, 15:02 #2
выложи манифест, посмотрим...
1
WaNdera
0 / 0 / 0
Регистрация: 08.05.2013
Сообщений: 5
30.08.2013, 21:19  [ТС] #3
Устанавливаю приложение- оправляю через почту на планшет samsung apk файл и запускаю его.
XML
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="com.example.qqqq"
    android:versionCode="1"
    android:versionName="1.0" >
 
   <uses-sdk
        android:minSdkVersion="17"
        android:targetSdkVersion="17" />
    <uses-permission android:name="android.permission.INTERNET"/>
 
    <application
        android:allowBackup="true"
        android:icon="@drawable/ic_launcher"
        android:label="@string/app_name"
         >
        <activity
            android:name="com.example.qqqq.MainActivity"
            android:label="@string/app_name" >
            <intent-filter>
                <action android:name="android.intent.action.MAIN" />
                <category android:name="android.intent.category.LAUNCHER" />
            </intent-filter>
        </activity>
    </application>
 
</manifest>
0
verylazy
Заблокирован
30.08.2013, 21:35 #4
выдвину предположение что из-за android:minSdkVersion="17"
http://developer.android.com/guide/t...k-element.html
1
WaNdera
0 / 0 / 0
Регистрация: 08.05.2013
Сообщений: 5
30.08.2013, 21:38  [ТС] #5
я в ручную могу его подправить??? Структура папок при этом важна?
0
verylazy
Заблокирован
30.08.2013, 21:41 #6
можно попробовать просто поменять значение minSdk с 17 на 14 и скомпилировать снова
1
WaNdera
0 / 0 / 0
Регистрация: 08.05.2013
Сообщений: 5
30.08.2013, 21:47  [ТС] #7
Спасибо, все разобрался!! По умолчанию предлагали только 4,2,2 а у меня стоит 4,1,1. Думаю что надо писать вообще под 3,0
0
MegaSinner
91 / 87 / 3
Регистрация: 09.04.2010
Сообщений: 746
31.08.2013, 20:23 #8
Цитата Сообщение от WaNdera Посмотреть сообщение
Таргет версия 4,0,0
Нет, таргет сдк 17 - это 4.2.
Вот это будет полезно, там все версии расписаны. Приятного кодинга!

EDIT: Не заметил ответов выше..
1
31.08.2013, 20:23
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.08.2013, 20:23
Привет! Вот еще темы с ответами:

Дизайн Андроид приложения - Программирование Android
Как же мне изменить дизайн своеого приложения? Вот, например, я нашел человека, который вроде делает дизайн для андроид приложений:...

Дизайн андроид приложения - Программирование Android
Посоветуйте инструменты(векторной графики) для создания(рисования) фона, кнопок и т.д для андроид приложения.

Адаптировать андроид приложения - Программирование Android
Здравствуйте! Сразу извиняюсь, за то что может быть это тема уже не однократно поднималась. Вопрос: Как адаптировать андроид...

Бот для андроид-приложения - Программирование Android
Подскажите, пожалуйста, как написать бота для андроид-приложения, чтобы он каждый день автоматически в определенное время заходил в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.