Форум программистов, компьютерный форум CyberForum.ru

Программирование Android

Войти
Регистрация
Восстановить пароль
 
Tripolis
1 / 1 / 1
Регистрация: 21.03.2013
Сообщений: 10
#1

uses-sdk - Android

09.09.2013, 20:46. Просмотров 489. Ответов 0
Метки нет (Все метки)

Собственно проблема вот в чем, если в Android Manifest занести любое разрешение, в моем случае это \
XML
1
 <uses-permission android:name="android.permission.INTERNET" />
то строка в Eclipce
XML
1
<uses-sdk android:minSdkVersion="11" />
начинает светиться желтым показывая
<uses-sdk> tag should specify a target API level (the highest verified version; when running on later versions,
compatibility behaviors may be enabled) with android:targetSdkVersion="?"
Программа скомпилируется, но вылетит при любом действии. Если же строчку uses-sdk удалить, программа будет корректно работать, но запросит два ненужных разрешения, а именно о состоянии телефона и запись на SD.
Подскажите, что делать?

Добавлено через 2 часа 28 минут
Все, разобрался сам.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.09.2013, 20:46     uses-sdk
Посмотрите здесь:

Android Android SDK тормозит
Android NDK и SDK
Android SDK or NDK
Android Проблемы с SDK
Android Andoid SDK и Eclipse
SDK на SSD Android
Android "No Android SDK found. configure an Android SDK". Что делать?
Android Vk-android-sdk
Vk sdk Android
Android Eclipse SDK
Android sdk Android
Обновление sdk Android

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Ответ Создать тему
Опции темы

Текущее время: 11:23. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru