Форум программистов, компьютерный форум, киберфорум
Наши страницы
Arch Linux
Войти
Регистрация
Восстановить пароль
 
vempel
0 / 0 / 0
Регистрация: 28.04.2012
Сообщений: 12
1

Ноутбук видит только интегрированную карту

22.07.2019, 14:55. Просмотров 258. Ответов 0

Notebook: SVF1521X1R

Код
Section "Module"
   Load "modesetting"
EndSection

#Nvidia card
#Section "Device"
#    Identifier "nvidia"
#    Driver "nvidia"
#    BusID "PCI:1:0:0"
#    Option "AllowEmptyInitialConfiguration"
#EndSection

#intell card
Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0:2:0"
    Option "AccelMethod" "sna"
    #Option "TearFree" "True"
    #Option "Tiling" "True"
    #Option "SwapbuffersWait" "True"
EndSection
Когда я комментирую Intell card и раскомментирую блок Nvidia система не запускается.

[sergey@sergeyM X11]$ lspci | egrep 'VGA | 3D'
Код
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)
X server лог, когда карта intell закомментирована, а Nvidia раскомментирована:

Код
[    87.650] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[    87.829] 
X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
[    87.829] Build Operating System: Linux Arch Linux
[    87.830] Current Operating System: Linux sergeyM 5.2.0-arch2-1-ARCH #1 SMP PREEMPT Mon Jul 8 18:18:54 UTC 2019 x86_64
[    87.830] Kernel command line: \\vmlinuz-linux ro root=UUID=901fe241-bac5-4c9f-ab28-e4abf40732fc initrd=\initramfs-linux.img
[    87.830] Build Date: 30 June 2019  09:52:01AM
[    87.831]  
[    87.831] Current version of pixman: 0.38.4
[    87.831] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    87.831] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    87.832] (==) Log file: "/home/sergey/.local/share/xorg/Xorg.0.log", Time: Mon Jul 22 13:17:16 2019
[    87.960] (==) Using config file: "/etc/X11/xorg.conf"
[    87.960] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    87.960] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    88.070] (==) No Layout section.  Using the first Screen section.
[    88.070] (==) No screen section available. Using defaults.
[    88.070] (**) |-->Screen "Default Screen Section" (0)
[    88.070] (**) |   |-->Monitor "<default monitor>"
[    88.102] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[    88.102] (**) |   |-->Device "nvidia"
[    88.103] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    88.103] (==) Automatically adding devices
[    88.103] (==) Automatically enabling devices
[    88.103] (==) Automatically adding GPU devices
[    88.103] (==) Automatically binding GPU devices
[    88.103] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    88.153] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    88.153] 	Entry deleted from font path.
[    88.178] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    88.178] 	Entry deleted from font path.
[    88.178] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    88.178] 	Entry deleted from font path.
[    88.178] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    88.178] 	Entry deleted from font path.
[    88.178] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    88.178] 	Entry deleted from font path.
[    88.178] (==) FontPath set to:
	/usr/share/fonts/TTF
[    88.178] (==) ModulePath set to "/usr/lib/xorg/modules"
[    88.178] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    88.178] (II) Module ABI versions:
[    88.179] 	X.Org ANSI C Emulation: 0.4
[    88.179] 	X.Org Video Driver: 24.0
[    88.179] 	X.Org XInput driver : 24.1
[    88.179] 	X.Org Server Extension : 10.0
[    88.181] (++) using VT number 1

[    88.181] (--) controlling tty is VT number 1, auto-enabling KeepTty
[    88.186] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_33
[    88.188] (II) xfree86: Adding drm device (/dev/dri/card1)
[    88.190] (II) systemd-logind: got fd for /dev/dri/card1 226:1 fd 10 paused 0
[    88.196] (II) xfree86: Adding drm device (/dev/dri/card0)
[    88.198] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 11 paused 0
[    88.202] (--) PCI:*(0@0:2:0) 8086:0166:104d:90b8 rev 9, Mem @ 0xd1000000/4194304, 0xc0000000/268435456, I/O @ 0x00004000/64, BIOS @ 0x????????/131072
[    88.202] (--) PCI: (1@0:0:0) 10de:1292:104d:90b8 rev 161, Mem @ 0xd0000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/524288
[    88.202] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    88.202] (II) "glx" will be loaded by default.
[    88.203] (II) LoadModule: "modesetting"
[    88.249] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    88.486] (II) Module modesetting: vendor="X.Org Foundation"
[    88.486] 	compiled for 1.20.5, module version = 1.20.5
[    88.486] 	Module class: X.Org Video Driver
[    88.486] 	ABI class: X.Org Video Driver, version 24.0
[    88.486] (II) LoadModule: "glx"
[    88.501] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    89.017] (II) Module glx: vendor="X.Org Foundation"
[    89.017] 	compiled for 1.20.5, module version = 1.0.0
[    89.017] 	ABI class: X.Org Server Extension, version 10.0
[    89.017] (II) LoadModule: "nvidia"
[    89.017] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    89.425] (II) Module nvidia: vendor="NVIDIA Corporation"
[    89.425] 	compiled for 4.0.2, module version = 1.0.0
[    89.425] 	Module class: X.Org Video Driver
[    89.460] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    89.462] (II) NVIDIA dlloader X Driver  390.116  Sun Jan 27 05:57:42 PST 2019
[    89.462] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    89.463] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[    89.463] (WW) Falling back to old probe method for modesetting
[    89.464] (II) systemd-logind: releasing fd for 226:1
[    89.492] (II) Loading sub module "fb"
[    89.492] (II) LoadModule: "fb"
[    89.493] (II) Loading /usr/lib/xorg/modules/libfb.so
[    89.572] (II) Module fb: vendor="X.Org Foundation"
[    89.572] 	compiled for 1.20.5, module version = 1.0.0
[    89.572] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    89.572] (II) Loading sub module "wfb"
[    89.572] (II) LoadModule: "wfb"
[    89.591] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    89.643] (II) Module wfb: vendor="X.Org Foundation"
[    89.643] 	compiled for 1.20.5, module version = 1.0.0
[    89.643] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    89.643] (II) Loading sub module "ramdac"
[    89.643] (II) LoadModule: "ramdac"
[    89.643] (II) Module "ramdac" already built-in
[    89.773] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    89.773] (EE) NVIDIA:     system's kernel log for additional error messages and
[    89.773] (EE) NVIDIA:     consult the NVIDIA README for details.
[    89.773] (WW) Falling back to old probe method for modesetting
[    89.784] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    89.784] (EE) NVIDIA:     system's kernel log for additional error messages and
[    89.784] (EE) NVIDIA:     consult the NVIDIA README for details.
[    89.784] (II) modeset(G0): using drv /dev/dri/card1
[    89.784] (II) modeset(G1): using drv /dev/dri/card0
[    89.784] (EE) No devices detected.
[    89.784] (EE) 
Fatal server error:
[    89.784] (EE) no screens found(EE) 
[    89.784] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    89.784] (EE) Please also check the log file at "/home/sergey/.local/share/xorg/Xorg.0.log" for additional information.
[    89.785] (EE) 
[    89.795] (EE) Server terminated with error (1). Closing log file.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.07.2019, 14:55
Ответы с готовыми решениями:

Во время установки не видит сетевую карту
Добрый вечер, во время установки Ubuntu 16.04 на ноут Sony Vaio вылетает ошибка ниже. Если...

После переустановки Windows комп не видит сетевую интегрированную карту
Прошу помощи. Комп вдруг перестал включаться. Я переустановил Windows XP (не лицензионный). После...

Dell inspire n5040 видит только интегрированную видеокарту
Система не видит вторую видеокарту ноутбук Dell inspire n5040 видит только интегрированную...

Ноутбук не видит Wi-Fi карту
Ноутбук ACER Extensa 5635ZG-452G25Mnkk LX.EDR0C.035 не видет WI-FI карти. Система стоит Windows 7....

Ноутбук не видит дискретную карту
Доброе время суток. У моего друга случилась проблема с ноутбуком HP - 15-ay538ur. Когда его...

0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.07.2019, 14:55

Ноутбук не видит дискретную карту
Ноутбук Acer Aspire E1-571G, видеоадаптер Nvidia geforce 620m. Началось всё пару месяцев назад....

Включить интегрированную видео карту
Здравствуйте подскажите как включить интегрированную видео карту вместе с обычной если это возможно...

Ноутбук не видит 2 gb оперативной памяти. Из 6 gb видит только 4
Ребят, подскажите может кто сталкивался? ноутбук asus aspire. Изначально комплектация одной...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru