Форум программистов, компьютерный форум, киберфорум
Наши страницы
C#: ASP.NET Core
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
Alex_student
18 / 18 / 8
Регистрация: 10.02.2013
Сообщений: 250
Завершенные тесты: 1
1

Не подгружает стили

19.10.2015, 20:29. Просмотров 1210. Ответов 6
Метки нет (Все метки)

Доброго времени суток уважаемые форумчане.
Возник такой вопрос, разрабатываю сайт и развернул его на IIS, все отображается гуд и отлично и все стили и скрипты подгружаются, но когда разворачиваю с помощью IIS Express скрипты и стили не подгружаются и в браузере пишет 500 ошибку. Подскажите пожалуйста в какую сторону копать то? и в чем возможная причина?
За ранее огромное спасибо!
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.10.2015, 20:29
Ответы с готовыми решениями:

Новость с символьным кодом не подгружает стили сайта
Новость с символьным кодом не подгружает стили сайта, отображается только новость. В настройках...

Встроенные стили элементов или стили в отдельном файле
Здравствуйте. Вопрос чисто из интереса, хотелось бы знать, как лучше с теоретической точки зрения. ...

Не подгружает BG
Помогите, сайт не хочет подгружать BG. Как правильно прописывать пусть в css. Мой вариант: ...

Не подгружает шаблоны
Нужно было поставить новый шаблон. Загружаю как всегда, но вместо того, что бы написать шаблон...

Не подгружает полностью страницу
Всем ,привет! столкнулся с такой проблемой, что chrome,opera,firefox не подгружает полностью...

6
Metall_Version
2124 / 1261 / 516
Регистрация: 04.03.2014
Сообщений: 4,092
Завершенные тесты: 2
19.10.2015, 20:44 2
Цитата Сообщение от Alex_student Посмотреть сообщение
браузере пишет 500 ошибку
сообщение ошибки какое? бандлы используете? показывайте web.config
0
Alex_student
18 / 18 / 8
Регистрация: 10.02.2013
Сообщений: 250
Завершенные тесты: 1
19.10.2015, 21:03  [ТС] 3
http://localhost:8887/Content/site.css Failed to load resource: the server responded with a status of 500 (Internal Server Error) - это ошибка по стилям и скриптам ..везде однотипная на другие файлы думаю приводить не стоит.
Да использую бандлы, пробовал убрать их и стандартно подключать, но к сожалению не помогло.
а вот и web.config
XML
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
<?xml version="1.0" encoding="utf-8"?>
<!--
  For more information on how to configure your ASP.NET application, please visit
  [url]http://go.microsoft.com/fwlink/?LinkId=301880[/url]
  -->
<configuration>
  <configSections>
    
    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
  <!-- For more information on Entity Framework configuration, visit [url]http://go.microsoft.com/fwlink/?LinkID=237468[/url] --></configSections>
  <connectionStrings>
    <add name="XXX" connectionString="Data Source=.\;Initial Catalog=XXX;Integrated Security=True" providerName="System.Data.SqlClient" />
  </connectionStrings>
  <appSettings>
    <add key="webpages:Version" value="3.0.0.0" />
    <add key="webpages:Enabled" value="false" />
    <add key="ClientValidationEnabled" value="true" />
    <add key="UnobtrusiveJavaScriptEnabled" value="true" />
  </appSettings>
  <system.web>
    <authentication mode="None" />
    <compilation debug="true" targetFramework="4.5" />
    <httpRuntime targetFramework="4.5" />
  </system.web>
  <system.webServer>
    <modules>
      <remove name="FormsAuthenticationModule" />
    </modules>
        <staticContent>
            <mimeMap fileExtension=".woff" mimeType="application/x-font-woff" />
        </staticContent>
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Helpers" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Mvc" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-5.0.0.0" newVersion="5.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.WebPages" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-3.0.0.0" newVersion="3.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="WebGrease" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="0.0.0.0-1.5.2.14234" newVersion="1.5.2.14234" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.AspNet.Identity.Core" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-2.0.0.0" newVersion="2.0.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-2.1.0.0" newVersion="2.1.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="Microsoft.Owin.Security" publicKeyToken="31bf3856ad364e35" culture="neutral" />
        <bindingRedirect oldVersion="0.0.0.0-2.1.0.0" newVersion="2.1.0.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
  <entityFramework>
    <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
      <parameters>
        <parameter value="v11.0" />
      </parameters>
    </defaultConnectionFactory>
    <providers>
      <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
    </providers>
  </entityFramework>
</configuration>
0
Metall_Version
2124 / 1261 / 516
Регистрация: 04.03.2014
Сообщений: 4,092
Завершенные тесты: 2
19.10.2015, 21:21 4
Цитата Сообщение от Alex_student Посмотреть сообщение
http://localhost:8887/Content/site.css
это ты не развернул в iis
создай сайт в iis, физический путь укажи на свое приложение, задай ему домен, и по нему обращайся к своему приложению

Добавлено через 3 минуты
Цитата Сообщение от Alex_student Посмотреть сообщение
это ошибка по стилям и скриптам
скопируй url для файла который не грузится и открой в новой вкладке, увидишь полный текст описания ошибки

очень странно видеть 500 ошибку при загрузке файлов, чуствую проблема с бандлами
0
Alex_student
18 / 18 / 8
Регистрация: 10.02.2013
Сообщений: 250
Завершенные тесты: 1
19.10.2015, 21:34  [ТС] 5
Да, это я запускал уже через IIS Express, в обычном IIS все норм отображается (правда домен не задаю а просто через порт стучусь)
открыл в другом окне как Вы и советовали.
пишет что ошибка в этих строках:

XML
1
2
3
   29:         <staticContent>
   30:             <mimeMap fileExtension=".woff" mimeType="application/x-font-woff" />
   31:         </staticContent>
после того как закоментировал 30 строку все норм отобразилось... не понятная штука одним слово). Спасибо за совет
0
Metall_Version
2124 / 1261 / 516
Регистрация: 04.03.2014
Сообщений: 4,092
Завершенные тесты: 2
19.10.2015, 21:42 6
Лучший ответ Сообщение было отмечено Alex_student как решение

Решение

Цитата Сообщение от Alex_student Посмотреть сообщение
в обычном IIS все норм отображается (правда домен не задаю а просто через порт стучусь)
это как раз и есть IIS Express
а обычный iis это там где мы создаем сайт и указываем его домен (в двух словах)

Цитата Сообщение от Alex_student Посмотреть сообщение
после того как закоментировал 30 строку все норм отобразилось... не понятная штука одним слово). Спасибо за совет
ну если еще и ошибки читать то все будет понятно, на сколько я догадываюсь в тексте ошибки написано что это расширение не зарегистрировано в iis, или зарегистрировано но с другим типом.

чтобы зарегистрировать его в iis нужно сделать : открыть iis, выбираем наш сайт, справа выбираем меню "Типы MIME", нажимаем "Добавить" и добавляем необходимый тип (или изменяем существующий)-
расширение файла ".woff"
а тип MIME - "application/font-woff"

в общем в итоге там должен быть этот тип


еще может похожая ошибка если используешь файлы с расширением .woff2, нужно будет проделать аналогичную операцию
1
Alex_student
18 / 18 / 8
Регистрация: 10.02.2013
Сообщений: 250
Завершенные тесты: 1
19.10.2015, 21:44  [ТС] 7
ДА спасибо большое) уже начал копать в этом направлении.

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

0
19.10.2015, 21:44
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
19.10.2015, 21:44

IronPython 2.7 не подгружает xlrd
IronPython 2.7 хочу подгрузить библиотеку для работы с эксель (создание файла/чтение /запись) ...

Браузер подгружает лишний код
Здравствуйте! Вначале я обратил внимание, что иногда выскакивает в отдельном окошке...

Realtek hd сильно подгружает систему
подозреваю что это майнер, до этого подцепил цеую кучу вирусни в интернете, лечил от касперского до...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru