Форум программистов, компьютерный форум CyberForum.ru

Basic4Android

Войти
Регистрация
Восстановить пароль
 
Рейтинг: Рейтинг темы: голосов - 9, средняя оценка - 4.67
Fire_Hawk
0 / 0 / 0
Регистрация: 09.11.2015
Сообщений: 14
#1

Ошибка "unknown android-api-level-9" при установке admob в eclipse - Basic4Android

06.03.2016, 08:53. Просмотров 1558. Ответов 8
Метки нет (Все метки)

пробую установить admob в eclipse как тут описано https://developers.google.com/admob/android/eclipse но ничего не получается после создания проекта с существующим кодом выдаёт unknown android-api-level-9
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.03.2016, 08:53     Ошибка "unknown android-api-level-9" при установке admob в eclipse
Посмотрите здесь:
Windows 7 При установке драйвера для NVIDIA GeForce GTX 460 появляется сообщение: "An unknown error has occurred"
ошибка при установке Android SDk на eclipse Android
Ошибка "inaccessible due to its protection level" при обходе объектов в коллекции C#
Turbo Pascal При использовании функции log (x) при компиляции выводится ошибка "unknown identifier"
C++ Ошибка при компиляции "Size of the type 'char[]' is unknown or zero"
Ошибка при создании триггера: "Column unknown"
Ошибка "Protocol error: Unknown transport" при использовании SignalR C# MVC
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Vladimir93
36 / 36 / 4
Регистрация: 28.06.2015
Сообщений: 151
07.03.2016, 13:17     Ошибка "unknown android-api-level-9" при установке admob в eclipse #2
Вам нужно, загрузить, API - 9. В эклипсе. Что бы эта библиотека отображалась, нужно поставить галку, Obsolete
DAngel85
0 / 0 / 0
Регистрация: 09.07.2016
Сообщений: 6
23.07.2016, 13:58     Ошибка "unknown android-api-level-9" при установке admob в eclipse #3
Здравствуйте! При попытке подключения Admob к своему проекту столкнулся с такой проблемой:

B4A version: 5.50
Parsing code. (0.01s)
Compiling code. (0.06s)
Compiling layouts code. (0.00s)
Generating R file. Error
d:\android\sdk\extras\google\google-play-services\libproject\google-play-services_lib\res\values-v21\appinvite_styles.xml:5: error: Error retrieving parent for item: No resource found that matches the given name '@android:style/Theme.Material.Light.DialogWhenLarge.NoActionBar'.


Подскажите, с чем может быть связано, и как с этим бороться!
DAngel85
0 / 0 / 0
Регистрация: 09.07.2016
Сообщений: 6
24.07.2016, 17:16     Ошибка "unknown android-api-level-9" при установке admob в eclipse #4
Решено добавлением последней google-play-services.jar в папку библиотек b4a.
Но при выполнении AdView1.LoadAd выдает такую ошибку:

java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Boolean

В яве не силен, подскажите, в чем может быть проблема?
Vladimir93
36 / 36 / 4
Регистрация: 28.06.2015
Сообщений: 151
25.07.2016, 10:30     Ошибка "unknown android-api-level-9" при установке admob в eclipse #5
А чем там Java, написано же нельзя привести стрингу к булке. Ищите, где то пытаетесь принудительно преобразовать.
DAngel85
0 / 0 / 0
Регистрация: 09.07.2016
Сообщений: 6
25.07.2016, 16:50     Ошибка "unknown android-api-level-9" при установке admob в eclipse #6
Это понятно, но единственный код, который я добавил - это и тутора:

AdView1.Initialize("Ad", "мой admob id")
Activity.AddView(AdView1, 0dip, 0dip, 320dip, 50dip)' AdView1.LoadAd 'loads an ad
AdView1.LoadAd

И ошибка появляется именно после него.

Добавлено через 7 минут
*из тутора

Добавлено через 5 часов 19 минут
Люди, помогите!
Пробовал на примере из admob-interstitial-playservices-1.02. Опять же ошибка возникает после .LoadAd

В чем искать проблему? В SDK, Google Play Services, Admob?
Уже не знаю, что делать...
FGL_Alexey
0 / 0 / 0
Регистрация: 27.09.2016
Сообщений: 7
27.09.2016, 14:16     Ошибка "unknown android-api-level-9" при установке admob в eclipse #7
DAngel85, если вопрос ещё актуален. Можно скомпилировать .apk как есть, а затем вшить в него рекламу по вот этому туториалу: http://gamedevblogs.ru/blog/fgl/1860.html
DAngel85
0 / 0 / 0
Регистрация: 09.07.2016
Сообщений: 6
02.10.2016, 23:08     Ошибка "unknown android-api-level-9" при установке admob в eclipse #8
FGL_Alexey, спасибо за совет! Единственное, не могу понять как прикрепить библиотеку, которую требует Enhance. Не подскажите решение? Буду очень признателен!
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
03.10.2016, 12:24     Ошибка "unknown android-api-level-9" при установке admob в eclipse
Еще ссылки по теме:
При описании функции по выделению N-го слова выдаётся ошибка "Unknown identifier" Turbo Pascal
.NET После запуска среды выскакивает окошечко с ошибкой "Unknown error" или "Неизвестная ошибка"
Ошибка "Failed to initialize client - unknown error" при запуске Code of Honor 3
C++ Ошибка в Eclipse "Type Program "make" not found in PATH"
Windows 8, 8.1 Ошибка при установке: "Нам не удалось найти драйверы..."

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
FGL_Alexey
0 / 0 / 0
Регистрация: 27.09.2016
Сообщений: 7
03.10.2016, 12:24     Ошибка "unknown android-api-level-9" при установке admob в eclipse #9
Библиотека нужна будет если показывать/прятать. Для Basic4Android её ещё нет, но расскажу по секрету, что в очереди - задача отключения баннера за in-app с помощью ZeroCode, без программирования.
Yandex
Объявления
03.10.2016, 12:24     Ошибка "unknown android-api-level-9" при установке admob в eclipse
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru