Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.53/17: Рейтинг темы: голосов - 17, средняя оценка - 4.53
Rockstar7
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 9
1

Настройка cisco 3750

08.11.2013, 21:51. Просмотров 3451. Ответов 7
Метки нет (Все метки)

Есть сеть 10.0.0.0 и есть выход в интернет адрес 22.22.22.22 шлюз 22.22.22.23. нужно сделать выход в интернет, далее что я вводил. (возможности выложить конфиг нет напишу кратко)
int fa0 /wan
ip add 22.22.22.22
no switchport
int ge1 /lan
mode access
vlan 20
int vlan20 /виртуальный интерфейс
ip add 10.0.0.1

ip routing
ip route 0.0.0.0 0.0.0.0 22.22.22.23

итог с свича пингуются обе подсети а с локальной не пингуется даже шлюз провайдера. Таблица маршрутизации в порядке, все сети подключены.

зы и на интерфейсах не вводится команда ip nat, как будто он ее не знает.

Добавлено через 21 минуту
Выкладываю конфиг здесь ip провайдера заменен на локальный но суть не меняет 192.168.0.1 шлюз .234 адрес интерфейса.

Кликните здесь для просмотра всего текста
Код
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
boot-start-marker
boot-end-marker
no aaa new-model
switch 1 provision ws-c3750x-24
system mtu routing 1500
crypto pki trustpoint TP-self-signed-3928023552
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3928023552
 revocation-check none
 rsakeypair TP-self-signed-3928023552

spanning-tree mode pvst
spanning-tree extend system-id
vlan internal allocation policy ascending
!
interface FastEthernet0
 no ip address
 no ip route-cache
!
interface GigabitEthernet1/0/1
 no switchport
 ip address 192.168.0.234 255.255.252.0
 no ip route-cache
!
interface GigabitEthernet1/0/2
 no switchport
 ip address 10.0.0.1 255.255.252.0
 no ip route-cache

interface Vlan1
 no ip address
 no ip route-cache
!
interface Vlan3
 no ip address
 no ip route-cache
!
ip default-gateway 192.168.0.1
ip http server
ip http secure-server

ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip routing


Код
Gateway of last resort is 192.168.0.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.0.1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/22 is directly connected, GigabitEthernet1/0/2
L        10.0.0.1/32 is directly connected, GigabitEthernet1/0/2
C     192.168.0.0/22 is directly connected, GigabitEthernet1/0/1
      192.168.0.0/32 is subnetted, 1 subnets
L        192.168.0.234 is directly connected, GigabitEthernet1/0/1
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.11.2013, 21:51
Ответы с готовыми решениями:

Соедниене 2-х CISCO CATALYST 3750
Добрый вечер!!! Подскажите пожалуйста знающие люди... Насколько я понимаю 2 коммутатора между...

Маршрутизация на Cisco Catalyst 3750
Схема: Свитч 3750, к нему подключены 2 два свитча 2950. На 3750 включен ip routing. На всех...

Интернет в vlan, cisco catalyst 3750
Здравствуйте , помогите разобраться с cisco, подарили мне cisco вот пытаюсь его изучить в свободное...

Trunk port между cisco 3750
Добрый день. Кто знает как создать транковый порт между двумя cisco 3750 ? По подробней...

IGMP-filtering на cisco catalyst 3750
Добрый день. Прошу помощи, цискарь я никакой! Вкратце: Есть мультиплексор (стример), на нем...

7
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
09.11.2013, 01:56 2
Цитата Сообщение от Rockstar7 Посмотреть сообщение
зы и на интерфейсах не вводится команда ip nat, как будто он ее не знает
так и есть...(
0
Rockstar7
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 9
09.11.2013, 13:45  [ТС] 3
Решено! подключал wan к 100 мегабитному интерфейсу, который рядом с консольным. Так делать нельзя, тк все что на него приходит не маршрутизируется и не комутируется. Ну и nat недоступен для 3750)
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
09.11.2013, 14:01 4
Цитата Сообщение от Rockstar7 Посмотреть сообщение
подключал wan к 100 мегабитному интерфейсу
management port так и не должен работать
0
09.11.2013, 14:01
Rockstar7
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 9
10.11.2013, 22:16  [ТС] 5
хм тупой вопрос а вообще конфига белый айпи + приватная сеть без ната будет раздавать интернет?!

Добавлено через 10 минут
имхо не должна, соурс ip из приватной сети будет(((
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
10.11.2013, 22:25 6
Цитата Сообщение от Rockstar7 Посмотреть сообщение
хм тупой вопрос а вообще конфига белый айпи + приватная сеть без ната будет раздавать интернет?!
не вполне понял вопрос, но без ната можно иметь интернет, только если конечное(ые) устройство(а) будет иметь маршрутизируемый в глобальной сети адрес.
0
Rockstar7
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 9
10.11.2013, 22:59  [ТС] 7
Вот этого и боюсь что в интернет он с адресом 10.0.0.0 уйдет, был бы на его пути нат или прокси обратно бы пакеты шли а тут не уверен.

Добавлено через 3 минуты
в наличии есть рутеры на dd-wrt, наверное придется временно один поставить и обратный маршрут по умолчанию на нем задать.
0
Jabbson
Эксперт по компьютерным сетям
3462 / 2505 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
11.11.2013, 00:00 8
Так и поступите!
0
11.11.2013, 00:00
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
11.11.2013, 00:00

Cisco 3750, нужна помошь, почему не применяютсят ACL?
Cisco 3750: IOS (tm) C3750 Software (C3750-I9-M), Version 12.1(19)EA1d, RELEASE SOFTWARE (fc1)...

Cisco C881 настройка SIP ALG через Cisco Configuration Professional
Cisco C881 настройка SIP ALG через Cisco Configuration Professional Есть маршрутизатор Cisco...

Настройка сети с оборудивания Cisco, в Cisco Packet Tracer
Добрий день. Помогите настроить сеть. Есть физическая топология, есть разпределени между собой...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.