Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
kolka88
1 / 1 / 1
Регистрация: 25.10.2012
Сообщений: 63
1

DMVPN+IPSEC+EIGRP Spoke не видит другого Spoke

09.01.2014, 07:35. Просмотров 870. Ответов 7
Метки нет (Все метки)

Приветствую Вас уважаемые форумчане. Подскажите плз настроил DMVPN Hub-and-2 Spoke, работает от хаба к спокам все отлично, но вот не могу отпинговать со Spoke локальную сеть второго Spoke....

Конфиг Hub:
Кликните здесь для просмотра всего текста
Код
interface Tunnel11
 ip address 10.135.200.1 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nat inside
 ip nhrp map multicast dynamic
 ip nhrp network-id 125
 ip nhrp holdtime 400
 ip virtual-reassembly in
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet0/0.3643
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile IPSPROFILE

router eigrp 10
 network 10.0.0.0
 redistribute connected route-map Local_nets
 redistribute static route-map Local_nets


Конфиг Spoke 1:
Кликните здесь для просмотра всего текста
Код
interface Tunnel11
 ip address 10.135.200.3 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp map 10.135.200.1 82.162.31.82
 ip nhrp map multicast 82.162.31.82
 ip nhrp network-id 125
 ip nhrp holdtime 400
 ip nhrp nhs 10.135.200.1
 ip tcp adjust-mss 1360
 tunnel source Loopback0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile IPSPROFILE

router eigrp 10
 redistribute connected route-map Local_nets
 redistribute static route-map Local_nets
 network 10.0.0.0
 no auto-summary


Конфиг Spoke 2:

Кликните здесь для просмотра всего текста
Код
interface Tunnel11
 ip address 10.135.200.8 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp map multicast 82.162.31.82
 ip nhrp map 10.135.200.1 82.162.31.82
 ip nhrp network-id 125
 ip nhrp holdtime 400
 ip nhrp nhs 10.135.200.1
 ip tcp adjust-mss 1360
 tunnel source GigabitEthernet0/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile IPSPROFILE

router eigrp 10
 network 10.0.0.0
 redistribute connected route-map Local_nets
 redistribute static route-map Local_nets


В суммарной информации на любом из Spoke вижу только HUB...

Код
sh ip nhrp brief
   Target             Via            NBMA           Mode   Intfc   Claimed 
10.135.200.1/32      10.135.200.1    82.162.31.82    static   Tu11    <   >
Но насколько я понял должна быть и запись с динамическим тунелем... Но ее нет. Форумчане что где не так сделано? Получается что я не вижу локальную сеть от Spoke к Spoke а вот от HUB до любого Spoke без проблем...
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.01.2014, 07:35
Ответы с готовыми решениями:

GNS3. Примеры конфигураций VPN (GRE/IPSEC), DMVPN, IP SLA, EBGP
Приведу в теме примеры конфигураций роутеров (во вложениях) для настройки VPN (GRE/IPSEC), DMVPN,...

Несколько DMVPN с одного внешнего IP адреса
Всем привет. Недавно нарисовалась такая проблема. Есть циска 1841 с внешним адресом,с которой...

Не видит RayCast из другого скрипта
Здравствуйте. Есть скрипт который создаёт декаль, после вызывает метод в другом скрипте(на декале)...

windods не видит другого винчестера
windods не баче другого вінча

Почему модуль не видит процедуру из другого подключенного к нему модуля?
Помогите, пожалуйста, найти ошибку. Почему модуль не видит расшареную в другом модуле процедуру?...

7
Jabbson
Эксперт по компьютерным сетям
3368 / 2439 / 751
Регистрация: 03.11.2009
Сообщений: 7,774
Записей в блоге: 3
09.01.2014, 11:12 2
если маршрутизация через eigrp, на хабе должно быть no ip next-hop-self eigtp #
для того, чтобы споки могли разговаривать друг с другом без участия хаба.

Добавлено через 6 минут
Чтобы споки знали о маршрутах друг друга, еще может понадобиться no ip split-horizon eigrp #
1
kolka88
1 / 1 / 1
Регистрация: 25.10.2012
Сообщений: 63
09.01.2014, 13:06  [ТС] 3
Цитата Сообщение от Jabbson Посмотреть сообщение
если маршрутизация через eigrp, на хабе должно быть no ip next-hop-self eigtp #
для того, чтобы споки могли разговаривать друг с другом без участия хаба.

Добавлено через 6 минут
Чтобы споки знали о маршрутах друг друга, еще может понадобиться no ip split-horizon eigrp #
Прописал. Маршруты не появились... положил и поднял тунели на Spoke результата 0.... прикладываю конфиги которые сейчас получились.

HUB:

Кликните здесь для просмотра всего текста
Код
interface Tunnel11
 ip address 10.135.200.1 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 125
 ip nat inside
 ip nhrp map multicast dynamic
 ip nhrp network-id 125
 ip nhrp holdtime 400
 ip virtual-reassembly in
 ip tcp adjust-mss 1360
 no ip split-horizon eigrp 125
 tunnel source GigabitEthernet0/0.3643
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile IPSPROFILE

router eigrp 10
 network 10.0.0.0
 redistribute connected route-map Local_nets
 redistribute static route-map Local_nets


Spoke1:
Кликните здесь для просмотра всего текста
Код
interface Tunnel11
 ip address 10.135.200.8 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 125
 ip nhrp map multicast 82.162.31.82
 ip nhrp map 10.135.200.1 82.162.31.82
 ip nhrp network-id 125
 ip nhrp holdtime 400
 ip nhrp nhs 10.135.200.1
 ip tcp adjust-mss 1360
 no ip split-horizon eigrp 125
 tunnel source GigabitEthernet0/0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile IPSPROFILE

router eigrp 10
 network 10.0.0.0
 redistribute connected route-map Local_nets
 redistribute static route-map Local_nets
 eigrp stub connected summary


Spoke2:
Кликните здесь для просмотра всего текста
Код
interface Tunnel11
 ip address 10.135.200.3 255.255.255.0
 no ip redirects
 ip mtu 1400
 no ip next-hop-self eigrp 125
 ip nhrp map 10.135.200.1 82.162.31.82
 ip nhrp map multicast 82.162.31.82
 ip nhrp network-id 125
 ip nhrp holdtime 400
 ip nhrp nhs 10.135.200.1
 ip tcp adjust-mss 1360
 no ip split-horizon eigrp 125
 tunnel source Loopback0
 tunnel mode gre multipoint
 tunnel path-mtu-discovery
 tunnel protection ipsec profile IPSPROFILE
end

router eigrp 10
 network 10.0.0.0
 redistribute connected route-map Local_nets
 redistribute static route-map Local_nets
 eigrp stub connected summary
0
Jabbson
Эксперт по компьютерным сетям
3368 / 2439 / 751
Регистрация: 03.11.2009
Сообщений: 7,774
Записей в блоге: 3
09.01.2014, 13:12 4
eigrp 125?
1
kolka88
1 / 1 / 1
Регистрация: 25.10.2012
Сообщений: 63
09.01.2014, 13:39  [ТС] 5
Цитата Сообщение от Jabbson Посмотреть сообщение
eigrp 125?
упс...
0
Jabbson
Эксперт по компьютерным сетям
3368 / 2439 / 751
Регистрация: 03.11.2009
Сообщений: 7,774
Записей в блоге: 3
09.01.2014, 13:40 6
а можно конфиг для 125, а то в первом сообщении вижу только 10

upd
Цитата Сообщение от kolka88 Посмотреть сообщение
упс...
1
kolka88
1 / 1 / 1
Регистрация: 25.10.2012
Сообщений: 63
09.01.2014, 13:49  [ТС] 7
Цитата Сообщение от Jabbson Посмотреть сообщение
а можно конфиг для 125, а то в первом сообщении вижу только 10

upd

Просто наиогромнейшее спасибо за поиски ошибки в моем кривом конфиге... Все заработало.... Спасибо! пересоздал просто процесс eigrp под as 125 и все заработало.
0
Jabbson
Эксперт по компьютерным сетям
3368 / 2439 / 751
Регистрация: 03.11.2009
Сообщений: 7,774
Записей в блоге: 3
09.01.2014, 13:55 8
всегда пожалуйста
1
09.01.2014, 13:55
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.01.2014, 13:55

Не баг ли? Объект видит приватные члены другого объекта этого же класса
не баг ли что getObj() можно изменять приватное свойство другого объекта class Exam1 { ...

EIGRP
Вопрос возник.. делаю лабы по CCNA, конкретно - TS EIGRP. В моем понимании на Perimetr router ,...

EIGRP
Доброе утро Есть Successor ( Tunnel 1 ) Метрика 1 Есть Feasible Successor ( Tunnel 2 )...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru