Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.88/16: Рейтинг темы: голосов - 16, средняя оценка - 4.88
kycik
0 / 0 / 0
Регистрация: 04.06.2013
Сообщений: 112
1

Перенаправление в другую сеть

27.02.2014, 14:01. Просмотров 3259. Ответов 50
Метки нет (Все метки)

Есть router 3945 он подключен в 3 сети
1) Внешка от провайдера которая уходит в NAT с локалкой G0/0
2) Внутренняя (192.168.0.0 /24) G0/1
3) Сеть м/ду другими зданиями (10.0.0.0/21) G0/2
как можно настроить что бы клиенты из 192 обращаясь к 10 перенаправлялись в порт g0/2 а не в g0/0 (он указан как шлюз по умолчанию)?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.02.2014, 14:01
Ответы с готовыми решениями:

Проброс пк в другую сеть.
Добрый день! Вот недавно начал работать с cisco. поставили задачу: Компьютер "Здание2" вынести в...

Как не попасть в другую сеть через роутер
День добрый! Ситуация такая: Есть 2 роутера. 1й подключен для офиса asus rt-n16 2й роутер...

Одна сеть не видит другую (PPTP между двумя офисами)
Добрый день. Поднял pptp сервер на микротике RB2011UiAS-2HnD-IN. Создал пользователя который...

Перенаправление на другую страницу
Добрый день! как сделать так, что когда пользватель заходит на сайте на определенную страницу, его...

Перенаправление на другую страницу
Часть кода(вверху еще куча кода): else{ mail($admin_email1, $form_subject, $message, "From:...

50
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
27.02.2014, 14:12 2
статический роут?
0
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
27.02.2014, 14:15 3
Цитата Сообщение от kycik Посмотреть сообщение
как можно настроить что бы клиенты из 192 обращаясь к 10 перенаправлялись в порт g0/2 а не в g0/0 (он указан как шлюз по умолчанию)?
если я Вас правильно понял, и маршрутизация у Вас статическая, то вот так:
ip route 10.0.0.0 255.255.248.0 gi0/2
0
kycik
0 / 0 / 0
Регистрация: 04.06.2013
Сообщений: 112
27.02.2014, 14:31  [ТС] 4
Цитата Сообщение от Jabbson Посмотреть сообщение
статический роут?
нет не помогает, т.к. на циске для подключения к внешке поднят dialer с ppp и все это в нате с маршрутом по умолчанию на dialer интерфейс. Он тупо все пакеты шлет к провайдеру(ip route 0.0.0.0 0.0.0.0 Dialer1) мне нужно чтобы клиентам все сети включая внешка доступна была.
0
27.02.2014, 14:31
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
27.02.2014, 14:37 5
Цитата Сообщение от kycik Посмотреть сообщение
нет не помогает
тогда конфиг в студию
0
kycik
0 / 0 / 0
Регистрация: 04.06.2013
Сообщений: 112
27.02.2014, 14:48  [ТС] 6
Цитата Сообщение от W_Jim Посмотреть сообщение
конфиг в студию
Код
version 15.3
ip domain name xxxxxx
ip host XXXXXXXX
ip name-server XXXXXXXX
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
vpdn enable
!
vpdn-group 1
!
username admin privilege 15 password 0 XXXXXXXX
!
redundancy
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description LAN-ZDANIA
 ip address 10.0.0.1 255.255.255.0
 shutdown
!
interface GigabitEthernet0/1
 description INTERNET
 no ip address
 ip nat outside
 ip virtual-reassembly in
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no keepalive
 no cdp enable
!
interface GigabitEthernet0/2
 description LAN
 ip address 192.168.0.1 255.255.255.0
 ip access-group list in
 ip nat inside
 ip virtual-reassembly in
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 no ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname XXXXXXXX
 ppp chap password 0 XXXXXXXX
 ppp pap sent-username XXXXXXXX password XXXXXXXX
 no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat translation timeout 600
ip nat translation tcp-timeout 300
ip nat translation udp-timeout 60
ip nat translation dns-timeout 10
ip nat translation port-timeout tcp 110 60
ip nat translation port-timeout tcp 25 60
ip nat translation port-timeout tcp 8080 20
ip nat translation port-timeout tcp 80 20
ip nat inside source list 10 interface Dialer1 overload
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list extended list
 permit tcp any any eq www
 permit ip host 192.168.0.90 any
 deny   ip any any
!
dialer-list 1 protocol ip permit
!
access-list 10 permit 192.168.0.0 0.0.0.255
access-list 23 permit 192.168.0.0 0.0.255.255
access-list 112 permit tcp any any
access-list 112 permit udp any any
access-list 112 permit icmp any any
access-list 112 permit tcp any any eq www
access-list 112 permit 25 any any
access-list 112 permit 110 any any
!
control-plane
!
banner login XXXXX
!
line con 0
 password XXXXXXXX
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 access-class 23 in
 privilege level 15
 password XXXXXXXX
 logging synchronous
 transport input ssh
!
scheduler allocate 20000 1000
!
end
0
cat_driver
57 / 48 / 3
Регистрация: 19.12.2013
Сообщений: 203
27.02.2014, 14:55 7
Цитата Сообщение от kycik Посмотреть сообщение
interface GigabitEthernet0/0
description LAN-ZDANIA ip address
10.0.0.1 255.255.255.0
shutdown
?

че то конфиг со словами не сходится, или я уже туплю к концу дня?

сетки connected, поэтому поидеи ниче ненадо делать если все терминируется на роутере этом.
0
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
27.02.2014, 15:26 8
Цитата Сообщение от kycik Посмотреть сообщение
interface GigabitEthernet0/0
...
shutdown
...
!
interface GigabitEthernet0/2
...
ip access-group list in
...
!
ip access-list extended list
permit tcp any any eq www
permit ip host 192.168.0.90 any
deny ip any any
!
маршрутизация здесь не нужна...
нужно включить G0/0
и подправить ACL...

Добавлено через 23 минуты
точнее, не маршрутизация не нужна, а маршруты никакие дополнительно прописывать не нужно...
0
kycik
0 / 0 / 0
Регистрация: 04.06.2013
Сообщений: 112
27.02.2014, 15:32  [ТС] 9
Цитата Сообщение от cat_driver Посмотреть сообщение
че то конфиг со словами не сходится, или я уже туплю к концу дня?
сетки connected, поэтому поидеи ниче ненадо делать если все терминируется на роутере этом.
если вы про shutdown то отключил временно....
Цитата Сообщение от W_Jim Посмотреть сообщение
маршрутизация здесь не нужна...
нужно включить G0/0
и подправить ACL...
думаю не в этом проблема
.......
!
ip access-list extended list
permit tcp any any
permit udp any any
permit ip host 192.168.0.90 any
!
.....
вот клиент что говорит
Трассировка маршрута к 10.24.11.1 с максимальном числом прыжков 30
1 <1 ¬б 1 ms <1 ¬б router [192.168.0.1]
2 1 ms 1 ms 2 ms 85.XXXXXX
3 2 ms 1 ms 1 ms 85.XXXXXX
4 * * * Превышен интервал ожидания запроса

немного поясню
клиенты находящиеся в 192, хотят и внешку и 10 сетку...
0
Jabbson
Эксперт по компьютерным сетям
3449 / 2493 / 778
Регистрация: 03.11.2009
Сообщений: 7,937
Записей в блоге: 3
27.02.2014, 15:33 10
Цитата Сообщение от kycik Посмотреть сообщение
1) Внешка от провайдера которая уходит в NAT с локалкой G0/0
2) Внутренняя (192.168.0.0 /24) G0/1
3) Сеть м/ду другими зданиями (10.0.0.0/21) G0/2
Цитата Сообщение от kycik Посмотреть сообщение
interface GigabitEthernet0/0
description LAN-ZDANIA
!
interface GigabitEthernet0/1
description INTERNET
!
interface GigabitEthernet0/2
description LAN
не сходится
0
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
27.02.2014, 15:37 11
Цитата Сообщение от kycik Посмотреть сообщение
думаю не в этом проблема
...
interface GigabitEthernet0/0
description LAN-ZDANIA
ip address 10.0.0.1 255.255.255.0
...
Трассировка маршрута к 10.24.11.1
конечно не в этом... это же две разные сети... маршрутизатор о ней ничего не знает, вот и шлет пакеты на дефолт...
вам нужно либо интерфейс ввести в нужную подсеть, либо, если 10.24.11.1 находится за другим маршрутизатором, на обоих маршруты прописывать...
и даже если Вы это настроите, работать ничего не будет, пока Вы ACL не приведете в порядок...
0
kycik
0 / 0 / 0
Регистрация: 04.06.2013
Сообщений: 112
27.02.2014, 15:57  [ТС] 12
Цитата Сообщение от Jabbson Посмотреть сообщение
не сходится
когда тему создавал писал по памяти не сравнивал с config

1) Внешка от провайдера которая уходит в NAT с локалкой G0/1
2) Внутренняя (192.168.0.0 /24) G0/2
3) Сеть м/ду другими зданиями (10.0.0.0/21) G0/0
0
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
27.02.2014, 16:01 13
Цитата Сообщение от kycik Посмотреть сообщение
3) Сеть м/ду другими зданиями (10.0.0.0/21) G0/0
опять не сходится, ибо на интрефейсе у Вас:
Цитата Сообщение от kycik Посмотреть сообщение
interface GigabitEthernet0/0
description LAN-ZDANIA
ip address 10.0.0.1 255.255.255.0
а это не /21 а /24
0
kycik
0 / 0 / 0
Регистрация: 04.06.2013
Сообщений: 112
27.02.2014, 16:07  [ТС] 14
Цитата Сообщение от W_Jim Посмотреть сообщение
конечно не в этом... это же две разные сети...
извените коллеги совсем голова не варит, день очень тяжелый готовил txt другим...вот то что запостить хотел
вот клиент что говорит
Трассировка маршрута к 10.0.0.4 с максимальном числом прыжков 30
1 <1 ¬б 1 ms <1 ¬б router [192.168.0.1]
2 1 ms 1 ms 2 ms 85.XXXXXX
3 2 ms 1 ms 1 ms 85.XXXXXX
4 * * * Превышен интервал ожидания запроса

но суть все равно остается....
Цитата Сообщение от W_Jim Посмотреть сообщение
это же две разные сети
ну вот я и пытаюсь добиться что бы он тупо заворачивал на 10 сетку....в этой сетки (в 10) то же есть свой шлюз...но как это сделать ума не дам

Добавлено через 2 минуты
Цитата Сообщение от W_Jim Посмотреть сообщение
а это не /21 а /24
пусть даже и так в 10 сетку как трафик кинуть?
0
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
27.02.2014, 16:13 15
Цитата Сообщение от kycik Посмотреть сообщение
в 10 сетку как трафик кинуть?
C
1
sh ip route
в студию
0
kycik
0 / 0 / 0
Регистрация: 04.06.2013
Сообщений: 112
27.02.2014, 16:20  [ТС] 16
Цитата Сообщение от W_Jim Посмотреть сообщение
в студию
Код
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      85.0.0.0/32 is subnetted, 2 subnets
C        85.XXXXX is directly connected, Dialer1
C        85.XXXXXX is directly connected, Dialer1
C     192.168.0.0/24 is directly connected, GigabitEthernet0/2
      192.168.0.0/32 is subnetted, 1 subnets
L        192.168.0.1 is directly connected, GigabitEthernet0/2
0
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
27.02.2014, 16:22 17
Цитата Сообщение от kycik Посмотреть сообщение
S* 0.0.0.0/0 is directly connected, Dialer1
85.0.0.0/32 is subnetted, 2 subnets
C 85.XXXXX is directly connected, Dialer1
C 85.XXXXXX is directly connected, Dialer1
C 192.168.0.0/24 is directly connected, GigabitEthernet0/2
192.168.0.0/32 is subnetted, 1 subnets
L 192.168.0.1 is directly connected, GigabitEthernet0/2
а теперь делаем no sh на интерфейсе G0/0 и опять sh ip route в студию
0
kycik
0 / 0 / 0
Регистрация: 04.06.2013
Сообщений: 112
27.02.2014, 16:41  [ТС] 18
Код
S*    0.0.0.0/0 is directly connected, Dialer1
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/24 is directly connected, GigabitEthernet0/0
L        10.0.0.1/32 is directly connected, GigabitEthernet0/0
      85.0.0.0/32 is subnetted, 2 subnets
C        85.XXXXX is directly connected, Dialer1
C        85.XXXXX is directly connected, Dialer1
C     192.168.0.0/24 is directly connected, GigabitEthernet0/2
      192.168.0.0/32 is subnetted, 1 subnets
L        192.168.0.1 is directly connected, GigabitEthernet0/2
0
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
27.02.2014, 16:45 19
ок, а теперь traceroute 10.0.0.4 с cisco и с клиентского ПК в студию...
интерфейс при этом не отключаем...
0
kycik
0 / 0 / 0
Регистрация: 04.06.2013
Сообщений: 112
27.02.2014, 16:57  [ТС] 20
Код
#traceroute 10.0.0.4
Type escape sequence to abort.
Tracing the route to 10.0.0.4
VRF info: (vrf in name/id, vrf out name/id)
  1 85.XXXXX 0 msec 0 msec 4 msec
  2 85.XXXXX 0 msec 0 msec 0 msec
  3  *  *  *
  4  *  *  *
  5
такая же байда у клиента, он 10 кидает во внешку...

Добавлено через 7 минут
Код
#traceroute 10.0.0.4
Type escape sequence to abort.
Tracing the route to 10.0.0.4
VRF info: (vrf in name/id, vrf out name/id)
  1  *  *  *
  2  *  *  *
  3  *  *  *
  4  *
со статическим маршрутом выдает это....сейчас клиенты для того что бы к 10 сетки подрубиться меняют на статику свои ip со своим шлюзом и днс...
0
27.02.2014, 16:57
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
27.02.2014, 16:57

Перенаправление на другую страницу
Доброго времени суток всем. Нужно что бы после выполнения скрипта выполнялся переход на другую...

Перенаправление на другую страницу
привет всем. имеется страница с товарами и ссылка на удаление, При удалении автоматически...

Перенаправление на другую страницу
Подскажите как сделать перенаправление на другую страницу вместо этого что на скрине? &lt;?php ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru