Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.63/19: Рейтинг темы: голосов - 19, средняя оценка - 4.63
erohin-ae
0 / 0 / 0
Регистрация: 14.03.2014
Сообщений: 6
1

Cisco 851 - настройка интернета

14.03.2014, 11:26. Просмотров 3407. Ответов 12
Метки нет (Все метки)

Подскажите, как настроить интренет на cisco 851
провайдер дал ip адрес статический, маску, ip шлюз.
локальная сеть настроена.
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.03.2014, 11:26
Ответы с готовыми решениями:

Настройка маршрутизатора cisco 851
Здравствуйте.Помогите пожалуйста.Как настройкой cisco 851.Если можно по подробнее пожалуйста, я не...

Настройка NAT на CISCO 851
Добрый день. Никак не получается настроить NAT Система состоит из 2х роутеров (соответственно 2...

password recovery on Cisco 851
Проблема такая: есть cisco 851, на нее забыт пароль, необходимо восстановить. Подключился по...

Cisco 851 & Beeline
Добрый день. Помогите подружить сабж. Получаю на FE4 IP от DHCP, Virtual-ppp поднимается, но...

Cisco 851. Не работает. Switch порты
Случалась ситуация такая... стояла Cisco 851 K9, держала VPN канал. В WAN провод приходила соска...

12
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
14.03.2014, 11:30 2
Цитата Сообщение от erohin-ae Посмотреть сообщение
Подскажите, как настроить интренет на cisco 851
что конкретно у Вас не получается?
1
Jabbson
Эксперт по компьютерным сетям
3461 / 2504 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
14.03.2014, 11:34 3
Цитата Сообщение от erohin-ae Посмотреть сообщение
Подскажите, как настроить интренет на cisco 851
я думаю, что проблема в том, что нужно настроить трансляцию адресов
1
erohin-ae
0 / 0 / 0
Регистрация: 14.03.2014
Сообщений: 6
14.03.2014, 11:37  [ТС] 4
Я вообще не настраивал Cisco раньше.
Как настроить WAN для получения интернета

вот конфиг с настройками на данный момент:

Router#sh run
Building configuration...

Current configuration : 1015 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
dot11 syslog
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
dns-server 192.168.1.1
default-router 192.168.1.1
!
ip cef
ip name-server 77.88.8.8
!
username admin privilege 15 secret 5 $1$uWbB$ajgdPW1ephjyjHe2.REpC1
!
archive
log config
hidekeys
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
no ip address
shutdown
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip virtual-reassembly
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end


Я так понимаю, что нужно прописать настройки Fast ethernet 4 ip адрес внешний маску и шлюз.
и настроить связь локальной сети с сетью интернет
0
14.03.2014, 11:37
Konstantin®
132 / 128 / 21
Регистрация: 24.10.2013
Сообщений: 845
14.03.2014, 11:48 5
Цитата Сообщение от erohin-ae Посмотреть сообщение
нужно прописать настройки Fast ethernet 4 ip адрес внешний маску и шлюз
Верно понимаете.
Затем на этом интерфейсе выполнить
Bash
1
no shut
И далее как Вам уже советовали ранее
Цитата Сообщение от Jabbson Посмотреть сообщение
что нужно настроить трансляцию адресов
1
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
14.03.2014, 11:50 6
Цитата Сообщение от erohin-ae Посмотреть сообщение
Я так понимаю, что нужно прописать настройки Fast ethernet 4 ip адрес внешний маску и шлюз.
и настроить связь локальной сети с сетью интернет
в самом простейшем случае, если у Вас интернет приходит на interface FastEthernet4, то нужно сделать примерно так:
Код
conf t
int fast 4
no sh
ip add {ip адрес и маска, выданные провайдером}
exit
ip access-list stand NAT
permit 192.168.1.0
exit
ip nat inside source list NAT interface fast 4 overload
int fast 4
ip nat out
int Vlan 1
ip nat inside
exit
ip route 0.0.0.0 0.0.0.0 fast 4
end
вроде ничего не забыл...
2
erohin-ae
0 / 0 / 0
Регистрация: 14.03.2014
Сообщений: 6
14.03.2014, 11:56  [ТС] 7
ip route 0.0.0.0 0.0.0.0 fast 4
этим пунктом мы прописываем внешний шлюз?
0
W_Jim
122 / 122 / 17
Регистрация: 21.11.2013
Сообщений: 523
14.03.2014, 12:00 8
Цитата Сообщение от erohin-ae Посмотреть сообщение
этим пунктом мы прописываем внешний шлюз?
этим пунктом мы прописываем маршрут во внешку...

только у меня ошибочка в конфиге...
в конфиге acl...
нужно написать не
Цитата Сообщение от W_Jim Посмотреть сообщение
ip access-list stand NAT
permit 192.168.1.0
а
Код
ip access-list stand NAT
permit 192.168.1.0 0.0.0.255
2
Jabbson
Эксперт по компьютерным сетям
3461 / 2504 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
14.03.2014, 12:02 9
Цитата Сообщение от W_Jim Посмотреть сообщение
ip route 0.0.0.0 0.0.0.0 fast 4
не стоит делать маршрут указывающий на исходящий интерфейс для мультиаксес сетей
Код
ip route 0.0.0.0 0.0.0.0 {ip адрес шлюза, выданный провайдером}
2
erohin-ae
0 / 0 / 0
Регистрация: 14.03.2014
Сообщений: 6
14.03.2014, 12:19  [ТС] 10
ping пошел но только по ip.
так понимаю DNS не правильно прописан
0
Jabbson
Эксперт по компьютерным сетям
3461 / 2504 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
14.03.2014, 12:23 11
Код
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
no dns-server 192.168.1.1                 <<<<<
dns-server 8.8.8.8                        <<<<<
default-router 192.168.1.1
1
erohin-ae
0 / 0 / 0
Регистрация: 14.03.2014
Сообщений: 6
14.03.2014, 14:19  [ТС] 12
Спасибо за помощь!
0
Jabbson
Эксперт по компьютерным сетям
3461 / 2504 / 776
Регистрация: 03.11.2009
Сообщений: 7,940
Записей в блоге: 3
14.03.2014, 15:43 13
Цитата Сообщение от erohin-ae Посмотреть сообщение
Спасибо за помощь!
всегда пожалуйста
1
14.03.2014, 15:43
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.03.2014, 15:43

Слетел графический режим с CISCO 851
Решил я обновить Cisco 851, пошел делать все по мануалу, из одной из веток было написано удалить...

Cisco 851 как шлюз к двум ISP
Добрый день Есть ли какой-то вариант настройки этой модели для организации с двумя интернет...

Cisco C881 настройка SIP ALG через Cisco Configuration Professional
Cisco C881 настройка SIP ALG через Cisco Configuration Professional Есть маршрутизатор Cisco...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
13
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.