Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.58/12: Рейтинг темы: голосов - 12, средняя оценка - 4.58
sTARKj
0 / 0 / 2
Регистрация: 10.09.2012
Сообщений: 40
1

Настройка DHCP в Cisco, через маршрутизатор

29.04.2014, 16:49. Просмотров 2144. Ответов 11
Метки нет (Все метки)

Настройка DHCP в Cisco, через маршрутизатор


Подскажите как настроить промежуточные маршрутизаторы и можно ли вообще? На главном все установил по уроку http://findotvet.ru/nastrojka-cisco-dhcp/
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.04.2014, 16:49
Ответы с готовыми решениями:

Раздача DHCP через маршрутизатор (Cisco Packet Tracer)
Добрый день. Сеть в прикрепленной картинке. Кратко о настройках: часть слева - это 192.168.1.X;...

CPT - как настроить Cisco маршрутизатор (ip адреса, ftp, dns, dhcp, http, smtp)
Добрый день. Первый день в pt работаю, разобраться не могу. Для знающего человека сделать будет...

Настройка DHCP в Cisco packet tracer
Доброго времени суток форумчане. У меня проблема с сервером DHCP. Не получается настроить "сеть 2",...

VLAN на базе двух коммутаторов, настройка DHCP (Cisco Packet Tracer)
Добрый день. Нужна помощь по настройке, а точнее найти ошибку в настройке. Мною выполняется...

Cisco C881 настройка SIP ALG через Cisco Configuration Professional
Cisco C881 настройка SIP ALG через Cisco Configuration Professional Есть маршрутизатор Cisco...

11
Korax
Эксперт по компьютерным сетям
606 / 327 / 77
Регистрация: 20.04.2014
Сообщений: 895
29.04.2014, 19:40 2
http://www.cisco.com/en/US/docs/ios/.../htdhcpre.html
0
sTARKj
0 / 0 / 2
Регистрация: 10.09.2012
Сообщений: 40
30.04.2014, 19:22  [ТС] 3
спасибо

Добавлено через 14 часов 46 минут
все-таки мало что понимаю из информации по ссылке.....вот по этому уроку все сделал http://www.youtube.com/watch?v=GpWV4heSahA ,работает, но немогу сообразить, что прописать в 3 по счету маршрутизаторе....т.е. М1---М2---((М3))---ПК получающий адрес автоматом.
во втором маршрутизаторе из видео писал:






Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.0.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#int fa1/0
Router(config-if)#ip address 11.0.0.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ip helper-address 192.168.0.1
Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#net 192.168.0.0
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.0.1 (FastEthernet0/0) is up: new adjacency
Router(config-router)#net 11.0.0.0
0
Korax
Эксперт по компьютерным сетям
606 / 327 / 77
Регистрация: 20.04.2014
Сообщений: 895
30.04.2014, 22:01 4
При двух маршрутизаторах, на одном из которых запущен DHCP сервер, нужно на втором (где DHCP сервера нет) в настройках интерфейса, направленного ОТ DHCP сервера (т.е., к клиентам) задать:
ip helper-address address
где address - IP адрес того интерфейса первого маршрутизатора (т.е., с DHCP сервером), который направлен в сторону второго маршрутизатора.
т.е., в том видео, на 2-ом маршрутизаторе:
int fa0/1
ip ad 11.0.0.1 255.255.255.0
no sh
ip helper-address 192.168.0.1
0
30.04.2014, 22:01
sTARKj
0 / 0 / 2
Регистрация: 10.09.2012
Сообщений: 40
01.05.2014, 16:28  [ТС] 5
http://s1.ipicture.ru/uploads/20140501/SSl2zaSs.jpg - картинка.

Так и не удается добиться получения авто адреса через 3 маршрутизатор, не понимаю как его настроить. С двумя всё прекрасно работает, но как только добавляю 3, цепляю провода и пытаюсь настроить по аналогии второго маршрутизатора, то ничего не выходит. На всякий случай прилагаю архив с рабочими 2мя маршрутиз., если 3 удалить и соединить с коммутатором.

Так первый настраивал:
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no sh


Router(config)#ip dhcp pool 1
Router(dhcp-config)#network 11.0.0.0 255.255.255.0

Router(dhcp-config)#default-router 11.0.0.1
Router(dhcp-config)#exit
Router(config)#do sh ip int brief
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 192.168.0.1 YES manual up down

FastEthernet1/0 unassigned YES unset administratively down down

FastEthernet3/0 unassigned YES unset administratively down down
Router(config)#router eigrp 1
Router(config-router)#net 192.168.0.0
Router(config-router)#exit


Вот так второй настраивал:
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip address 192.168.0.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#int fa1/0
Router(config-if)#ip address 11.0.0.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ip helper-address 192.168.0.1
Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#net 192.168.0.0
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.0.1 (FastEthernet0/0) is up: new adjacency
Router(config-router)#net 11.0.0.0
Router(config-router)#

Ну и третий по аналогии второго пробовал:
Router(config)#int fa0/0
Router(config-if)#ip address 11.0.0.2 255.255.255.0
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#int fa1/0
Router(config-if)#ip address 172.168.0.1 255.255.255.0
Router(config-if)#no sh
Router(config-if)#ip helper-address 11.0.0.1
Router(config-if)#exit
Router(config)#router eigrp 1
Router(config-router)#ntnet 11.0.0.0
Router(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 11.0.0.1 (FastEthernet0/0) is up: new adjacency

Router(config-router)#net 172.168.0.0
Router(config-router)#net 192.168.0.0
Router(config-router)#
Router(config-router)#exit
Router(config)#interface FastEthernet1/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
0
Вложения
Тип файла: rar dhsp.rar (7.6 Кб, 7 просмотров)
Korax
Эксперт по компьютерным сетям
606 / 327 / 77
Регистрация: 20.04.2014
Сообщений: 895
01.05.2014, 21:06 6
У вас там клиент в сети 172.168.0.0.24, а dhcр пул - из 11.0.0.0/24
Если, клиент в 11-й сети (как я вашу схему изменил) - он адрес получит
Если клиент в 172-й сети - добавьте второй пул (или измените имеющийся - если измените, клиенты в 11-й сети останутся без адресов)
1
Вложения
Тип файла: zip dhcp.pkt.zip (12.1 Кб, 7 просмотров)
Korax
Эксперт по компьютерным сетям
606 / 327 / 77
Регистрация: 20.04.2014
Сообщений: 895
01.05.2014, 21:20 7
Да, и, конечно, на третьем маршрутизаторе:
ip helper-address 192.168.0.1
(это опять IP адрес маршрутизатора, где запущен dhcp сервер)
0
sTARKj
0 / 0 / 2
Регистрация: 10.09.2012
Сообщений: 40
02.05.2014, 08:58  [ТС] 8
А какая версия циско у вас? у меня 5.3.3.0019 и не совместимость выдает
0
Korax
Эксперт по компьютерным сетям
606 / 327 / 77
Регистрация: 20.04.2014
Сообщений: 895
02.05.2014, 10:29 9
CPT 6.0.1
0
Korax
Эксперт по компьютерным сетям
606 / 327 / 77
Регистрация: 20.04.2014
Сообщений: 895
02.05.2014, 10:36 10
Лучший ответ Сообщение было отмечено sTARKj как решение

Решение

Вот картинка.

Между двумя роутерами свич добавил - и к нему клиента прицепил.
Клиент адрес получит. Для обслуживания второго клиента (за третьим роутером) - как уже писал, добавьте еще один пул на dhcp сервере.
1
Миниатюры
Настройка DHCP в Cisco, через маршрутизатор  
sTARKj
0 / 0 / 2
Регистрация: 10.09.2012
Сообщений: 40
02.05.2014, 10:38  [ТС] 11
Большое спасибо
0
Korax
Эксперт по компьютерным сетям
606 / 327 / 77
Регистрация: 20.04.2014
Сообщений: 895
02.05.2014, 10:56 12
Пожалуйста

Да, имеет смысл почитать про dhcp-relay агент.
Не про то, как он настраивается в конкретном окружении (СРТ, живая циска или живые машины с общеупотребимыми осями), а про принцип действия.

Неплохое описание попадалось в майкрософтовском 2277 курсе (но там лаба по этому релей агенты с ошибкой была )

тут еще гляньте:
http://xgu.ru/wiki/Опция_82_DHCP
1
02.05.2014, 10:56
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.05.2014, 10:56

Настройка доступа к FTP через cisco PIX 506E
Приветствую всех участников форума. На границе между интернетом и локальной сетью стоит данный...

Маршрутизатор CISCO 877-K9
Маршрутизатор CISCO 877-K9 Настройки CISCO 877-K9 ? В общем вопрос такой, подключили интернет с...

Маршрутизатор cisco 881
Доброго времени суток! Пишу сюда с надеждой получить совет. У нас маленький офис. Интернет...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru