Форум программистов, компьютерный форум, киберфорум
Наши страницы
Cisco
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
woolf-234
0 / 0 / 0
Регистрация: 15.10.2014
Сообщений: 3
1

Cisco 1921 RDP

15.10.2014, 18:28. Просмотров 719. Ответов 5
Метки нет (Все метки)

Есть Cisco 1921 - настроил ее как роутер, все работает!
Уже неделю бьюсь и не могу настроить переадресацию порта, для RDP подключения.
Помогите пожалуйста, подскажите что не так в конфиги???!!!
Кликните здесь для просмотра всего текста

aaa new-model
!
!
!
!
!
!
!
aaa session-id common
!
ip cef
!
!
!
!
!
!
ip domain name 123.local
ip name-server 195.0.0.10
ip name-server 195.0.0.20
ip name-server 8.8.8.8
ip name-server 8.8.4.4
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921
!
!
username admin privilege 15 secret 5
!
redundancy
!
!
!
!
!
ip ssh version 1
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 30.0.0.239 255.255.255.0
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 10 interface GigabitEthernet0/0 overload
ip nat inside source static tcp 192.168.1.15 3389 GigabitEthernet0/0 3389
ip route 0.0.0.0 0.0.0.0 30.0.0.1
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0
exec-timeout 60 0
privilege level 15
password 7
logging synchronous
transport input ssh
line vty 1 4
exec-timeout 60 0
privilege level 15
logging synchronous
transport input ssh
!
scheduler allocate 20000 1000
!
end


P.S. Порт на локальной машине открыт!
При запросе через интернет (проверке порта через сайты которые предоставляют такую функцию) тоже пишет, что порт открыт.
Фаерволы отключены и стоит разрешение на подключение RDP?
Я хожу свободно по RDP по всей сети.
Но по подключение по РДП из интернета (города) не идет!
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.10.2014, 18:28
Ответы с готовыми решениями:

Cisco C881-K9 vs Cisco 1921
Здравствуйте, можете подсказать на сколько или во сколько процессор мощнее у 1821, чем у 881 ?? и...

Cisco 1921 VPN
Глупый вопрос задам наверно. Сразу извинюсь. Циску держу в руках первый раз. Имею Cisco...

Cisco 1921 IP NAT
Привет всем! Столкнулся со следующей проблемой: имеется маршрутизатор Cisco 1921 с прошивкой...

Cisco 1921 и GE порты
Добрый день. Пытаюсь настроить гигабитные интерфейсы на Cisco 1921, но про них ни слуху ни духу....

Cisco 1921 терплю бедствие
Здравствуйте. Не пинайте строго чайника, пожалуйста, но нужна помощь. Имеется роутер 1921, в g0/0...

5
cat_driver
57 / 48 / 3
Регистрация: 19.12.2013
Сообщений: 203
15.10.2014, 20:13 2
так пробовал:
C++
1
ip nat inside source static tcp 192.168.1.15 3389 30.0.0.239 3389 extendable
?
1
woolf-234
0 / 0 / 0
Регистрация: 15.10.2014
Сообщений: 3
15.10.2014, 23:06  [ТС] 3
Да, так тоже пробовал.

UPD: как случайно выяснилось RDP с улицы работает (чтоб они мне раньше об этом сказали, редиски!!!!)


RDP не работает в том случае, если я из локальной сети (192.168.1.хх) пытаюсь подключиться через улицу (30.0.0.239) к серверу (192.168.1.15).

Я понимаю, что можно забить и оставить все как есть, но хочется все донастроить!!
Что нужно прописать чтобы можно было при запросе из локальной сети на IP 30.0.0.239 попасть на сервер в локальной сети IP 192.168.1.15
0
Jabbson
Эксперт по компьютерным сетям
3482 / 2520 / 779
Регистрация: 03.11.2009
Сообщений: 7,953
Записей в блоге: 3
15.10.2014, 23:35 4
вот тут я по-моему по этому поводу писал.
0
woolf-234
0 / 0 / 0
Регистрация: 15.10.2014
Сообщений: 3
16.10.2014, 10:31  [ТС] 5
Jabbson все верно - в указанной теме поднимался интересующий меня вопрос.

Но!
У меня полноценная Cisco, по вашем-же словам тут все должно работать!
0
Jabbson
Эксперт по компьютерным сетям
3482 / 2520 / 779
Регистрация: 03.11.2009
Сообщений: 7,953
Записей в блоге: 3
16.10.2014, 19:59 6
да, должно, я даже написал как - NVI (ip nat enable) и строчка из моего поста с картинкой ip nat source ...
0
16.10.2014, 19:59
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.10.2014, 19:59

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

CISCO 1921/K9 вывести VLAN в Интернет
Добрый день! Прошу совета, и помощи в вопросе настройки CISCO 1921/K9. Я только начал что то...

Объединение сетей двумя тоннелями на Cisco 1921
Здравствуйте! Есть задача объединить две удаленных сети через мобильную и спутниковую связь. На...

Cisco 1921 - не могу раздать белые IP c интерфейса
Здравствуйте ув. специалисты и участники сообщества. Очень нужна ваша помощь, а то всю голову...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.